08-22-2016 11:02 AM
33 12
tools
  1. Windows Central Question's Avatar
    I've posted on this before, I'll post yet again - your site is SLOW. I know I don't have the most up to date PC, but Windows Central runs MUCH SLOWER than almost any other site I visit.

    It gets to the point where I have to wait so long I just give up and leave the site.

    Ironic.

    I enjoy the articles and comments, but I'd spend more time here if you site simply worked in a reasonable manner.

    It's not only ironic, it's ridiculous. You should be embarrassed.
    12-31-2015 11:37 AM
  2. James Falconer's Avatar
    @Pim - thanks for replying, and for your concern. Trust me, all concerns in this thread (and elsewhere) are very much important to us. Fixing any and all slowness issues are key for us here, but you're right, progress has been (ironically) slow.

    We can't do it without your (constructive) feedback though. Sometimes the smallest tip will help us solve a nagging problem.

    Thanks again!
  3. wolfee48's Avatar
    ^^^ This
    12-31-2015 11:45 AM
  4. libra89's Avatar
    Sadly, it's a hard experience without adblocker. :(
    RumoredNow and jhoff80 like this.
    12-31-2015 12:38 PM
  5. pallentx's Avatar
    Just came here to post about this. This site bogs down Edge and runs the CPU up 10-20% - and this is on a 6 core Xenon box.

    Also posting to the community is buggy. Often I cant get a cursor in the text field and things will be so slow that when I type, it leaves out letters.
    It seems like things got better for a while, but it has been unbearable lately. I'm not really one to run adblocker. If the site performance is bad, I just don't go there. I love the content here, but its getting harder to stay around.
    Kram Sacul, poit57 and jlangner like this.
    01-06-2016 04:04 PM
  6. jlangner's Avatar
    I have to say I almost have given up as well. The performance is pure ****. I tried downloading an edited hosts file and yes works great then you are screwed on clicking things from other sites, search engine, etc, and wth should I have to change my host file to use forums here. Pages disappear while viewing, cant click on quote 1/2 time, etc. Please fix.
    01-06-2016 05:32 PM
  7. pallentx's Avatar
    Almost completely unusable again today. I cant even type comments in threads because it drops letters while I type. I give up.
    02-01-2016 10:54 AM
  8. James Falconer's Avatar
    To everyone above - could you tell me which browser(s) you're using (along with version, and OS?)
    pkcable likes this.
    02-03-2016 09:26 AM
  9. tgp's Avatar
    To everyone above - could you tell me which browser(s) you're using (along with version, and OS?)
    I'm not one of the above, but I've complained about this site in other threads. In my experience, which browser you're using doesn't make much of a difference. What matters is whether or not you're using an ad blocker.

    We've been complaining about this for a long time now, and we all say that the ads are overpowering. The ads are the problem, not which browser/version/OS we're using.
    libra89 and ramyZgHR like this.
    02-03-2016 10:11 AM
  10. xandros9's Avatar
    Firefox 43.0.4
    Windows 10 Pro x64
    first-gen ThinkPad Yoga (internals are similar or identical to an i7 Surface Pro 3)

    I decided to turn off Ad-Block because I like Windows Central.

    Well, my experiment didn't last long.
    Firefox almost immediately locked up upon refreshing my New Posts search and opening another thread. (two tabs + Reddit, which is lightweight)
    I could kinda scroll and I see at least two auto-playing video ads.

    So after restarting Firefox I hit the New Posts button again. Firefox didn't hang so that's good.
    Whats bad is that scrolling was choppier than Fruit Ninja. (something like 2 frames/second?)

    Funnily enough I like how when logged out, it touts less ads as a perk for logging in/creating an account.

    Also worth noting that when I had a Windows Phone (Internet Explorer, 8.1 Update 1) last year, Windows Central was nigh unusable.
    02-03-2016 10:48 AM
  11. fpena911's Avatar
    Agreed. I often times have to reload the page several times and also get the error message from the browser that the page has crashed and it has to shut down the browser. Pretty frustrating...
    02-03-2016 12:34 PM
  12. ramyZgHR's Avatar
    Agree. Site is painfully slow due ads. I am using W10 with Edge, all up to date. Machine is Acer E1-522. Not the beast, but it shouldn't be like that.
    02-03-2016 01:31 PM
  13. bridder's Avatar
    In my experience, which browser you're using doesn't make much of a difference. What matters is whether or not you're using an ad blocker.
    Spot on, been thinking about posting on this very topic for quite some time but never bothered, visit the site less now to avoid the painfully slow loading and as xandros9 said below, around 2fps scrolling (If the browser doesn't crash). I don't use an adblocker in any of my browsers, my PC is a good one and it doesn't matter whether I use Chrome, Firefox, IE or Edge (they are all kept up to date really) it is such a frustrating experience. I realise the lights need to be kept on but whether through subscriptions or some other means the site surely needs to change.

    Lastly, the ads that automatically play sound are just plain rude and have the effect of slowing me down from 2 to 1fps, awful they are.
    02-04-2016 03:26 AM
  14. Pippa Pip's Avatar
    Use the mobile website on 81 on my 640. It is just awful. So slow. Plus the amount of ads! Ott! Seriously, it's to the detriment of the site.
    xandros9 likes this.
    02-06-2016 08:05 AM
  15. jlangner's Avatar
    Windows 10 up to date on a Surface pro 4
    Microsoft Edge 25.10586.0.0
    Microsoft EdgeHTML 13.10586

    This site runs so slow it is pathetic and I agree it is all the adds we are bombarded with.
    I use Notepad to type out my responses because the focus is constantly being stolen away from the reply box and keystrokes often go missing.
    In Firefox NoScript reports 63 scripts and 1 object forbiden and 5 that it allows thats a total of 69 it is no wonder this site slows to a crawl.
    If you could get the adds from stealing focus that would be a start.
    I would have given up on this site if I did not like the community here so much.

    This responce was typed in Notepad so I could post without pulling what out hair I have left.
    Basically same except SP3. Replying next to impossible. 5 seconds for what typed to show up
    .
    02-07-2016 08:18 AM
  16. jlangner's Avatar
    Also on SP3, gets very hot and fan to gear everytime get on. Seriously can the f$%#$% ads. I wouldn't click on one just for pain they cause me.
    02-07-2016 08:21 AM
  17. andrew-in-woking's Avatar
    I have an ASUS Taichi 21 with Windows 10 latest technical preview on it and I use Edge browser. The site is very slow and I find that it grinds to a halt completely if I have it open on more than two or three tabs. I often have to close Edge browser in task manager. Sometimes I get the "Stop script" option but even then I usually have to close the whole thing down.

    I had a production version of Windows 10 on the PC until recently and the performance was about the same, if not a bit worse.

    On Mobile (Nokia Lumia 1520) I have found it to be very slow and often hyper links are not actionable for some 10-30 seconds after the progress bar has indicated that the page has loaded. It does make for a very poor experience and I think a lot of (new) users would simply turn away after one experience like that.
    02-07-2016 08:38 AM
  18. ytrewq's Avatar
    Ditto.

    I'm using Windows 10. I have the same problems whether using Edge 25.10586 or Internet explorer 11.63.10586.

    It seems to be inconsistent. Sometimes trying to type a comment is so slow I give up. Other times, it works. (This time, it works.)
    02-09-2016 12:12 AM
  19. Kram Sacul's Avatar
    Same problem on Win 8.1 and IE11. The whole website is painfully slow with lots of stalling and pausing especially when trying to type something, even this post I'm writing now. It's godawful. Closing the tab and reloading the page usually fixes it but not for long. This is only website that does this. There's really no excuse.
    02-18-2016 10:48 AM
  20. poit57's Avatar
    Also posting to the community is buggy. Often I cant get a cursor in the text field and things will be so slow that when I type, it leaves out letters.
    I'm having the same exact experience. I've used Edge for about 95% of my web browsing since July. Usually, I only switch to Internet Explorer to print shipping labels from eBay. I was just posting in these forums for some help with a new phone, and I had to switch to Internet Explorer because half the letters and spaces I tried to type were not registering in the Edge browser.

    I have used many message boards from other websites in the Edge browser, but I've never experience this issue with any other website.
    03-05-2016 11:45 PM
  21. Bleser's Avatar
    Just wanted to echo concerns posted here. Typing his response is painfully slow as half the characters I type don't appear or appear ~3 seconds later. I'm running W10 Pro + Edge on a Core i7-4790K @ 4.0 GHz. Processing JavaScript shouldn't be this hard. Something is very, very inefficient in the way the site renders.

    I try to visit this site on my Surface 2 RT and give up within a few minutes. Useless.

    If I have to have an Ad Blocker to visit (make it functional), something is very wrong.
    920Walker and Kram Sacul like this.
    03-07-2016 08:59 AM
  22. wolfee48's Avatar
    It's not just Windows Central. All three run slow... Windows Central, iMore, and CrackBerry.


    W10
    Core - i7
    MS Edge
    07-27-2016 10:51 AM
  23. beman39's Avatar
    I have to agree with others that this site is horrible!!!!!!!!!!! and it is not adblocker because I'm using chrome with no AB and it is still stupidly slow! it is a bad running script!! you guys need to get ur **** in order or fire the webmaster! keeps crashing IE11 edge and chrome is just looping this is just horrible and shoddy website now
    wolfee48 likes this.
    08-01-2016 02:05 PM
  24. RobHalligan's Avatar
    Dittos. Way slower than any other site
    Edge. W10 Pro 1607. Core M5 with 16 GB RAM. CPU running at average of 30%.
    08-03-2016 08:37 AM
  25. Michael Alan Goff's Avatar
    The irony is I can type out comments and responses on my iPad Pro but not my Surface Pro 3. I have to click on the text field a good 5-7 times for they keyboard to come up on edge. One time does it for Safari on iOS.
    08-05-2016 10:19 AM
  26. Bobvfr's Avatar
    This has been an issue with this site for a long time, and I have to say without adblocker or the hosts file amendment the worst site I have come across, they of course suggest using the app, but when I am browsing, I am browsing not app-ing.

    I would never have even tried the hosts file change if it wasn't for how bad this site is.

    Having said that, with the hosts file and now with the latest adblocker extension it is fine.
    RumoredNow likes this.
    08-05-2016 11:14 AM
33 12

Similar Threads

  1. What is MS long-term strategy for Lumia?
    By davidD93 in forum Windows 10
    Replies: 4
    Last Post: 01-01-2016, 12:03 AM
  2. Windows 10 keyboard
    By Rakesh Rocky2 in forum Windows 10
    Replies: 0
    Last Post: 12-31-2015, 10:50 AM
  3. Outlook Mail and Calendar update available for all Windows 10 Mobile users
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-31-2015, 10:50 AM
  4. Microsoft brings its Power BI business intelligence software to Windows 10 Mobile
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-31-2015, 10:30 AM
  5. Is worth upgrading from 640 to 950?
    By chrisb1977 in forum Windows Phones
    Replies: 2
    Last Post: 12-31-2015, 08:08 AM
LINK TO POST COPIED TO CLIPBOARD