05-10-2016 02:12 PM
29 12
tools
  1. slivy58's Avatar
    Is it just me or do others have mega issues viewing/participating on the WC site (and other Central sites) via a browser, yes I know there is an app but sometimes working through a browser suits me better.

    Have multiple PCs/devices (W10) with most having i5s or better, 8 gigs ram or better, dedicated GPUs and main browsers used are IE, Edge and Firefox, everything on my devices are up-to-date, access to excellent high-speed internet so we can eliminate that as being a source of the problem, at home or work we encounter same scenarios.

    So right from the get-go site is slow to load then jitters, unresponsiveness, lagging and so on ensue immediately, if I want to respond to a post I'm usually met with the elusive "lag" in that pressing a key on the keyboard produces zero results, maybe once in eight tries and after a bit I resort to reloading page and trying again or closing browser, left clicking may return a result after 4-6 attempts. Scrolling, if we're lucky we'll get an action every 3 scrolls of the mouse wheel and then at other times it will take like ten, quite often putting the cursor on the right hand bar, left clicking and pulling down does little to invoke a response.

    Just cant see me being the only one experiencing this anomaly and would like to hear from others, any suggestions to minimize my issues or does the site need a massive overhaul? Cant think of another site that has ever been so problematic and frustrating to access/use, almost at the point where Im tempted to stop coming here which may make some happy LOL, so please, throw me a bone as I am starving ;).
    j1sh, xapache, Wevenhuis and 1 others like this.
    02-20-2016 03:02 PM
  2. slivy58's Avatar
    It is all the advertising causing all the lag and glitches. Some of us her use a custom host file to block all of it. I use it and now EDGE here behaves itself. you can get it here: A detailed guide for using the MVPS HOSTS file . Look Windows Central I am visiting and participating on your site and using a host file to BLOCK all of your ad's. This is the only site that made me NEED to do this, it was unbearable. The shear volume of video and focus stealing ads makes this site a nightmare with out some kind of intervention. I know you need the revenue to keep the site going but come on guys if you keep this up you will end up loosing in the end. Clean it up and a lot of us will quit blocking all the garbage tossed at us and you might just make more money. I don't mind seeing some ads on a site like this to keep it up but this site is out of control.
    Thanks Scott much appreciated, thought I was going nuts, well maybe I am, and you just confirmed my suspicions albeit they are obvious as hell just like the noise on ones face.

    Like you I don't have issue whatsoever with advertising when they causes small annoyances but it has escalated far beyond that now, couldn't even use my browser to reply to your response because it wouldn't allow me to type a single letter without becoming unresponsive, took over a minute to get the t & h registering in "thanks" so resorted to my phone to complete, all a step backwards if you ask me.

    I'll give your suggestion a go and we'll see where we end up, thanks again for your input.

    Any Mods willing too chime in and enlighten or educate us, interested in hearing your perspective on this matter, any proposed changes to the site to help alleviate the poor access/usability experience in the near future?
    02-20-2016 05:41 PM
  3. ven07's Avatar
    Are you both using Edge?
    Guytronic likes this.
    02-20-2016 05:48 PM
  4. slivy58's Avatar
    Are you both using Edge?
    I use IE, Edge and Firefox regularly, doesn't matter what PC/device or internet connection the result are same or very similar in each browser, appears the site has gotten considerably worse as of late.
    Guytronic likes this.
    02-20-2016 05:53 PM
  5. ven07's Avatar
    Weird.. I only get the glitches you mentioned when using Edge, but with Chrome (plus extensions) everything works just fine
    Guytronic likes this.
    02-20-2016 05:59 PM
  6. Guytronic's Avatar
    This is most likely not related.
    I've noticed in the past conflicting or out of date graphics drivers can have an effect on how browsers render.
    Edge gives me problems here usually after an update under W10.

    Yesterday EDGE was taking about 20 seconds to even start after a small update overnight.
    Rebooting the desktop straightened out the bug.
    ven07 likes this.
    02-20-2016 06:01 PM
  7. slivy58's Avatar
    Weird.. I only get the glitches you mentioned when using Edge, but with Chrome (plus extensions) everything works just fine
    Funny you mention Edge, in actuality it use to be the best but has succumbed to the same traits as the others, have never really used Chrome much, ever.
    ven07 likes this.
    02-20-2016 06:05 PM
  8. slivy58's Avatar
    This is most likely not related.
    I've noticed in the past conflicting or out of date graphics drivers can have an effect on how browsers render.
    Edge gives me problems here usually after an update under W10.

    Yesterday EDGE was taking about 20 seconds to even start after a small update overnight.
    Rebooting the desktop straightened out the bug.
    Like I said, all my devices are up-to-date including their graphics drivers, as well, same scenario on every PC/device which amounts to 7 that get used regularly, same browsers on all w/W10 64-bit home or pro.
    Guytronic and ven07 like this.
    02-20-2016 06:11 PM
  9. ven07's Avatar
    Funny you mention Edge, in actuality it use to be the best but has succumbed to the same traits as the others, have never really used Chrome much, ever.
    Yea I'm trying to quit Chrome lol As soon as the Edge teams adds extension support, I'll be using Edge full time
    Guytronic likes this.
    02-20-2016 06:18 PM
  10. Guytronic's Avatar
    If it weren't for having the slowdowns on more than one PC I'd point to stubborn malware.

    I can move this thread to "help and feedback" so the site administration can address if you'd like.
    ven07 and Laura Knotek like this.
    02-20-2016 06:26 PM
  11. Laura Knotek's Avatar
    I don't use Edge. I use Chrome and Firefox, but I always run uBlock Origin to make this site usable on my PC.
    ven07, slivy58, Guytronic and 1 others like this.
    02-20-2016 06:46 PM
  12. slivy58's Avatar
    If it weren't for having the slowdowns on more than one PC I'd point to stubborn malware.

    I can move this thread to "help and feedback" so the site administration can address if you'd like.
    Can assure you that there's no malware or anything of the like on any of my PCs, take pride in the fact that for many moons they've been bug free.

    Not sure moving will be worthwhile but if one doesn't try guess we will never know eh, can't imagine those in charge aren't aware of some of the problems mentioned as these aren't very good at masking themselves.
    Last edited by Elky64; 02-20-2016 at 09:20 PM.
    Laura Knotek and ven07 like this.
    02-20-2016 07:50 PM
  13. slivy58's Avatar
    I don't use Edge. I use Chrome and Firefox, but I always run uBlock Origin to make this site usable on my PC.
    Thanks Laura, just don't understand though why the makeup of the site has to be such that it causes horrendous problems for many, advertising at the cost of usability in the way I'm experiencing it just doesn't make sense. The time spent getting my tasks done leaves no room for viewing advertisements, but then I guess all that matters to those companies is that they have a presence on the site.

    Update:
    Went with your suggestions Laura and installed Chrome along w/uBlock Origin and uBlock for Firefox, its night and day compared to before (so far) and not sure why I didn't think of it sooner, thanks to everyone for their help/suggestions as it is much appreciated.
    Last edited by Elky64; 02-21-2016 at 12:33 AM. Reason: Update
    Laura Knotek likes this.
    02-20-2016 09:07 PM
  14. ytrewq's Avatar
    In terms of the lag problem when typing and sometimes keystrokes not registering at all:

    I have the same problems on all of my PCs (four), whether using IE, Edge, or Chrome. To give you a sense of how bad it is, I will re-type this line and NOT go back and fix the missed keystrokes:

    I have the same probms on all ofCs four), wheter using I, Edge, or Chrome. To give you a sense of how b it is, I will re-type this le and NOT go back and fix the mssed keystrokes.

    That's a pretty typical experience in terms of how many keystrokes get missed for me on WC. I have no problems at all on other forums.

    I'm pretty close to abandoning Windows Central. This has been going on too long, and it ruins the enjoyment of the site.
    tgp and xapache like this.
    02-22-2016 01:50 PM
  15. vogliadicane's Avatar
    agree, site is almost unusable since a long time (Win 8.1 Firefox and other browsers).

    It is TOO much ads, which make it freeze completely sometimes. Having opened another tab with this site means "just quit this site, you can anyways NOT continue with it".

    Tabs are also almost always reloading something. Honestly this is really too much and only annoying.
    03-04-2016 01:03 PM
  16. brhooma's Avatar
    uOrigins is working fine on every site I use apart from this one. I'm subscribed to almost all the lists but the ads are still there.
    The ads are still there, but if I click on any of them it directs me to the 'website refused connection' page.
    On Windows, I just used 'block elements' option to completely get rid of the ads. But android doesn't have such feature so I was wondering how can I block ads on the mobile website including those annoying MS Top Charts.
    03-17-2016 11:17 PM
  17. Laura Knotek's Avatar
    uOrigins is working fine on every site I use apart from this one. I'm subscribed to almost all the lists but the ads are still there.
    The ads are still there, but if I click on any of them it directs me to the 'website refused connection' page.
    On Windows, I just used 'block elements' option to completely get rid of the ads. But android doesn't have such feature so I was wondering how can I block ads on the mobile website including those annoying MS Top Charts.
    For your Android, you can use Firefox, which supports uBlock origin. You can also use the Windows Central Android app or Tapatalk for the forums.
    Guytronic likes this.
    03-17-2016 11:26 PM
  18. Wevenhuis's Avatar
    I can confirm that from windows 10 build 14279 and higher on Edge build 34.14279.1001.0 that there is something wrong with the whole windows central website. There is too much flash content on the site, which is causing issues with navigation and scrolling of the website. I’m even getting regular popups telling me that windows central is timing out due to flash problems. Not sure what specific flash issues there are, but it is consistent. Even typing in comment fields or accessing my account is almost a next to impossible task to do in Edge. It reminds me very much of similar issues I’m encouting with IE11 in windows 8.1. It reminds me very much a return of an old problem, almost feels like the return of old internet explorer gltiches. The strange thing though is that up till now only windows central seems to have a hard time in Edge. In IE11 I also had issues withs sites like engadget, the verge and pocketnow, but these sites seem to work relatively well in Edge. But the difference in performance between windows central and other sites is noticeable in Edge to the point that windows central website has become dysfunctional in Edge in windows 10, alsmost to the point that its better to use the windows central app and not use the windows central website at all. It even took me a couple of refreshes to get to this forum thread via the website in Edge. I think windows central should do something about toning down the flash content for a more glitchfree browsing experience in Edge or consider a collaborative feedback to the Edge team in winodws 10 to do something about their website flash issues. Good luck Windows Central. Great site, but it is not working well now in Edge for windows 10.
    RumoredNow likes this.
    03-19-2016 02:02 PM
  19. Wevenhuis's Avatar
    Updated to build 14295.1. Edge still seems to give windows central a hard time. Apparently there is so much flash on the windows central website that I'm regularly getting a crashed flash warning in 34.14295.1000.0. It's only windows central though. I'm not having issues with other sites like the Verge, Engadget, Winbeta or Pocketnow or other sites. The main behavioral problems are that its next to impossible to use the comment system. I have to type very slow and do multiple page refreshes or copy-past text from word. Article load is usually not a problem.Ads take forever and the pageload often fails to complete loading. Lastly it is very difficult to navigate the forum. Links seem to take many seconds to load pages and also here commenting in textboxes is deadslow. Selecting textboxes to type on also fails regularly, even after F5 a couple of times. It is not the experience it used to be compared to the early days of Edge. Stil feels like internet explorer 11. Hope this info helps to improve Edge and the windows central website.
    04-06-2016 03:50 AM
  20. XToro's Avatar
    It's funny, but I never realized that there were issues with PC's as well. I thought it was only on mobile browsers! I'll admit that all my PC's and my laptop run Linux and I use Chrome with an ad blocker, which seems to be why I've never had problems except when using my phone. I have Windows 10 installed on all my computers as a dual-boot, but only to play a couple of games. My day-to-day use and all my browsing is in Linux. No ads, and can't get a virus, so, yeah. You can also get ad blockers in Chrome on Windows, and I think Firefox as well. I recommend AdBlock Plus. It's free and I see zero ads, ever, including those YouTube video ads. Now we need ad blocking on Windows phones as well! It's my phone and my internet connection, and I should be able to block ad sites if I want to.
    04-09-2016 02:21 AM
  21. xapache's Avatar
    No what is really funny is how the Windows Central guys - who are usually very responsive - are quiet reference these problems. I have completely left the site and have moved the app. The app, thankfully, isn't plagued by all of this garbage (yet) and with the new version it is actually quite good.

    Sorry guys, no revenue for you. You can certainly have advertisement - complete understandable - but when you do advertisement this poorly you will not retain users. SEE ABOVE all of the remarks to the negative.

    How about you do a survey on performance of your website.
    04-15-2016 08:37 PM
  22. RumoredNow's Avatar
    ...what is really funny is how the Windows Central guys - who are usually very responsive - are quiet reference these problems...
    Just for the record... 3 different Site Volunteers have replied in this thread for a total of 7 posts previous to this comment. So the quote I made is from post #21... 7 out of 21 = a 33% participation.

    It is a fairly widely acknowledged issue. We have been advised that alternate methods are being debated at the highest levels of Mobile Nations. No further updates have come as of yet...

    FWIW, this football has been kicked around a lot and many replies from volunteers and even our Community Manager are on record.

    I don't know what else to advise in this regard.
    04-16-2016 12:13 PM
  23. MatsuDano's Avatar
    Any update on a decision by the powers that be? I'm just about ready to throw in the towel :/
    05-06-2016 12:15 PM
  24. James Falconer's Avatar
    I'll jump in here real quick.

    First off, THANK YOU for all that have reported issues. Trust me, we take all of these reports very seriously and want to fix things as soon as we possibly can.

    Second, whenever possible please report all the details you can on an issue. Don't tell us 'the site is slow'. Give us more details (many of you already are). Which browser? Which OS? Which device? The more you can give us the better, because we can try and recreate the problem. Once we recreate the problem we can fix.

    Third, there's no 'decision' to be made here, other than trying to fix all the things as soon as we can. To that end, feel free to ping me direct and provide as much data as you can that may help our tech team. My email is james@mobilenations.com and I totally welcome you to reach out.

    Can't do this without your help :)
    RumoredNow likes this.
    05-06-2016 12:52 PM
  25. cracgor's Avatar
    I had the same issues until I switched to Chrome and installed adblock. The site would just cause my PC to burn too hot.
    05-06-2016 03:02 PM
29 12

Similar Threads

  1. We hope Windows Mobile isn't dying.
    By Turikk95 in forum The "Off Topic" Lounge
    Replies: 28
    Last Post: 02-26-2016, 07:42 PM
  2. Hands-on with Alcatel Plus 10: Windows 10 and LTE on a 10.1-inch two-in-one
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-20-2016, 01:11 PM
  3. Alcatel announces the Plus 10 2-in-1 Windows 10 tablet
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-20-2016, 01:11 PM
  4. Windows 10 Mobile build 14267 brings Skype's 'Moji' to the Messaging app
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-20-2016, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD