1. XToro's Avatar
    So I had this issue before with the WC site being painfully slow, taking forever to load, and clicking on something takes forever to get to another page. My old 920 with WP 8.1 was slow and I stayed away from this site. I upgraded to W10M on my 920, and tried again, still slow as molasses. Now on my L650 it's just as bad. It's also horrendous on my wife's L830.

    What gives? Shouldn't this site be OPTIMIZED for Microsoft browsers? By the way, on my laptop, it works just fine in Linux using Chrome browser. But I also have an AdBlocker installed so I'm not sure if it's just the ads or what.

    Sadly, at this point, I completely avoid this website when I'm browsing from my phone. If I'm googling something and end up accidentally on a WC forum thread, I immediately hit the back button to try another link. I don't even bother trying, it's too frustrating.

    I've seen particular posts regarding different browsers and whatnot, but I just wanted to post saying that this site has issues with ALL Microsoft mobile browsers, IE AND Edge. Please fix. It's been like this for months and months. Surely a Windows site should work well from any Microsoft product!
    jijesh babu likes this.
    04-09-2016 01:53 AM
  2. jijesh babu's Avatar
    Even i am also met with a problem. If we click on a link in browser it stuck for a moment not finding loading..
    04-09-2016 02:09 AM
  3. Tom Kaminski's Avatar
    So I had this issue before with the WC site being painfully slow, taking forever to load, and clicking on something takes forever to get to another page.
    Do you find it slow in the forums, (http://forums.windowscentral.com), homepage (Windows Central | News, Forums, Reviews, Help for Windows Phone), or articles (My first 24 hours with Microsoft HoloLens and awesome things I learned | Windows Central), or all of them?
    04-09-2016 11:53 AM
  4. James Falconer's Avatar
    @Xtoro ^^^?

    Any feedback would help! Thanks!
    04-11-2016 12:21 PM
  5. cnjvh's Avatar
    Ads. Using adblock is the only thing that makes it usable. You'll be out of luck with a Windows mobile device.
    04-11-2016 01:12 PM
  6. XToro's Avatar
    Sorry for the slow reply. It's slow everywhere. The initial page display is a little slow, but the progress loading bar never reaches 100%, it just sits at around 90-95%. Scrolling leaves blank white spaces that only display content when I stop scrolling. But the worst is touching links and nothing happens. It takes a minimum of 10 seconds for the browser to react to clicking a link. I end up touching a link over and over, then zooming in and trying again to make sure I touched it, and then just wait, and wait, and wait.... Sometimes it eventually goes, and sometimes nothing happens.
    04-13-2016 11:18 AM
  7. gwinegarden's Avatar
    It's absolutely brutal on my S2.
    04-18-2016 09:01 AM

Similar Threads

  1. How to carrier unlock (activate) on Sprint
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 09-18-2017, 10:11 PM
  2. Has tap to pay on NFC always been in windows 10 mobile
    By buffalosolja in forum Windows 10 Mobile
    Replies: 54
    Last Post: 04-25-2016, 09:10 AM
  3. Does the Lumia 650 do T-Mobile Wi-Fi Calling?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 04-09-2016, 11:04 PM
  4. Windows Device Recovery Tool will not open on my Surface 3, why?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-09-2016, 02:05 AM
  5. #OneCast Ep 13: Winding down Build 2016, Holographic futures, PC games on Xbox One
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-08-2016, 08:30 PM
LINK TO POST COPIED TO CLIPBOARD