1. eddlang's Avatar
    Lumia 640 dual-SIM, 10586.494

    Your website is very unresponsive in edge. When I open a page it seems to load in 10-15 seconds, which is fine, but the problem is that it actually is still loading in the background and does not respond when I tap on a link at all. I have to wait for about 4-5 minutes before I can open an article/link.

    Also, when I stay on a page for too long, say when I'm reading an article, the page freezes after a few minutes (I cannot scroll, open links, etc.) Refreshing usually doesn't work. I have to load the whole page from scratch. (the page freezes, not edge itself.) It seems that both the desktop and mobile versions are affected.

    It's been like this for as far as I can remember. It has made navigating the website an utter pain.

    P.S. I've cleared cache, history, etc. no change.
    P.S.2. Only a small number of websites that I regularly visit behave like this. Most are fine.
    Last edited by eddlang; 07-18-2016 at 10:34 PM.
    07-18-2016 05:57 PM
  2. cracgor's Avatar
    The easiest fix is to use a web browser with extension support and install an adblocker. The problem has to do with whatever ad software they use on this website.
    07-18-2016 06:16 PM
  3. xandros9's Avatar
    It's been like that since WP8.1 if not earlier.

    And I'm not sure about the ads. While they make the site unusable on desktop, I've been able to use the site on my iPhone and not-at-all on any WP.
    07-18-2016 09:20 PM
  4. thron's Avatar
    I have ads blocked on my 640 and the site/forum is usable on Edge or UC Browser without issues. The Windows 10 app is an entirely different story.
    07-18-2016 11:59 PM
  5. Ivanildo Alves da Silva's Avatar
    Update: 10.0.14393.0 - Erro 0x80310027
    07-19-2016 04:48 AM
  6. eddlang's Avatar
    I have ads blocked on my 640 and the site/forum is usable on Edge or UC Browser without issues. The Windows 10 app is an entirely different story.
    How did you block ads on your phone?
    07-23-2016 11:08 AM
  7. thron's Avatar
    Jailbreak it for Full system access (FS Access)
    07-23-2016 03:07 PM

Similar Threads

  1. What do you do with your phone's NFC?
    By hardywang in forum Windows 10 Mobile
    Replies: 45
    Last Post: 09-09-2016, 02:34 AM
  2. Replies: 1
    Last Post: 07-20-2016, 03:02 AM
  3. Does Showing the Color Black on L950 Screen Use Power?
    By RobHalligan in forum Microsoft Lumia 950
    Replies: 3
    Last Post: 07-18-2016, 07:16 PM
  4. Can I recover deleted history on a Windows 8.1 Nokia Lumia 635?
    By Windows Central Question in forum Nokia Lumia 635
    Replies: 1
    Last Post: 07-18-2016, 05:15 PM
  5. Why is my location on my pc not working?
    By bayharborbucher in forum Windows 10
    Replies: 1
    Last Post: 07-18-2016, 04:10 PM
LINK TO POST COPIED TO CLIPBOARD