1. tomg1951's Avatar
    Your web site detects that I am using an Ad Blocker but it is incapable of detecting that I have Windowscentral.com "white listed" so each day I get this annoying message asking me to disable my ad blocker. It would be great if the detection method was also capable of seeing if it is white listed. Whew - - I feel so much better now!

    PS: Great web site - I love all the content.
    aximtreo likes this.
    03-24-2017 12:14 PM
  2. cnjvh's Avatar
    And as of today if I proceed past the "Ad blockers make us sad" page I get nothing but a white screen. If I turn off my ad blocker everything is fine. Windows Central appears to now be blocking all access to browsers with an ad blocker. Fortunately there are other site out there I can use to get my Windows news.
    03-24-2017 01:04 PM
  3. jmshub's Avatar
    This thread has been moved to an appropriate forum...
    As per this advice: Who Should Post in Ask a Question? WC members are free to post in all areas of the board. Please use Ask a Question only for time critical help issues that affect the immediate functionality of your device.
    Guytronic and RumoredNow like this.
    03-24-2017 01:07 PM
  4. jmshub's Avatar
    @tomg1951 My guess is that you're white listing windowscentral.com, but there may be other sites pushing content that is causing your error message.

    Try adding mobilenations.com to the white list as well. That may solve your problem.
    Guytronic, RumoredNow and aximtreo like this.
    03-24-2017 01:09 PM
  5. tomg1951's Avatar
    Thanks for the input - I just added the other and will give that a try.
    jmshub likes this.
    03-24-2017 05:07 PM
  6. tomg1951's Avatar
    thank you - duly noted.
    03-24-2017 05:09 PM
  7. Ryujingt3's Avatar
    I don't want to piggyback this topic but, seeing as nobody replied to mine, why is the forum section of this site pretty much unusable if you use an ad blocker? With ad blocker plus enabled I cannot sign in to the forums (menu doesn't pop-up when you hover the mouse cursor) and, when I am signed in, with an ad-blocker enabled, I cannot access the notifications menu, mouse-over does nothing.

    Can't the site just add a paid service for members to browse ad free?
    aximtreo likes this.
    04-01-2017 06:40 AM
  8. tgp's Avatar
    why is the forum section of this site pretty much unusable if you use an ad blocker? With ad blocker plus enabled I cannot sign in to the forums (menu doesn't pop-up when you hover the mouse cursor) and, when I am signed in, with an ad-blocker enabled, I cannot access the notifications menu, mouse-over does nothing.
    It works fine for me. I get the "adblocker makes us sad" every once in a while, but I close it and carry on as usual. I primarily use Chrome, on both Windows and Mac, with ABP.
    RumoredNow likes this.
    04-01-2017 07:07 AM
  9. RumoredNow's Avatar
    It works fine for me. I get the "adblocker makes us sad" every once in a while, but I close it and carry on as usual. I primarily use Chrome, on both Windows and Mac, with ABP.
    Ditto for me with AB+ on Iron which is chromium based.
    @Ryujingt3 what browser are you using?
    04-01-2017 09:19 AM
  10. Ryujingt3's Avatar
    Ditto for me with AB+ on Iron which is chromium based.
    @Ryujingt3 what browser are you using?
    I am using Edge. But I solved the issue and found something interesting too. For Edge there is an Adblock extension and an AdBlock Plus extension. If you use Adblock, this site pretty much breaks and cannot be used.

    If you use Adblock Plus the site is much more functional, whilst also blocking ads too.

    Long story short, if you use Edge you need the Adblock Plus extension for this site.
    RumoredNow and aximtreo like this.
    04-02-2017 06:38 AM
  11. Penny_1's Avatar
    I'm using AdBlock Plus on Chrome for Mac. Most of the time, with the ABP enabled, I can click "close" on the "ad blocker makes us sad" screen and proceed to the content. Sometimes, like today, it will just keep kicking me back to that screen.

    Unfortunately, Windows Central, this website is borderline unusable for me without the AdBlocker. 850MB of ram usage for this tab alone, with CPU usage ranging from 30-120 (!) and my laptop fan starting to sound like a turbine.

    For reference, this is a 2012 MacBook Pro, Core i7, 16GB Ram, SSD.

    Sorry, but other than this post, I'm simply not going to use this site when I can't have ABP on, OR until this site becomes usable with ABP off.
    slivy58 likes this.
    05-16-2017 02:59 PM
  12. slivy58's Avatar
    I'm using AdBlock Plus on Chrome for Mac. Most of the time, with the ABP enabled, I can click "close" on the "ad blocker makes us sad" screen and proceed to the content. Sometimes, like today, it will just keep kicking me back to that screen.

    Unfortunately, Windows Central, this website is borderline unusable for me without the AdBlocker. 850MB of ram usage for this tab alone, with CPU usage ranging from 30-120 (!) and my laptop fan starting to sound like a turbine.

    For reference, this is a 2012 MacBook Pro, Core i7, 16GB Ram, SSD.

    Sorry, but other than this post, I'm simply not going to use this site when I can't have ABP on, OR until this site becomes usable with ABP off.
    Haven't been visiting site much lately with this just becoming evident to me yesterday. Out of all the sites I've ever frequented Mobiles Nations has been the only one forcing me to implement an ad blocker.

    In the past, no matter what the device specs, it was just so painful to use w/o a blocker. No plans to test this out again, it'll either work w/blocker enabled or I'll just keep my distance... Other than the occasional glance on my mobile devices via an app.

    Does seem to work if you disable blocker, visit site then re-enable, how long before "we're sad" rears it's ugly head again is anyone's guess... Finding closing out browser will reinitiate sometimes requiring one to go through motions again, or it does in my case.
    Last edited by Elky64; 05-17-2017 at 10:02 AM.
    05-17-2017 09:44 AM

Similar Threads

  1. Your favorite Microsoft product of all time?
    By James Falconer in forum The "Off Topic" Lounge
    Replies: 23
    Last Post: 03-28-2017, 06:01 AM
  2. Exchange server email settings out of date
    By dadford in forum Ask a Question
    Replies: 1
    Last Post: 03-24-2017, 11:59 AM
  3. PC water-cooling project part three: Completing 'the Leviathan'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-24-2017, 08:10 AM
  4. Mass Effect: Andromeda tips and tricks to get more from the game
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-24-2017, 06:40 AM
  5. How to use Windows 10 File History to back up data
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-24-2017, 06:10 AM
LINK TO POST COPIED TO CLIPBOARD