The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
04-15-2016 03:06 AM
35 12
tools
  1. DavidinCT's Avatar
    Hey all Pebble/Windows Phone users.

    I noticed today that the Pebble app was updated a few days ago. It says last updated on 3/25.

    I hope they updated it for the Pebble Time. After owning a Pebble 301BL for about 2 weeks now I love it and the BIG factor compared to other smartwatches is the 7-10 battery life. I put it on a Monday and don't bother thinking about it till the next weekend. Pretty awesome.

    I tend to pull out my Windows Phone a lot less, as all emails, texts, phone calls, all come to the pebble, on emails it will show From/to, and about first 7-10 lines of the email, ENOUGH to tell you if you need to pull your phone out.

    The Pebble time has a microphone now never mind a e-ink 64-color display with the same battery life.

    Here is the updated app, you need to sideload it, I have not done it yet but, I will be in a little while...
    Pebble Notifications | Windows Phone Apps+Games Store (United States)
    03-30-2015 06:53 PM
  2. DavidinCT's Avatar
    Installed, No real changes that I noticed...

    1. It asked if you can run in the background...
    2. You need to select your apps if you want to see notifications from it (if you did it in the last build you will need to do it again)

    It didn't fix my issue every time a notification comes in, it's telling me that "You need to update your phone app to 2.0 or higher". (waiting for a fix to be put up on pebblebits.com)
    03-30-2015 08:16 PM
  3. Buenri's Avatar
    Previous message:

    Hi, I have the same problem with this v2.0 message, if you find a way to solve it, please share it.

    Thanks!

    Update:
    Ok so I already fixed it thanks to a custom firmware from MaryasinS. Now got a Pebble Steel, with all notifications, and updated to 2.9.1.

    Thanks to all the community to make this possible!
    Last edited by Victor Garde Escriche; 06-30-2015 at 05:38 AM.
    06-29-2015 07:30 PM
  4. Buenri's Avatar
    So, at last after surfing a lot the web I managed to solve the issue with a custom firmware developed by MaryasinS, so now I have the Pebble Steel working with 2.9.1 version and receiving all notifications from my phone (Lumia 930). Just clarify that it is normal to not maintain bluetooth connection as the Pebble notification App connects with the watch every time it needs, which means everytime there is a notification to send.

    Great work from the community and Microsoft to give us this unofficial App, despite of having to side load it.
    Penguwin likes this.
    06-30-2015 04:19 AM
  5. Roderick Laird's Avatar
    Installing windows phone 10 seems to break the app... it simply will not load for me... Do I need to "re-sideload" it perhaps?

    I have also entered the "stupids" domain as I cannot work out now how to get the app onto my desktop to side load it in any case. (I previously downloaded from a direct link)

    sigh

    Rod
    07-08-2015 09:35 PM
  6. DavidinCT's Avatar
    Installing windows phone 10 seems to break the app... it simply will not load for me... Do I need to "re-sideload" it perhaps?

    I have also entered the "stupids" domain as I cannot work out now how to get the app onto my desktop to side load it in any case. (I previously downloaded from a direct link)

    sigh

    Rod
    When I upgraded to 10166 today, it would not load, it would open, then just close. So I uninstalled it and re-installed it (using the 8.1 SDK), It loads now, connects to the pebble but, It will not load the app list it just hangs on "Loading Applist".

    I wonder if it will pull down email still to my Pebble, going to play with it but, this sucks because I lose other app notifications if cant select them.

    Always something Isn't it ?

    Edit: Confirmed Email is working going to my Pebble but, nothing else :(
    07-12-2015 11:08 AM
  7. DavidinCT's Avatar
    Now that the change in the Marketplace, you cant download apps directly any more but, changing country you can DOWNOAD them manually :) (tricky to figure out)

    This app was updated on 7/11/2015 so just about a month ago, and newer than any of us have...

    Download here... (go to the bottom of the page and download/manuall install or Descargar e instalar manualmente )

    https://www.windowsphone.com/es-ni/s...2-067e550b8d7f

    I have not updated my phone Yet but, will in a little bit... so updated again !

    Edit: No change, same version 1.1.0.13 (to tell, extract the app, in the AppxMetadata folder open the AppxBundleManifest.xml).

    I have 1.1.0.11 and 1.1.0.13 in my archive. Using 1.1.0.11 right now with no issues, I had minor issues with 13 but, was able to fix them.
    Last edited by DavidinCT; 08-11-2015 at 04:56 PM.
    Penguwin likes this.
    08-11-2015 01:53 PM
  8. Moskus's Avatar
    Does this app work on Win10M?
    08-27-2015 03:32 AM
  9. DavidinCT's Avatar
    Does this app work on Win10M?
    Yes... On 10512...
    08-30-2015 07:57 PM
  10. MMissionary's Avatar
    Tried downloading from link but it says I can't. Fix?
    08-30-2015 08:02 PM
  11. Penguwin's Avatar
    Tried downloading from link but it says I can't. Fix?
    I tried downloading it as well with no luck either.

    The app does not appear to be public yet. I don't know exactly how beta apps work on Windows Phone, but it looks like you have to be invited to download it first or at least be on some authentication list.

    I didn't see any way of contacting the developer, so if anyone has any ideas... We'd love to hear them :) .

    Any way to sideload this perhaps?
    08-31-2015 02:15 AM
  12. Moskus's Avatar
    Here's the direct link: http www windowsphone com/es-ni/store/app/pebble-notifications/fc6a5eec-593c-47b9-8772-067e550b8d7f/xap?apptype=regular
    (I'm not allowed to post links yet :( )

    ... and Yes, It's working great on 10512. :)
    Penguwin likes this.
    08-31-2015 02:33 AM
  13. DavidinCT's Avatar
    Here's the direct link: http www windowsphone com/es-ni/store/app/pebble-notifications/fc6a5eec-593c-47b9-8772-067e550b8d7f/xap?apptype=regular
    (I'm not allowed to post links yet :( )

    ... and Yes, It's working great on 10512. :)
    I can also confirm this, working with my Pebble Steel. It's working fine for the most part on 10512. The Version linked above is 1.1.0.13 and that is the newest version available.

    Wish someone here worked for Microsoft and had official access. If you look at the first link on the page, it gives an internal beta for Microsoft employees and gives a link to.

    https://www.yammer.com/microsoft.com/notes/1362520

    And with out a Microsoft email we can't get in, would love to see if there was any notes or testing of features for it.
    09-01-2015 07:53 AM
  14. Moskus's Avatar
    I take it back! It's not working like I want it to.

    The list of apps keep resetting itself, so I went back to the "original" (the one first linked to here on Windows Central). That appears to work just like the new one, except the app list is kept.
    09-01-2015 08:06 AM
  15. DavidinCT's Avatar
    I take it back! It's not working like I want it to.

    The list of apps keep resetting itself, so I went back to the "original" (the one first linked to here on Windows Central). That appears to work just like the new one, except the app list is kept.
    What link are you talking about ? I want to see what version your using ?

    I saw that problem too but, If you go in an add them (DO NOT UNSELECT anything) and go back a screen, then close the app, it seemed to stick, as long as I didn't go back into it...

    I do see some funkiness with it, what I mean, if I get 3-4 emails from different accounts at the same time sometimes I will only get 1 notification for the first email. It's a sometimes thing, 95% of stuff I get fine tho.
    09-01-2015 08:55 AM
  16. Moskus's Avatar
    I can't figure out which versions I have. How do you do that?

    I just updated to 10536, and now I have a different problem: I can't deploy any version my my device! :(
    EDIT: No, after several restarts of the device and the computer it finally worked. I'm giving the new version a chance again (version 1.1.0.13?).
    Last edited by Moskus; 09-16-2015 at 05:01 AM.
    09-16-2015 04:33 AM
  17. noned's Avatar
    Hi guys,
    thanks for all the information so far. Unfortunately, I do have a problem which I was unable to solve.
    I'm on the latest Preview 10536, installed the latest version of Pebble Notifications app from sd card (downloaded it via the link provided in post #12), my Pebble is connected and recognized by the app. However, I'm not getting any notifications apart from email and media (changing track), and in the app itself I can't see the list of all available apps - it is stuck on 'Loading Applist...'.
    I understand that some of you somehow managed to solve the issued I'm facing - or not?
    09-18-2015 04:57 AM
  18. DavidinCT's Avatar
    Hi guys,
    thanks for all the information so far. Unfortunately, I do have a problem which I was unable to solve.
    I'm on the latest Preview 10536, installed the latest version of Pebble Notifications app from sd card (downloaded it via the link provided in post #12), my Pebble is connected and recognized by the app. However, I'm not getting any notifications apart from email and media (changing track), and in the app itself I can't see the list of all available apps - it is stuck on 'Loading Applist...'.
    I understand that some of you somehow managed to solve the issued I'm facing - or not?
    I would uninstall and re-install, try again...Have not seen that locked on Loading Applist from a few builds ago...10166 was the last I saw that issue...
    09-18-2015 02:05 PM
  19. no_flo's Avatar
    Hi guys,
    thanks for all the information so far. Unfortunately, I do have a problem which I was unable to solve.
    I'm on the latest Preview 10536, installed the latest version of Pebble Notifications app from sd card (downloaded it via the link provided in post #12), my Pebble is connected and recognized by the app. However, I'm not getting any notifications apart from email and media (changing track), and in the app itself I can't see the list of all available apps - it is stuck on 'Loading Applist...'.
    I understand that some of you somehow managed to solve the issued I'm facing - or not?
    Had the same error. Fixed it by doing a reset. Works now, although I restored my device from backup.
    09-23-2015 08:08 AM
  20. grahamf's Avatar
    Hi I can't seem to download the app? The links you guys are giving redirect to the US store, and I can't figure out how to navigate to the app store when I change regions
    10-15-2015 07:59 PM
  21. DavidinCT's Avatar
    Hi I can't seem to download the app? The links you guys are giving redirect to the US store, and I can't figure out how to navigate to the app store when I change regions
    It seems to re-directing me to the US.... PM me with your email and I'll send it to you...
    10-16-2015 08:41 PM
  22. grahamf's Avatar
    Thanks but I was able to download it from XDA. I got it installed, but I still have to wait for my pebble to come in. I got a metal strap which was backordered so it may take longer...
    DavidinCT likes this.
    10-16-2015 11:36 PM
  23. DavidinCT's Avatar
    Thanks but I was able to download it from XDA. I got it installed, but I still have to wait for my pebble to come in. I got a metal strap which was backordered so it may take longer...
    Awesome, let me know if you have any issues, I seem to be the person here who talks about it the most :-/
    10-17-2015 09:10 AM
  24. segelfreund's Avatar
    Have anybody run the APP on the latest preview of W10M?
    I can't connect my pebble with the 930. In Bluetooth they find the pebble, but it don't connect right.
    11-01-2015 09:29 AM
  25. DavidinCT's Avatar
    Have anybody run the APP on the latest preview of W10M?
    I can't connect my pebble with the 930. In Bluetooth they find the pebble, but it don't connect right.
    Tried it in the newest build, no problems, also playing with a Microsoft Band as well..
    11-01-2015 04:48 PM
35 12

Similar Threads

  1. Developers- I Want to develop apps for WP and I need your help. thanks :-)
    By Ashish Gupta888 in forum Software Development and Hacking
    Replies: 9
    Last Post: 04-17-2016, 10:48 AM
  2. Installed App has disappeared?
    By nrimolde in forum Nokia Lumia 1520
    Replies: 12
    Last Post: 08-24-2015, 09:49 AM
  3. Why do I get the Error (8007000d) on updating my Lumia 530?
    By WPCentral Question in forum Microsoft Lumia 530
    Replies: 5
    Last Post: 04-04-2015, 12:32 PM
  4. How can I update my Kin 2 to new software?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2015, 10:47 PM
  5. BBM for Windows Phone gets Channel support in latest beta update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-30-2015, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD