650 and Bluetooth

HW01

New member
Dec 13, 2016
2
0
0
Visit site
Just changed from 630 to 650 and hit problem with Bluetooth. My 630 connects to headphone immediately, but 650 not at all. Is this is a known problem with 650? many thanks.
 

HW01

New member
Dec 13, 2016
2
0
0
Visit site
First firmware update made no difference, but the second was successful. Many thanks. Finding quite a lot of changes from my older Lumia 630.
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
Yea... The 650 has something weird in it's Bluetooth. I'm not sure if it's a driver issue or it's chipset. But for some reason the 650's Bluetooth isn't as compatible with other Bluetooth devices as with other phones.

I have a motorcycle Bluetooth intercom (Sena SMH10) that just doesn't work 100% with my 650. I can pair the SMH10 with just about any other phone on the planet and it works properly with all it's features, but not with the 650.

I've paired the intercom with other Windows phones (Nokia, Microsoft, and others) at the Microsoft Store and it's fine, again just the 650 has issues. Trying to get MS to look into it, has been rather futile.

And, yes... I have the current firmware installed :cry:
 

eightyplus

New member
Dec 27, 2016
8
0
0
Visit site
It may seem strange restarting this thread after 2 years but my new L650 will not connect to my new Sony 5-540-488-12 Personal Audio System. The Sony works great with my wife's Samsung J3 phone. Any ideas what I might do to find what is wrong? The L650 has all the updates to build 14393.953 and works great except with the Sony speaker.
 

Members online

Forum statistics

Threads
324,701
Messages
2,245,900
Members
428,222
Latest member
Jeniferhanea