Battery level thing broken

ArousedSpoon

New member
Aug 13, 2011
37
0
0
Visit site
Okay so the past like week or two every few mornings I wake up after charging my phone all night to the battery level thing only being 3/4 full. But the green light is on, if I reset my phone it'll go to full as it should, and if I just leave it, it wont show me losing battery until the battery physically catches up to where it is showing. Is there any known reason this issue is happening? It's not a huge issue but I'm hoping it's easily fixed.
 

sinlessearth

New member
Feb 10, 2011
108
0
0
Visit site
I have heard of this before. Have you updated your phone to the current OS and firmware? Try to recondition the battery, let it run completely dead until it turns off on it's own then recharge completely. Do this a few times. This will recalibrate the battery reading.
 

wizake

New member
Sep 15, 2011
129
0
0
Visit site
Something similar happened to me just now. HD7 with Mango on it.
The battery level indicator was low, so I connected it to my laptop. The battery indicator changed as if it was charging, but the battery charge level remained at 0% (I can see this in settings - battery saver). When i disconnected the phone, the "Clitically low battery" message appeared. I tried pluging-it into the power outlet, but the same thing was happening. It didnt seem to charge the battery.

Then I removed the battery for a few seconds, put it back in and turned on the phone. The battery level is now 51% and it's charging.

So even though WP7 didnt know, the battery was charging. But the OS kept saying that the battery is empty.

Should I worry?
 

TheWeeBear

New member
Jan 9, 2011
5,285
17
0
Visit site
I had that once when i had flashed a new ROM update on my Omnia wizake, the OS just seemed to be confused until i just let the battery die and then recharged it.

It just needed the battery indicator recallibrated by doing what SinlessEarth has suggested.

Don't think you have anything to worry about, but what about that smoke coming from the earphone socket ? ;)
 

ArousedSpoon

New member
Aug 13, 2011
37
0
0
Visit site
Okay well just going to update quick, after it being like 10 days and recieving the mango update, it finally has fixed itself, I was hoping updating to mango would fix it, but after charging my phone the night after updating, it did not, but to my surprise the 2nd charge after updating and my 10th total, it is finally fixed. Thanks!
 

a box of fish

New member
Sep 14, 2011
78
0
0
Visit site
I have heard of this before. Have you updated your phone to the current OS and firmware? Try to recondition the battery, let it run completely dead until it turns off on it's own then recharge completely. Do this a few times. This will recalibrate the battery reading.

I am having the same problem, I will give this a try and see what it does.
 

DrHuss

New member
Mar 29, 2011
9
0
0
Visit site
this seems to be a bug in mango. i have witnessed the same thing with the battery indicator on my HD7 after updating. Ive done the recalibration thing. still nothing
 

Members online

Forum statistics

Threads
324,215
Messages
2,245,166
Members
428,176
Latest member
Arthur Dent