Flash broken. Any ideas?

gvp 1995

New member
Aug 2, 2013
114
0
0
Visit site
I left my 1020 on the table camera down next to a glass of iced water. When I picked my phone, I noticed the bottom was wet because of the little puddle of condensed water around the glass. I wiped the phone, and was sure there would be no damage, but after some time my 'focus assistant light' went on and stayed on whatever I was doing. I suspect the culprits are those two small contacts on the back for wireless charging. This is the only way how humidity (water, vapor) could get inside...

To cut a long story short, after 3 days it was still on, even after full battery discharge and multiple reset to 'factory settings'. Then I spoke with the tech support via chat. And he asked me if I tried Nokia Software Recovery Tool. So I tried that, and after using it and re-starting the phone the light went off! I don't know if it was a coincidence of a sort because afterwards the light went on several times, but each time weaker and weaker, and now it is gone completely (5 days after).

But now I have another problem. The flash does not work! When the light was on, it was working. What could it mean? And how can I fix it? Any ideas? Should I try to take the phone apart and clean? Is the flash module broken based on what I described?

Thanks in advance for any ideas/info. Everything else is working fine. The phone is not on a warranty - it was one of the first 1020s, which I bought from MS Store back in July 2013
 

Members online

Forum statistics

Threads
323,804
Messages
2,244,423
Members
428,133
Latest member
BettyeWaret