Frequent signal drops

Shad0wguy

New member
May 15, 2013
212
0
0
Visit site
I've noticed this for a while, but its starting to really get annoying. I'll be standing in one place and have 3 bars of 4G, and a second later I'll have no signal. A few minutes later and it will come back just to be lost again later on. Has anyone else had this issue and if so were you able to resolve it?
 

Laura Knotek

Retired Moderator
Mar 31, 2012
29,382
16
38
Visit site
Have you had similar issues with coverage on your previous device? How is your carrier's coverage in your area?

Have you tried getting a new SIM from your carrier?
 

Shad0wguy

New member
May 15, 2013
212
0
0
Visit site
Have you had similar issues with coverage on your previous device? How is your carrier's coverage in your area?

Have you tried getting a new SIM from your carrier?

I did not have this problem with the Lumia 521 I had before getting the 925, nor with my old Galaxy Nexus. Service in my area is typically excellent. Haven't tried getting a new sim though. May give that a try if nothing else just to eliminate the possibility.
 

Laura Knotek

Retired Moderator
Mar 31, 2012
29,382
16
38
Visit site
I did not have this problem with the Lumia 521 I had before getting the 925, nor with my old Galaxy Nexus. Service in my area is typically excellent. Haven't tried getting a new sim though. May give that a try if nothing else just to eliminate the possibility.

I've already asked for new SIM when I've had that type of problem. It has worked for me.
 

Staff online

Members online

Forum statistics

Threads
322,448
Messages
2,242,023
Members
427,927
Latest member
felixdel