Google sign in blocked on Edge on Pixel 2

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
Can anyone help me figure out how to sign into Google sites with Edge on a Pixel 2? Google sites work, but don't allow me to log in for YouTube and Google Groups, the only Google sites that I use. I don't get an error message. It's just that nothing happens when I click on the sign on button.

The Pixel 2 is new to me. I can sign into the YouTube app. And I can sign into YouTube on Chrome on the phone. Sign in is only blocked on Edge. I had no problems signing in to YouTube or Google Groups with Edge on my Lumia 650 or Galaxy S7.

What settings or permissions do I need to change to get it to work. I did look into the Google account settings on the phone and looked at security settings. I checked some concerns that it had due logging in from a new device, saying, yes that was me. I'm not sure what setting need to be adjusted.

Can't Google see that I've logged into Google from the exact same device, so logging into Edge should be safe? What's preventing them from seeing that, if that's the issue?

I found this support article for the Pixel on Google Support, where they suggest trying again in a week. That is a pathetic solution. What if I wait a week and it still doesn't work? Then that's going a week without moving forward towards a solution.
https://support.google.com/pixelphone/troubleshooter/2402620?hl=en#ts=9279979

This isn't a huge problem. I can still use the YouTube app, and I infrequently look in Google Groups these days, but it's annoying.
 

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
I'll pass on asking there. I already asked the question on reddit in the Pixel sub, and got a couple downvotes just for asking. I guess no one uses Edge there, and many are anti-Microsoft or something. I asked here, because I figured more people might be using Edge, and some might have encountered the same issue.

I searched Google support and found some things. JavaScript needs to be enabled, but it was already enabled. Also, insecure apps are blocked from sign in, but I checked on my phone, and all the apps, including Edge, are considered secure. As I said before, this is a new phone to me, totally reset when I got it, and I didn't mess with any settings, either for the phone or for Edge. I did deny some Google permission requests when setting up the phone, but after encountering this, I figured I would enable those permissions and restart the phone. Still no good.

I'm almost thinking it's done on purpose to get people to use Chrome. I could use Edge to sign in to Google sites on my Lumia 650 and Galaxy S7, but those phones aren't controlled by Google. And I have no problems with sign in to any non-Google sites.

As for desktop Edge, I'm glad they are switching to the same engine as Chrome (not a techie, so I might have the description of that slightly wrong). I also switch to IE once in a while for the few things that don't work in Edge. But that doesn't have anything to do with my issue.
 

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
I finally found one Google site that would allow me to sign in: Find My Device. After that, I immediately went to try YouTube, Google Groups, and My Activity, but was still blocked on those. Those sign ins are linked - signed into one means you're signed into the others. Find My Device must be separate from those sign ins, because if you have lost your device, it'd be hard to justify making it hard to sign in from any device.
 

Lightning_Racer

New member
Dec 19, 2015
30
0
0
Visit site
I found this support article for the Pixel on Google Support, where they suggest trying again in a week. That is a pathetic solution. What if I wait a week and it still doesn't work? Then that's going a week without moving forward towards a solution.
https://support.google.com/pixelphone/troubleshooter/2402620?hl=en#ts=9279979

I'm finally able to sign in to Google sites on Edge on my Pixel 2. No settings were changed, it just appeared to be a 10 or 11 day Google timeout since first using the Pixel and installing Edge app same day or a day later. That's a bit longer than the help article above was suggesting, but must be the situation the article was talking about.
 

Members online

Forum statistics

Threads
323,770
Messages
2,244,351
Members
428,124
Latest member
Monday Moods