Issue with Windows or RAM or HD?

  • Thread starter Windows Central Question
  • Start date
W

Windows Central Question

I've been facing some issue with my laptop lately. Windows take a lot of time to load. Softwares or folders don't open promptly. At times if I open a particular software like Chrome or Firefox, it only shows in the task manager (multiple instances if I've clicked multiple times) but doesn't open at all or maybe it might open after 5 minutes or so. I play Dota 2 on my laptop and whenever there is an update for the game it doesn't update properly in one go. The download would stop at a particular point (say 50MB out of 120MB) and everytime I restart the update, it would get stuck at the same point again and again. At times restarting the laptop helps. But that also takes a lot of time.

Ran diagnostics and it shows RAM is working fine. But can't be sure if it's an issue with the HDD/Windows 10/RAM.

Any suggestions would be helpful.

Details about the laptop:
It's a Vaio Fit series running Windows 10 on 4GB RAM, i5 processor, some Nvidia gfx card (probably 740M) and 500 GB HDD.
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
I've been facing some issue with my laptop lately. Windows take a lot of time to load. Softwares or folders don't open promptly. At times if I open a particular software like Chrome or Firefox, it only shows in the task manager (multiple instances if I've clicked multiple times) but doesn't open at all or maybe it might open after 5 minutes or so. I play Dota 2 on my laptop and whenever there is an update for the game it doesn't update properly in one go. The download would stop at a particular point (say 50MB out of 120MB) and everytime I restart the update, it would get stuck at the same point again and again. At times restarting the laptop helps. But that also takes a lot of time.

Ran diagnostics and it shows RAM is working fine. But can't be sure if it's an issue with the HDD/Windows 10/RAM.

Any suggestions would be helpful.

Details about the laptop:
It's a Vaio Fit series running Windows 10 on 4GB RAM, i5 processor, some Nvidia gfx card (probably 740M) and 500 GB HDD.

first thing you can check is to see if there are a lot of programs that run at startup - go to task manager > startup - and disable unnecessary programs from starting up
Second would to disable unneeded programs from running in the background - you can do this in settings > privacy > background apps
third would be to do a virus/malware check
Clear cookies in browsers
For those browsers, remove unneeded add ons or update the add ons and the browser

If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
 

Members online

No members online now.

Forum statistics

Threads
324,232
Messages
2,245,205
Members
428,178
Latest member
TheStivo