Just unlocked AT&T Lumia 1020 and 1520 and moved to T-Mobile. Phones only stay on Edge now?

Lloydbm4

New member
Dec 21, 2013
46
0
0
Visit site
Just curious if anyone else has had this issue?

I unlocked both phones without issue. Ported the numbers no problem. Set up both phones correctly downloading Access Point and using a UK Sim to ensure I could tether and send MMS without issue. Both phones do this no problems. Everythings works on both phones. Only thing is, I should be getting at a minimum HSPA+ where I am (since the LTE bands for T-Mo aren't on these phones), but all I can get is Edge? Slow as snot! And once I pop the T-Mo Sim into my Moto X or Nexus 5, I immediately see 4G.

Any ideas?
 

Laura Knotek

Retired Moderator
Mar 31, 2012
29,404
24
38
Visit site
Just curious if anyone else has had this issue?

I unlocked both phones without issue. Ported the numbers no problem. Set up both phones correctly downloading Access Point and using a UK Sim to ensure I could tether and send MMS without issue. Both phones do this no problems. Everythings works on both phones. Only thing is, I should be getting at a minimum HSPA+ where I am (since the LTE bands for T-Mo aren't on these phones), but all I can get is Edge? Slow as snot! And once I pop the T-Mo Sim into my Moto X or Nexus 5, I immediately see 4G.

Any ideas?
You'll need to wait until your area is refarmed to use T-Mobile LTE. Until that happens, EDGE is the best you'll get with unlocked AT&T devices.
 

len0808

New member
Jan 11, 2014
34
0
0
Visit site
Don't know about 1020, but the att 1520 have lte bands 4 and 17, so you should be getting lte. Att locked aws bands, so you will not get hspa+. Double check your apn settings and also make sure you have correct sim card from tmobile.
 

Jam8240

New member
Jun 13, 2014
38
0
0
Visit site
I did the same thing with a 1520. The best you can get is h+, but if T-Mobile has not reframed the 3g bands in your area, you will be stuck on edge, even if there is 3g service for native T-Mobile phones.
 

len0808

New member
Jan 11, 2014
34
0
0
Visit site
I have an unlocked att 1520 on tmobile and I get lte on tmobile. There are also many members on this forum with unlocked att 1520 getting tmobile lte service.
 

metalchick719

New member
Oct 4, 2012
2,353
1
0
Visit site
I assume your area hasn't been refarmed yet. I have an unlocked AT&T HTC One that gets good LTE speeds on T-Mobile. You shouldn't have to wait TOO long to see 4G and LTE, though, as T-Mobile is in the process of converting all of its 2G to LTE.
 

RumoredNow

New member
Nov 12, 2012
18,134
0
0
Visit site
It is radios vs towers.

T-Mo uses the 1700 MHz band in the US. Traditionally that has been where they park their 3G/H+ traffic.

Which phones of yours have 1700 on the correct radio for 3G/H+?
Lumia 1050 - RM940 (ATT variant) does not... Falls back to EDGE on 1900.
Lumia 1020 - RM877 (ATT variant) does not... Falls back to EDGE on 1900.
Moto X - not sure which variant you have... If you see 4G that is how T-Mo displays H+ and LTE will show LTE... I think you must have a T-Mo Moto X???

T-Mo is currently shifting their 3G/H+ to 1900 MHz and using the 1700 band for LTE

What happens with your phones when your area is refarmed?
Lumia 1050 gets H+ and LTE. Falls back to EDGE in un-refarmed areas.
Lumia 1020 gets H+ and LTE. Falls back to EDGE in un-refarmed areas.
​Moto X goes up to LTE and keeps H+ ???

Nexus 5 - has the right stuff radio wise for any North American carrier. EDGE/3G/H+/LTE no worries no matter where or who. Limited only by the speed your carrier offers where you are standing at the moment.
 

Members online

Forum statistics

Threads
323,203
Messages
2,243,449
Members
428,043
Latest member
oqg63899