lumia 650 can't connect to 4G anymore and more

nitro912gr

New member
Oct 21, 2016
9
0
0
Visit site
Hello I have a lumia 650 and since the last month I got a weird problem. I have 4G network enabled and I was able so far to use it.
Last month something changed and I can no longer go above H+ connection with my 650.
I tried soft reset and restarts nothing changed, I enabled 2G, 3G and then 4G again but still H+ is the best I get.

Any idea? I don't think it is a problem from the carrier, my gf have the same carrier and she still get 4G like no problem on her phone.

Another thing is that I noticed that lately the home button no longer instantly respond to get me at home screen, anybody else is experiencing the same? This was the big deal I loved about this phone compared to my android one, the insta-kill of the open app to get you at the home screen.

Thanks
 

Old_Mil

New member
Dec 23, 2015
187
0
0
Visit site
Try a new sim card. If that doesn't work, with the new sim card still in the phone, try a total reset. If that doesn't work, it's likely the handset and time to move on.
 

nitro912gr

New member
Oct 21, 2016
9
0
0
Visit site
Oh and make sure you check all your APN settings are correct.

Hello thanks for the answer, it was a carrier problem after all, I changed from prepaid to a monthly plan and for some reason I had to call them to enable 4G...

Also my poor 650 is dead now :( I wish MS had new lumias out to replace it.
 

patcherd

New member
Oct 16, 2015
419
0
0
Visit site
I know this old but what did you replace the 650 with ? I'm going back to a 650 to try out again in 2019. Was a good phone when I owned one.
 

nitro912gr

New member
Oct 21, 2016
9
0
0
Visit site
I know this old but what did you replace the 650 with ? I'm going back to a 650 to try out again in 2019. Was a good phone when I owned one.

I don't think it is going to cut it in 2019 also most of the apps are dead now that support from MS is ending.

I replaced it with a Xiaomi Redmi 6 and use the launcher 10 to replicate the experience of metro UI.

It is better for sure but it is not the fluent, lag free experience of windows mobile.
 

patcherd

New member
Oct 16, 2015
419
0
0
Visit site
I'm currently using a Pixel 3a with Microsoft launcher installed. It's not bad. I've tried some of the other launchers like 10 but it wasn't a great experience.

So I guess the Lumia 650 was a bad idea then? I don't use my phone for work or business so I should be able to get by.

I really missed that screen on the 650 and how fluid a SD 212 processor is on windows compared to Android.

Is mytube still functional do you know ?
 

fin11

New member
Aug 13, 2016
143
0
0
Visit site
I'm currently using a Pixel 3a with Microsoft launcher installed. It's not bad. I've tried some of the other launchers like 10 but it wasn't a great experience.

So I guess the Lumia 650 was a bad idea then? I don't use my phone for work or business so I should be able to get by.

I really missed that screen on the 650 and how fluid a SD 212 processor is on windows compared to Android.

Is mytube still functional do you know ?

Mytube still works and is frequently updated with new improvements. Got a new update yesterday.
 

patcherd

New member
Oct 16, 2015
419
0
0
Visit site
I just got my 650 today and I am having problems connecting to 4G also on T-Mobile.
I have been with them since 2000 and bought the 650 when it originally came out in 2016, it worked fine then.

Now a couple of years later and this thing is not even a good feature phone.

T-Mobile said something about my APN setting but why should I have to fool with something I never had to before ?

I'm not going to quit until I get this thing working again like it is supposed to.
 

nitro912gr

New member
Oct 21, 2016
9
0
0
Visit site
Your provider usually sent the settings automatically to your device through cellular or a SMS that configure it.
In my case Vodafone need to be contacted to enable 4G on their side for some reason, my APN was correct as I checked it back then.

T-mobile need to provide this configuration or tell you how to add it manually.
 

patcherd

New member
Oct 16, 2015
419
0
0
Visit site
I found out it was TMobile. They upgraded their service a year or so ago and that made some older models not compatible anymore.

After 19 years with them I had had enough and moved over to at&t this past Monday. Now both my new Nokia 3310 and the Lumia 650 work great.
 

patcherd

New member
Oct 16, 2015
419
0
0
Visit site
I think there was only 1 flip phone on display at TMobile. I believe it was an Alcatel.

I have several phones that I juggle around with. I sometimes like to use my Nokia 3310 for the battery longevity and the nostalgic factor it has when I had the original.

Just got my pixel unlocked from T-Mobile today and it works great on AT&T.

Sometimes I wonder if they just want people using newer devices on their Network.

Here in the states the major duopoly is Samsung and Apple. Though T-Mobile does offer the one +7 and pro version I am just not interested in either.

Very fast phones but my Pixel 3a serves me well and I'm content with it.
 

Members online

Forum statistics

Threads
322,502
Messages
2,242,128
Members
427,941
Latest member
JeffersonCop