Lumia 950 / XL : Incredibly unreliable?

EFats

Member
May 6, 2018
59
0
6
Visit site
I have 2 of each of the 950 and 950XL. I didn't get them "new", some may be new old stock, some refurb. Only one is known to be used but all are near mint/new condition. I have had them since before the Windows 10 Mobile EOL.
They all behave the same and have always done so. The only difference, they all have different capacity & manufacturer of micro SD card.

While "at home", just on WiFi, watching Youtube and what not, these are super fantastic. While out and about as a "dumb" phone, it still works fine.
The minute I start enabling data and/or location and/or camera work, ALL of them become super unreliable and will shutdown and reboot randomly. Batteries all good health and even got a new (old stock?) battery. Nothing helps.

I am just wondering how these phones could have ever worked in "real life". Walking around with maps & GPS? Guaranteed re-boot sometime.
Out and about taking pictures or videos? Guaranteed random reboots. Try turning mobile data off and on? It will never turn back on. It seems like unless I boot the phone with mobile data enabled, it never figure out it has a data connection. (This is with 2 different providers).

I can put up with the lack of apps currently and they are still fantastic photo machines, but maaaan, I can NOT deal with the random reboots! Any known fixes or anyone know the root cause? (I'm not crazy, I do have iOS, Android & Blackberry phones at my disposal if I wish to use it. But these are orders of magnitude more reliable. The Blackberry 10 phone is most solid, followed by iOS and the Android ones vary).
 

xandros9

Active member
Nov 12, 2012
16,107
0
36
Visit site
It could be age, the batteries not being able to output the power the phone demands with heavier use, or Windows 10 Mobile being quirky. But that's definitely not normal. You could try resetting one to see if it makes a difference.
 

EFats

Member
May 6, 2018
59
0
6
Visit site
I've tried resetting, no change.
Of course I know it's not normal, but all 4 devices? One of my first thoughts was just old batteries, but I tried a relatively newer 3rd party battery (based on the S/N date code, it's within a couple years) and it still does this.
And if it's power draw, I don't understand why the mobile radios seem to make the difference. When I'm on WiFi and running anything/everything I can, there is zero issue. It has NEVER randomly rebooted that I can recall, and I use them everyday like this. Plus I've got a drawer full of phones that are much older, have been used significantly more and that I push much harder (mostly Blackberry) and they never have issue. Frankly I don't think I recall my Lumia 650 ever doing this either...it's just the 950 siblings.
 

finbaar

Member
Apr 4, 2014
66
1
6
Visit site
They are old now, but that does seem strange to have reboots on all 4. Can you try a burner sim card from a completely different network to see if that might be the problem?
 

Members online

Forum statistics

Threads
323,709
Messages
2,244,264
Members
428,106
Latest member
Akashdeep3469