Miracast Mess Up Apps [SOLVED]

Dewg

New member
Oct 29, 2012
430
0
0
Visit site
Running S3 with TH2 (1511) update. Just after connecting my Surface to a Microsoft Wireless Display Adapter (miracast), my apps stopped working correctly. Many apps such as Disney free fall games and slot machine style games would hang on their splash screens for 30 seconds before loading. Some games such as Xbox Rabbids Big Bang would hang at their splash screen for 30 seconds and then crash to desktop.

I did a factory reset and setup the S3 from scratch (no restore). Everything was running smoothly for about a week. I then did a System Restore Point (prepared this time). Then I connected it to the Miracast again. Same thing happened - app my apps started messing up. Restart, shut down, nothing solved it. So I restored the system back to the restore point (took 5 mins!). Apps started working properly again.

Is anyone else having this problem? Is your S3 on Windows 10 with the November update (TH2) applied? Make sure you turn on System Restore (I have a 128GB S3 so I set System Restore to use 3% of the drive) and set a restore point just before you connect to Miracast.
 
Last edited:

tbsteph

New member
Oct 15, 2013
90
0
0
Visit site
Re: Miracast Mess Up Apps

I'm sure you rather have a fix but my S3 works with the WDA without issue. Have you downloaded the WDA app from the Store? As I recall when I ran that app there was a firmware update for the adapter. Good Luck.
 

Dewg

New member
Oct 29, 2012
430
0
0
Visit site
Re: Miracast Mess Up Apps

Yes, running latest firmware released on the 26th. I'll test again tomorrow. It must be a display driver issue or DX software problem.
 

Dewg

New member
Oct 29, 2012
430
0
0
Visit site
After two Surface 3's, I finally figured it out! For those that have the same issue - after connecting your Surface 3 to a Miracast device (like the Microsoft Wireless Display Adapter), your Unity apps start crashing or taking 30+ seconds to load:

Remove the Miracast adapter from Device Manager - the apps start working normally again!

To do this - open Device Manager
Click View - Show Hidden Devices
Find the Miracast device you connected to (usually in a section that says "Miracast")
Delete (or uninstall) it.
Close Device Manager

That's it! You may have to do this each time you connect your S3 to Miracast - but it seems to work!
 

fabiomarp

New member
Jan 27, 2014
9
0
0
Visit site
I have a S3 2gb 64 MB with Windows 10 totally updated and when I use MS WDA, it works randomly switching between pretty mirroring and stuttering , specially with Netflix. The process manager shows high disk, memory and processor activity. It's frustrating. If I use the Surface with the hdmi cable, everything works fine. I am realizing that it just can't the streaming and mirroring at the same time. What do you think? Am I correct?
 

Members online

No members online now.

Forum statistics

Threads
323,625
Messages
2,244,101
Members
428,089
Latest member
KaledOlavive