My HTC Windows Phone 8X cannot connect to my Wi-Fi network unless there is No Security.

benrk

New member
May 26, 2013
9
0
0
Visit site
Hi-
I recently got an HTC 8X smartphone with Windows Phone 8. I cannot connect to my home Wi-Fi network unless there is no security. I can add MAC address filtering, but my parents don't want it because it is not secure enough. I have been using WPA2 TKIP and WPA2 AES, and none of them allow my phone to connect to the network. They all brought up an error message of: Connection Unsuccessful, ...there was no response from the network. I tried WEP but couldn't figure out what to do with it. Are the WEP keys the passwords or the passphrase the passcode?

I also tried a reset of my router, hard reset of my phone, and changing the SSID, but none of that works. The only thing that worked was taking off all security and using MAC address filtering. I also have a WP7.8 Samsung Focus Flash that has always worked perfectly and connects easily without any configuration.

This is really bothering me because I love the phone and want to use it.

Does anybody know anything or can help me?
Thank you very much!!

-Ben
 
Last edited:

Laura Knotek

Retired Moderator
Mar 31, 2012
29,412
25
48
Visit site
Have you tried the following?
[h=3]To connect to a hidden Wi-Fi network[/h] A Wi-Fi network might be hidden, which means the network name isn't broadcasted. A hidden network won't appear in the list of available networks on the Wi-Fi settings screen, and a notification won't appear when the network is in range. To connect to a hidden Wi-Fi network when it's in range, you'll need to enter the network name and password.

  1. In Settings
    start-icon-settings.png
    > Wi-Fi, make sure that Wi-Fi networking
    basic-icon-toggle-on.png
    is set to On , and then tap Advanced.
  2. Tap Add
    basic-icon-plus.png
    , type the network name in the Network name box, and then tap Add.
  3. On the Sign in screen, type the password in the Password box, and then tap Done.

[h=3]Note[/h] The network name and password are case-sensitive.

Connect to a Wi-Fi network | Windows Phone How-to (United States)
 

benrk

New member
May 26, 2013
9
0
0
Visit site
I have tried that. It did not work. I think it has something to do with the security because I put it on No security and it did work. Thank you for your help though.
 

benrk

New member
May 26, 2013
9
0
0
Visit site
Yes. All other devices connect perfectly fine. Two Kindle Fires, my Nexus 4, Windows 8 computer, and even my Samsung Focus Flash.
Thanks for your help!
 

benrk

New member
May 26, 2013
9
0
0
Visit site
Okay... I tried switching it to straight G (instead of b/g) and also changed the password. I got the WiFi to work on my 8x for about an hour and now it won't connect. The only way it worked was if I signed into the network on my phone when it was still loading the new router settings. Otherwise, it never works. Does this give you any clues?
 

Pu Corleone

New member
Oct 25, 2013
1
0
0
Visit site
i had the same problem like u. my phone is HTC 8s. and when i tried to do what Laura Knotek said, it worked. i think u should try again and make sure u type a CORRECT network name. good luck :)
 

benrk

New member
May 26, 2013
9
0
0
Visit site
Turned out all I needed was a router firmware update. If all the other methods fail, try checking to see if there is a firmware update available for your router.
 

eastendboy13

New member
Mar 4, 2014
1
0
0
Visit site
Hi Ben,
Can you please give me some details on how to get the Routers firmware updated? Sorry if this sounds a little lame.........I have Cable internet from BrightHouse Networks.

Thanks!
 

Forum statistics

Threads
323,629
Messages
2,244,110
Members
428,094
Latest member
deadpool7788