Newly built custom gaming pc is very slow... HELP?

WillSkates

New member
Feb 1, 2019
2
0
0
Visit site
I have the following parts
i3 8100
1060 6gb zotac mini
2 x 4 gb Corsair ram
1 tb hard drive
Evga 600 watt power supply
Cooler master master box lite 3.1
Gigabyte z370p d3
motherboard

I was so happy after about 5 hours of building this pc for my birthday that it actually turned on and all the parts were detected! Went through the bios and everything seemed to have been working fine. So then I went ahead and installed windows 10 on a usb stick. Once I had done that, I checked for updates so all the drivers could be updated and then went ahead and downloaded all the nessecary programs (chrome, steam, epic games, discord etc.). I was so proud that everything seemed to work! I built this pc mainly for gaming, and all the benchmarks show that most games get 60+FPS at 1080p with medium-high settings. And this is when I realised my pc was strange. After opening fortnite, using medium settings I could only get about 25 FPS. This isn’t the only game. Playing subnautica at low settings got 35 FPS and then my whole pc crashed and restarted. Basically any game I play completely underperforms to what I see in the benchmarks. The only other application on in the back ground is discord. PLEASE HELP ME!
 

Golfdriver97

Trusted Member Team Leader
Aug 19, 2013
824
0
0
Visit site
I have the following parts
i3 8100
1060 6gb zotac mini
2 x 4 gb Corsair ram
1 tb hard drive
Evga 600 watt power supply
Cooler master master box lite 3.1
Gigabyte z370p d3
motherboard

I was so happy after about 5 hours of building this pc for my birthday that it actually turned on and all the parts were detected! Went through the bios and everything seemed to have been working fine. So then I went ahead and installed windows 10 on a usb stick. Once I had done that, I checked for updates so all the drivers could be updated and then went ahead and downloaded all the nessecary programs (chrome, steam, epic games, discord etc.). I was so proud that everything seemed to work! I built this pc mainly for gaming, and all the benchmarks show that most games get 60+FPS at 1080p with medium-high settings. And this is when I realised my pc was strange. After opening fortnite, using medium settings I could only get about 25 FPS. This isn’t the only game. Playing subnautica at low settings got 35 FPS and then my whole pc crashed and restarted. Basically any game I play completely underperforms to what I see in the benchmarks. The only other application on in the back ground is discord. PLEASE HELP ME!
Welcome to the forums. Is your RAM set up in dual channel? The sticks should be in every other slot.
 

Members online

Forum statistics

Threads
323,628
Messages
2,244,107
Members
428,092
Latest member
raymowen