• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Not able to update to Windows11, version 22H2 from 21H2, error 0x8007001f


New member
Oct 23, 2022
Hi there,
I'm currently on Windows 11 Version 21H2 (OS Build 22000.1098)

Windows update shows that the 22H2 version is available, however, when the download and install is done, and the system is restarted, it jumps straight to 63% if I'm not wrong, and boots. No update is applied, then it shows error 0x8007001f.

I've tried updating 3 times, but the problems persist.
I've searched for the error, and based on the results, I've tried the following things so far:

1) Deleting everything in the directory C:\Windows\SoftwareDistribution\Download
2) Disabling and re-enabling windows update from services and restarting the service with point 1 done.
3) Disabling Windows defender realtime protection, etc (I don't have any other antivirus installed).
4) Running sfc /SCANNOW (everything fine, no corrupted files).
5) Running DISM.exe /Online /Cleanup-Image /Restorehealth (everything fine, no corrupted files).

None of the above worked.
How to fix this?

Members online

Forum statistics

Latest member