Surface pro 3 sloow boot, screen dead spots, wrong bit locker key

Pkzipper

New member
Nov 5, 2017
1
0
0
Visit site
So in the past 2 weeks I have experienced some strange goings on with my surface pro 3 with Windows 10.
I now have some dead spots on my screen during touch only. the pen and mouse work perfectly but the touch does not.
When I went to restart the surface it got stuck on the surface logo for a long time (3+ min)??? Hmmmm, once it loaded I was able to briefly ( a seconds) work in the dead spots.
So I went o work to fix the issue.
1. updated all drivers
2. 2 button reset
3. screen calibration (windows 10)
4. found a link for external screen calibration tool that did not run so obviously did not work.
5. system refresh
6. complete system refresh to factory defaults
No Joy problem still there!!
I am thinking this is a BIOS issue (windows UTI??/) because when I jump to the bios setting the problem is there and sticking at the surface logo before going to the bios settings page. I am not sure if there has been a BIOS update recently that may have messed things up.
There is also another interesting thing that I am not sure if it is normal or not but while doing the startup repair, clearing the bios setting it asked me for my bitlocker codes and other keys to proceed. the reference was to use my desktop code to continue. Not sure why it asked for that code because this is my surface and not my desktop. My desktop is working fine and so are the rest of my surfaces which none are a pro 3 like this one. I do have listed keys in Microsoft account for all my units.

Any Ideas???
 

Members online

Forum statistics

Threads
324,487
Messages
2,245,606
Members
428,210
Latest member
Star-Evaluator