Surface pro 7 touch screen unresponsive after sleep

Gertrude Fouche

New member
Oct 24, 2021
1
0
0
Visit site
After installing Windows 11 I noticed that the touch screen was unresponsive. I followed instructions to reinstall the driver and enable the touch screen which worked. However, now every time the surface sleeps the touchscreen becomes unresponsive. Uninstalling and reinstalling the driver is not working. Any suggestions?
 
Jun 9, 2021
458
12
18
Visit site
Actually Touchscreen driver is the culprit. Now first download the driver manually from Manufacturer website then uninstall the driver completely then before restarting the system delete its files from "Program Files" and "Program Data" folders. Then restart your system and install the driver which you have downloaded earlier. Hoping your problem will be solved.

If in windows update settings your system reinstall or overlaps your driver then in "Device Manager" roll back your driver to previous then your problem will be solved and again windows update settings cant install the driver automtically.
 

Raunaq Chhabra

New member
Jan 23, 2022
1
0
0
Visit site
After installing Windows 11 I noticed that the touch screen was unresponsive. I followed instructions to reinstall the driver and enable the touch screen which worked. However, now every time the surface sleeps the touchscreen becomes unresponsive. Uninstalling and reinstalling the driver is not working. Any suggestions?

I am having the same issue. Tried speaking with customer service who made me download an update. But the problem still persists.
 

Alex Buk

New member
Jun 27, 2022
1
0
0
Visit site
I am having the same issue. Tried speaking with customer service who made me download an update. But the problem still persists.

SOLVED!!! i had this same issue for months, ITS THE TYPE COVER, when you close it it tells the surface to deactivate touch (why would you need touch with type cover closed) ubt when you open it does not "unlock" type cover, i tried everything, reinstalling drivers, hard reset, ect

Then i put a new type cover on and solved the problem instantly,

Hope this helps
 

Members online

No members online now.

Forum statistics

Threads
323,689
Messages
2,244,213
Members
428,098
Latest member
Linux86