Surface RT Fails to charge.

camptime

New member
Feb 26, 2012
241
0
0
Visit site
My surface Rt has been the best tablet experience I have had, It has been in constant use for the last 10 months I have owned it. (Averaging 5-6 hours use every day)
Unfortunately it is now not charging :( we have to Surface RT in the house so I know its not the charger. The light on the end of the charging cable does not light up. I have tried cleaning the terminal but that has not made any difference. looks like I need a replacement.
 
Last edited:

camptime

New member
Feb 26, 2012
241
0
0
Visit site
Have two Surface RTs in the house my charger charges my wife's RT fine. tried everything suggester from the Surface forums sill not working.
Really missed not having it today. Hope Microsoft will let me pay a little more and upgrade to Surface 2.
 

longlifexs

New member
Nov 14, 2012
46
0
0
Visit site
Happened to me too. The light on the charger didn't even light up. I only have one tablet so I wasn't sure if it was the Surface or the charger, but being in a country where Surface isn't officially available (=no support/service available), I just let it sit on the table and collect dust. A couple weeks later, out of sheer curiosity, I pugged the charger in and voila - it started charging and I am typing this very message from my again-functional Surface RT. I understand this isn't of much help and if you can get it serviced, by all means do, but I just wanted to let you know that it might start working by itself after some time :)
 

jonldevries

New member
Oct 27, 2012
23
0
0
Visit site
I had the same problem, I brought it to a Microsoft store and it charged, bought another charger and that worked, now both chargers work


Not sure why it stopped charging
 

law506

New member
Dec 28, 2013
3
0
0
Visit site
Anyone ever figure out why this happens?

I got one from my company 4 days ago and I am having this problem. Rather disappointing to have this happen after only 4 days of rather light use.

I did, however, notice something odd prior to the issue. I was using the tablet and noticed that the battery charge percentage never went down from 100%. I restarted it to clear up any problems that might of been going on and it never booted back up. When I pushed the start button it turned on, showed the 'Surface' screen, then went to the battery symbol. Plugged in the charger and no light.

Borrowed a co-worker's charger and it did not work either. So I guess I will sit around with it for a few days, or weeks, since I can't get to a store or file a warranty right now and hope it magically comes back on.
 

law506

New member
Dec 28, 2013
3
0
0
Visit site
**Update**

Talked with support and they say it is a faulty battery and to put in a replacement request. So if anyone else has this issue you will probably be looking at having to get a new one.

On the otherhand, if you want to wait around and wait for the battery to fully discharge... the battery seems to 'clear' its error at this point and come back to life. At least that is what I have gathered over the last few days of readings.
 

Blackberry-Prince

New member
Jun 4, 2015
73
0
0
Visit site
My surface Rt has been the best tablet experience I have had, It has been in constant use for the last 10 months I have owned it. (Averaging 5-6 hours use every day)
Unfortunately it is now not charging :( we have to Surface RT in the house so I know its not the charger. The light on the end of the charging cable does not light up. I have tried cleaning the terminal but that has not made any difference. looks like I need a replacement.

I ended up finding a solution on a few forums. When the error massage (battery not detected) is showing in the desktop icon on tast bar, unplug the charger (tablet will shut off) hold down power button about 10 seconds and while still holding it plug the charger back in. When the surface logo appears let go of power button. That will then give you the "plugged in, not charging" message. Repeat the steps and it will eventually work. After it was at 45% i unplugged it and plugged it back in. It worked and was charging well but after unplugging and plugging back in several times i noticed sometimes it would not charge. It is just a matter of plugging in and unplugging the charger in my experience. Ive heard many other people having the same problem and getting around it doing the steps i suggested.
 

Members online

Forum statistics

Threads
323,278
Messages
2,243,563
Members
428,055
Latest member
graceevans