• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Taiwan RM-937 variant suddenly gets LTE since Cyan...not that I'm complaining...


New member
Feb 18, 2012
I bought a 1520 from Omage Cell in Edmonton (I'm in Calgary) back in January. It was the RM-937 Malaysia variant and it was defective so I sent it back but not before getting a Rogers LTE nano sim, and it did indeed get Rogers 2600 band LTE and screamed on it (for around 24 hours until the screen crapped out). Omega sent me a replacement but it was the Taiwan variant, which only tops out at HSPA+. I complained about this and they sent me a $100 refund. They said if it's the 937 it should get LTE but I sent a pic of the box which only listed GSM and HSPA bands and also read that Taiwan didn't get LTE despite the 937 model being sold there. None of these turned into a big deal; I was and am happy with the phone and I have a pretty meagre data plan anyway and so LTE can be overkill.

Anyway, I updated to Cyan a week or so ago and one of the first things I noticed was a "4G" signal on the status bar. I thought this was just a renaming of the H+ indicator but saw it cycle among 3G, H+ and 4G. The SIM options that used to only have 2G and 3G highest connection speed options now have 2G, 3G and 4G. No LTE.

Now the best part: I ran a speed test when my partner and I were at the Chinatown street festival here this past weekend (this was downtown in other words) after I noticed the 4G was steady with lots of bars. Result: 63.65Mbps down, 17.96 up. There is no way this is H+ since I've never seen an H+ upload speed exceed around 2Mbps. This is, in fact, faster than any wi-fi test I've run (fastest there has been maybe 45 download speed), AND my partner simultaneously ran his own speedtest.net test on his iPhone 5S and only got around 38 down. Fast, but not nearly as fast as mine. I ran a second test and got 53.8/18.9.

I asked the sales guy at a Rogers Imagine Wireless store if 4G and LTE were the same thing- not for marketing but if I was in fact getting LTE- and he said no, but Rogers doesn't sell the 1520 so neither he nor the vast, vast vast majority of people in Canada would be familiar with it, especially a Taiwanese model. The Malaysian version I had DID show LTE on the status bar, not 4G, or so I recall.

I know it's a shot in the dark but has anybody else had this experience? Did the cyan update "open" the LTE radio or something?



New member
Sep 8, 2013
On Cyan it won't show LTE but 4G. Mine always had LTE on 2600 even before cyan. The guy at the Rogers is wrong. You were getting LTE. You can't get those speeds on HSPA. If you turn network to 3G/HSPA it will max out at much slower speeds. But, I wouldn't leave it on 4g as the radio keeps searching for the weaker 2600 signal and drains the battery.