To anyone thinking of using a Lumia 900 on an MVNO

hasasimo

New member
Apr 8, 2012
1,922
0
0
Visit site
Be aware that you will NOT be able to use MMS :(

I took the risk and bought one yesterday. I made sure to have my Red Pocket sim in the phone with the first boot. It did not detect the APN and MMS settings. Add to that the fact that Nokia's Network Setup app is no longer in the marketplace, and the result is a beautiful smart phone that can't multimedia message. Very frustrating.

I did two hard resets after that just to be sure, and again, it didn't detect the settings. I don't know if this is because the phone is locked or what, but typically WP detects your sim's settings automatically when you first boot it up.

The good news is I'm getting 4G HSPA+ data speeds (manually entered web APN settings).

I'm thinking of reverting back to my Lumia 800 (installed Network Setup on there before it was taken down) and returning my 900. Not sure yet.
 

nokiaqueen

New member
Apr 10, 2012
81
0
0
Visit site
My mms works fine, I can send and receive, take urs to an at&t store and have them look at it

Sent from my Lumia 900 using Board Express
 

nokia4life

New member
Mar 31, 2012
430
0
0
Visit site
How are you using an art branded locked device on a mvno is it unlocked or something

Sent from my Lumia 900 using Board Express
 

hasasimo

New member
Apr 8, 2012
1,922
0
0
Visit site
How are you using an art branded locked device on a mvno is it unlocked or something

Sent from my Lumia 900 using Board Express

Because the MVNO uses ATT's network. If it was a locked T-Mobile device for instance, it wouldn't work on my MVNO, only one that utilizes T-Mobile's network.

Sure beats those crazy ATT prices.
 

Members online

Forum statistics

Threads
323,142
Messages
2,243,329
Members
428,029
Latest member
killshot4077