Videos won't play on Lumia 620

RetroMan71

New member
May 14, 2013
49
0
0
Visit site
As the title says, my Lumia 620 has recently decided that it won't play videos with any apps. Whether it be YouTube; MetroTube or any video app... They just wont play!
There's no error message or anything, I simply click PLAY icon which seems to respond to my touch but nothing else.

Just curious to know if anyone else has had a similar issue and hopefully fixed it?

Thanks! :eek:rly:
 

montsa007

Ambassador
Apr 10, 2013
3,036
0
0
Visit site
Hold down volume down + power button, screen will go off, release the buttons and it'll reboot, try then.

Try a different wifi/3G connection.

Remember - A soft reset is the first and most common solution to most of the problems.
 

diktea

New member
May 6, 2013
144
0
0
Visit site
To check whether the phone /apps are problematic or not, just load some videos to your phone itself locally and try to play it (if it does not play then it could be some new apps you downloaded messing it up, if it plays well it could very well be the network connection)

try recalibrate the network connection by deleting the wifi connection on your phone and re-search it and reconnect it. (if you have not done it)
If GDR2 with Data Sense did you limit your data usage ?

I dont know the solution but that might just help... All the best
 

RetroMan71

New member
May 14, 2013
49
0
0
Visit site
Mmm! Thanks for your input guys, but after some headbanging, it seems that certain videos will play that don't say VEVO on them. Also if I go to the YouTube website and try to play the same video, it says "This video is not available on mobile. Add to playlist to watch it later on a PC"...

So there you go...
 

montsa007

Ambassador
Apr 10, 2013
3,036
0
0
Visit site
Try to play a different video on youtube mobile app, I use metrotube and never had this error "Not avl. for mobile"

As for VEVO thing, never heard of that :/
 

RetroMan71

New member
May 14, 2013
49
0
0
Visit site
Try to play a different video on youtube mobile app, I use metrotube and never had this error "Not avl. for mobile"

As for VEVO thing, never heard of that :/

To be honest, I've been using MetroTube for a while also and never had these issues before. Only in the last week or so has it been acting weird.

The VEVO logo appears on the video before you click on it to play...

vevo.jpg

Any video that has this won't play... others play fine.
 

RetroMan71

New member
May 14, 2013
49
0
0
Visit site
Just to update.. Been using mytube, didn't know about this app, very good by the way. Anyhoo, was fine for a while but sure enough again in having issues playing certain music vids. Some that where playing before suddenly have stopped working.. Really bizarre, very frustrating!!!!!!!
 

montsa007

Ambassador
Apr 10, 2013
3,036
0
0
Visit site
To be honest, I've been using MetroTube for a while also and never had these issues before. Only in the last week or so has it been acting weird.

The VEVO logo appears on the video before you click on it to play...

View attachment 42977

Any video that has this won't play... others play fine.

If you're head is still not leaking blood by constantly banging it somewhere, I'd like to inform that I can't play this thing either, I'd shoot myself ifI saw that video anyway after seeing a bunch of her pics at VMA performance on 9gag.
 

RetroMan71

New member
May 14, 2013
49
0
0
Visit site
If you're head is still not leaking blood by constantly banging it somewhere, I'd like to inform that I can't play this thing either, I'd shoot myself ifI saw that video anyway after seeing a bunch of her pics at VMA performance on 9gag.

Haha! thanks mate. She went all weird right? I read somewhere that it has something to do with adverts that should play before the video starts on vevo videos??
Anyway, I've recently switched over to mytube and all is great with that now after purchasing.
 

Shuvro Sudipta Saha

New member
Mar 20, 2014
1
0
0
Visit site
now the same problem is happening in my 720....
neither YouTube nor FB vids are playing on my phone ( since last 2 weeks )
says "Sorry, we can't play this file on your phone."
no idea what suddenly went wrong.
 

Bernard Moyo

New member
Apr 27, 2016
1
0
0
Visit site
vedios not playing on my lumia 640LTE

my phone is also refusing to play vedios that i download and those i take using my cam and also refusing to open photos that i shoot using my phone..it says format not supported
 

Members online

Forum statistics

Threads
323,709
Messages
2,244,261
Members
428,106
Latest member
Akashdeep3469