Why does my Nokia Lumia 1520.3, have a No Service message on T-Mobile and my phone won't connect?

blowjet

New member
Dec 25, 2014
4
0
0
Visit site
Nokia Lumia 1520.3, "No Service" message on T-Mobile, Phone won't connect

Bought a Lumina 1520.3 (RM-938) from B&H Photo yesterday. Bought a new SIM at a T-Mobile store (have current T-Mobile service) but I get "No Service" on the live tile and "No network found" in settings; cellular+SIM. This phone has LTE 1700 & 2100 frequencies. Others use this phone on T-mobile. I am in Zip 98020, 20 miles from the T-Mobile headquarters in Bellevue, WA. Could someone of you experts out there advise me on connecting it to the T-Mobile network?

I was switching the same number from my old Nokia 921 to the new Nokia 1520 at a T-Mobile store. I had to switch back to the Nokia 921. Could it be that there was a conflict between deleting the 921 and adding the 1520? (By the way, the 1520 is a great WiFi internet device and I can call with Skype)

I appreciate your help! Regards -Fran
 

HoosierDaddy

Well-known member
May 28, 2013
2,334
65
48
Visit site
Re: Nokia Lumia 1520.3, "No Service" message on T-Mobile, Phone won't connect

I don't understand why they charged you for a sim.

I'm a little confused about the phone number. The phone number is linked to a SIM not a phone model. They would simply associate the new SIM to your account. The phone shouldn't really matter.

But if you went back to your 921 and it worked that means you either moved your new SIM to it with an adapter OR they linked your old SIM back to your account which would mean the nano-SIM was no longer linked to your account and should not work.

I don't know how to fix your problem but when I switched to my 1520.3 and went to the T-Mobile store to get a nano-SIM they installed and configured it for me for free. If you are close to a store, you could go in and make sure everything works before you leave.
 

blowjet

New member
Dec 25, 2014
4
0
0
Visit site
Re: Nokia Lumia 1520.3, "No Service" message on T-Mobile, Phone won't connect

I took the phone to the T-Mobile store on the Microsoft campus and they got it connected in 5 minutes. Evidently there was a snafu switching to it from my 521 originally. I don't think they did anything special but It works great now. Thanks HoosierDaddy, appreciate your help. Also, like your emblem, it's just like the one on my CTS. I am a Hoosier daddy too being born in Anderson, but obviously live in Washington state now.
 

HoosierDaddy

Well-known member
May 28, 2013
2,334
65
48
Visit site
Re: Nokia Lumia 1520.3, "No Service" message on T-Mobile, Phone won't connect

I took the phone to the T-Mobile store on the Microsoft campus and they got it connected in 5 minutes. Evidently there was a snafu switching to it from my 521 originally. I don't think they did anything special but It works great now. Thanks HoosierDaddy, appreciate your help. Also, like your emblem, it's just like the one on my CTS. I am a Hoosier daddy too being born in Anderson, but obviously live in Washington state now.
Glad they got it working!

I have a tuned ATS Turbo M6. Here is a video showing the car and why you don't comment to your son as he's backing out that there's gum on a back tire.

 

Members online

Forum statistics

Threads
324,096
Messages
2,244,984
Members
428,166
Latest member
kasha963