Win10 laptop making router wifi unrecognisable

prithee

New member
Jul 4, 2020
4
0
0
Visit site
After connecting my router wifi from win10 laptop, it connects and after 1/2 minutes, it says no internet and the router WiFi also becomes unrecognisable. To make the router WiFi work again, I need to power off the router.
ISP connection: PPPOE
Wifi Router manufacturer: TPLINK
Laptop vendor: Acer

Diagnosis: when connecting the router WiFi via mobile WiFi, it's working fine, no issue at all, but as soon as I am trying to connect it with the laptop, boom, no internet and router WiFi becomes unrecognisable.

Please help.
 

me just saying

Active member
May 17, 2020
1,195
12
38
Visit site
your post is confusing. are you saying that when you connect your laptop to the router, you lose internet connection? anyway, please give the full model number of the router. also did you try a power cycle with the modem? unplug the modem and router, then plug in the modem wait for it to reset, then plug in the router and try again.
 

prithee

New member
Jul 4, 2020
4
0
0
Visit site
Router model number: TL-WR841N (TP-LINK router).
I do not have a modem, just the WiFi router, I guess modem is used by my vendor providing me internet.

The router is working fine. Like when I am connected to it via mobile phone or desktop (via LAN cable).

But as soon as I connect it using my win 10 acer laptop's WiFi, it connects and within 2mins, it goes from internet to no-internet and also my router WiFi becomes unrecognisable. Now, at this condition, I can't even get the WiFi from my mobile. I have to power off my router to get the WiFi back and connect via mobile WiFi. When I again try to connect it from laptop, again same problem.
 

prithee

New member
Jul 4, 2020
4
0
0
Visit site
Router model number: TL-WR841N (TP-LINK router).
I do not have a modem, just the WiFi router, I guess modem is used by my vendor providing me internet.

The router is working fine. Like when I am connected to it via mobile phone or desktop (via LAN cable).

But as soon as I connect it using my win 10 acer laptop's WiFi, it connects and within 2mins, it goes from internet to no-internet and also my router WiFi becomes unrecognisable. Now, at this condition, I can't even get the WiFi from my mobile. I have to power off my router to get the WiFi back and connect via mobile WiFi. When I again try to connect it from laptop, again same problem.
 

naddy6969

New member
Aug 8, 2017
147
0
0
Visit site
I would upgrade the router. The TL-WR841N is very old, and currently sells for $20. It is basically junk at this point.

I had a TP-LINK router a few years ago. I switched to a NetGear. All of my WiFi problems disappeared.
 
Last edited:

prithee

New member
Jul 4, 2020
4
0
0
Visit site
You sure it's the Router and not the windows 10 new updates messing with the WiFi ?
I did something, that is to adjust both the router and the win 10 wireless adapter frequency to 2.4 GHz and it seems to solve the problem. Worked well for 2days.
Still, could you please suggest me a good NetGear router for home purpose, one which also goes well with PPPOE broadband connection? Thanks in advance.
 

naddy6969

New member
Aug 8, 2017
147
0
0
Visit site
It sounds like you solved your problem. Still, you might want to get a new router. If you are the only person using it, you should be OK. I replaced my old TP-LINK router because there were several people using here using it. It would randomly reboot due to being overloaded.

Any modern router will be able to handle PPPOE, since it is standard for DSL internet connections. I have a Netgear R6700, which is a few years old but is still being sold. It is fast (enough for me), easy to setup and reliable. Under $100. There are many other Netgear routers, up to $500. You certainly don't need a $500 router, as DSL does not support such speeds.

I have cable TV internet via Xfinity, and have never used PPPOE. But I see it in the setup options.
 

DimitrovDev

New member
Jan 15, 2021
6
0
0
Visit site
Maybe the wifi module/drivers are the problem. I have a old PC which randomly loses it's wifi when using the integrated wifi module, but it's working fine with external wifi dongle.
 

Members online

Forum statistics

Threads
322,538
Messages
2,242,230
Members
427,958
Latest member
gorly3