1. ohaness's Avatar
    The great feature of the TP2 (maybe others) is when you are in the phone/dialpad screen or you get a call, when you put the phone to your ear, the backlight goes out and keeps your head (ear/cheek) from hitting someting on the screen and hanging up or whatever. What has become annoying is when I intiatle a call from the dialpad/phone screen, put it up to my ear, the screen goes blank as it should, take it from my ear to do some task on the phone pad and it goes back to the home screen.

    I heard back from others that their phones (all Verizon flavor) does not do that...it stays in the phone/dial pad after returning from the ear. One other person did hve the same issue as me.

    I question if I have made a change to someting to cause this undesireable situation.

    Does anyone know of a change that I can make to fix this issue?
    09-17-2009 03:01 PM
  2. bbazian's Avatar
    I just got my phone from Verizon. I have the same issue. When I receive or make a call and put the phone to my ear the phone goes dark. That s is great. When I take the phone off my ear the screen goes to the home screen instead of staying on the phone screen and I need to navigate back to it to use the dial pad to dial extensions etc. How do I change this behavior? Not sure that I made any changes but when I first got it the phone screen stayed active till I hung up the call.
    09-18-2009 08:06 AM
  3. ohaness's Avatar
    I'm finding that if you soft-reset the device, it will work as expected...that is stay on the call/dial. That was yesterday. Now today, back to the problem. So as far as I'm concerned, there is no setting that was made by mistake. Its some other software bug....
    09-18-2009 08:46 AM
  4. jfa1's Avatar
    apparently ohaness its an issue with cdma tr2's if yours is a cdma tp2. If you have tmo then its common to all tp2's and hopefuly its something that will be fixed when the devices are upgraded to 6.5 when the rom update comes out.
    09-18-2009 12:16 PM
  5. monomer's Avatar
    I'm using the European version of the TP2 and I see this behaviour on occasion. I found that it tended to happen if I have a few running applications in the background.

    Try closing down applications from the task manager. (And yes I find it really annoying too!)
    09-20-2009 01:37 PM
  6. ohaness's Avatar
    Someone on Verizonwireless forum reports its due to security/lock. Yes I have it on and I am required to keep it on through Exchange server security. Do the others having similar issues using the security lock?
    09-21-2009 06:14 PM
  7. ejonny's Avatar
    I have the Sprint TP2. I am using a complex password that invokes after 2 hours of no use. I have not had the problem described.

    My lock is not Exchange enforced.
    09-21-2009 11:14 PM
  8. ohaness's Avatar
    A call to HTC about this today was immediately greeted with -"do you have Exchange enforced phone lock being used?" Yes was my answer..."we are aware of the issue and I believe we are currently working on a resolution".

    So HTC is aware of the issue and will address it...stay tuned to their support web-site for a "fix" was his next comment.

    We will see....
    Last edited by ohaness; 09-22-2009 at 09:00 PM.
    09-22-2009 12:57 PM
  9. monomer's Avatar
    Someone on Verizonwireless forum reports its due to security/lock. Yes I have it on and I am required to keep it on through Exchange server security. Do the others having similar issues using the security lock?
    Thanks for reporting back about HTC's response to this. Yes I do have an exchange server enforced security policy on my device, so this would explain why only some people are experiencing it.

    I hope they come up with a fix for it soon.
    09-22-2009 06:32 PM
  10. ohaness's Avatar
    Well to my surprise, HTC contacted me today. One of their technical folks called and asked me to explain the symptoms, exactly how the device was set-up, what I encountered under what circumstances. He concurs that this is not how it is supposed to work and is boiling down to a problem with TouchFlo 3D and the OS (6.1). He is gathering the information and is in the process of relaying it to the developers for a patch or ROM update...but ...he was quite frank in that WM.5 and an expected updated TouchFlo D may resolve this and may come out before they can patch it or maybe not in time to get it resolved...lots of maybes and may's....

    Appreciated HTC trying to resolve. As I said before, time will tell. Seems like they are trying.
    Last edited by ohaness; 09-23-2009 at 10:52 PM.
    monomer likes this.
    09-23-2009 10:47 PM
  11. monomer's Avatar
    Could you let me know how you contacted them? I was just thinking that maybe if more of us reported this, they'd get better information about how it can be resolved (and perhaps make a bit more of a priority).
    09-28-2009 08:54 AM
  12. ohaness's Avatar
    I called their US "hotline" at 866-449-8358 (found in thier website with HTC.com set to US viewing...I see you are in Europe). Sorry, I don't recall the prompts to get to the technical rep.

    Great idea to contact...they seemed suprised to find that some companies require the lock to be on and have Exchange enforce it.
    09-28-2009 11:29 AM
  13. ohaness's Avatar
    An update...HTC tech support called me twice today. The first call confirmed numerous calls by other customers with the same issue. He wanted to assure me that the issue was being looked into by the development team for resolution. The second call was to ask me to load two sets of diagnostic tools. They recorded (as best I can tell) the problem and created logs which I was asked to send them for review by their developers. I did what was asked.

    Bottom line, no timetable to a resolution or a fix.
    monomer likes this.
    09-29-2009 07:05 PM
  14. ohaness's Avatar
    I believe I have stumbled on a resolution. I went into Start>Settings>All Settings>Personal tab>Today>Items tab. I then unchecked the "Today timeout" that by default, is set as on and 4 hours. When running under Windows and not TouchFlo3D, I believe this setting will revert you back to the "Today" screen after the time set (4 hours in the default case).

    I do not know what Touch Flo is doing with that setting and the lock being on, but my phone will now stay on dial pad consistently. If you look closely, the screen will flash but a fraction of a second to the today screen but go to the dial pad...

    For those having the same problem as myself, give it a try and see if I'm crazy or what?
    10-05-2009 09:09 AM
  15. monomer's Avatar
    For those having the same problem as myself, give it a try and see if I'm crazy or what?
    Thanks for posting your solution. I seem to remember trying this before, but can't really test it out as I've now disabled the security PIN setting on my TP2.

    Is your solution still working? :)
    10-06-2009 05:07 PM
  16. ohaness's Avatar
    To be honest, I have had instances of it going back to its old ways but generally its been consistantly staying on the dial pad.

    Still hoping that HTC will have a real solution soon...again unless they are waiting to integrate any changes when they offer WM 6.5 and the TouchFlo update.
    Last edited by ohaness; 10-08-2009 at 10:21 PM.
    10-07-2009 11:26 AM
  17. monomer's Avatar
    Still hoping that HTC will have a real solution soon...again unless they are waiting to integrate any changes when they offer WM 6.5 and the TouchFlo update.
    I hope so too. There are similar threads to this one on the forums at xda-developers and ppcgeeks, and neither have solutions for this problem apart from disabling the security lock. From the gist of things, it seemed like at first HTC dismissed the problem as a 'feature', but I guess too many people complained, so now they're working to fix it. :)
    10-11-2009 05:05 PM
  18. monomer's Avatar
    Yay! I've just flashed the HTC Official Upgrade to WM 6.5 for the European version of the TP2. I'm happy to report that they seem to have resolved the issue with the screen going back to 'Home' on the new ROM! :)

    I also note even if I have an Exchange-enforced simple PIN lock enabled, switching the phone out of standby now doesn't revert back to the Home screen either, and just stays on whatever screen you left it last on.
    10-13-2009 07:02 PM
  19. ohaness's Avatar
    Well that is great news. I'll need to wait until Verizon in the US gets the upgrade. My last correspondence with HTC was they are working at it...meaning it will get fixed when 6.5 is ready it seems.

    Thanks again for the update!
    10-14-2009 10:29 PM
  20. ohaness's Avatar
    It looks like we will have to wait (as expected and feared) for the WINMO 6.5 update to solve this:

    My question to HTC about the status of the problem a few days ago:

    "Any update or can you check the status of this? I have seen comments of HTC TP2 users in Europe who have the GSM version that have been provided the Win 6.5 Update, that the update has cured the problem. If this is true, is HTC just going to wait for the Verizon TP2 Win 6.5 update (whenever that comes out) to resolve?"

    The answer:

    I am glad to hear back from you about your Verizon Touch Pro 2.

    They have accepted the ticket but I have not got any further updates about it.
    It will be very likely that they would include this in a ROM update. They usually attempt to take care the majority of the "bugs" in the next firmware update.

    Please feel free to contact us with any inquiries you may have in the future.

    HTC Technical Support Team

    O-Well....
    10-31-2009 11:58 PM
  21. monomer's Avatar
    Sounds like it's now in Verizon's hands. Let's hope the WM 6.5 update gets released soon! :)
    11-01-2009 05:55 PM
LINK TO POST COPIED TO CLIPBOARD