1. tester24's Avatar
    Not entirely sure if I'm doing this right but I'll tell you what's wrong and what i've tried any maybe someone might have an idea what's going on.

    I'm with Verizon (I don't know if that matters). So I did the whole switching the GPS settings to none, none and left the baud rate at 4800 and I checked let windows configure and run the GPS. I downloaded Google maps application it installed and after running it tries to get a satelite but eventually gives up and gives me an error saying there is no GPS or it isn't configured properly. Once in a while it will crash and give me a device.exe error.

    I tried rebooting the phone shutting it on and off messing with the settings for the GPS and I made sure that the GPS was updated with the latest satelite information with the quick fix program.

    Not sure whats going on any help would be appreciated.
    10-22-2009 09:59 PM
  2. nrfitchett4's Avatar
    on sprint you have to run quickgps under program files. I set mine to update once a week and it works great with sprintnav (I haven't added google maps yet, and so far I have been impressed with sprintnav).
    10-23-2009 04:04 AM
  3. tester24's Avatar
    I did that, however it still keeps giving me a cannot find GPS like it cannot find the GPS reciever on the phone. Or it will fail completely and the will say device.exe failed which i assume is the GPS.
    10-23-2009 07:16 AM
  4. Zookeeper's Avatar
    Did you see this thread?

    http://forum.xda-developers.com/show...=563483&page=2

    Go into the Location setting for Phone: Personal tab, Phone, CDMA Services, Location Settings, Get Settings, set to "Location On". Soft reset. When the phone comes back up, you'll get some sort of message about the GPS being on. Say OK.

    In Google Maps, select menu and make sure "Use GPS" is selected. For the first time, you may have to leave the phone outside for a bit . . . maybe a half hour or less, to get the first acquisition. Running HTC Quick GPS may help you get the first lock faster, and help you get subsequent locks more quickly as well.

    Everything else should be left to Verizon defaults.
    10-23-2009 11:33 AM
  5. nrfitchett4's Avatar
    Did you see this thread?

    http://forum.xda-developers.com/show...=563483&page=2

    Go into the Location setting for Phone: Personal tab, Phone, CDMA Services, Location Settings, Get Settings, set to "Location On". Soft reset. When the phone comes back up, you'll get some sort of message about the GPS being on. Say OK.

    In Google Maps, select menu and make sure "Use GPS" is selected. For the first time, you may have to leave the phone outside for a bit . . . maybe a half hour or less, to get the first acquisition. Running HTC Quick GPS may help you get the first lock faster, and help you get subsequent locks more quickly as well.

    Everything else should be left to Verizon defaults.
    I'll try that too. I loaded google maps last night and immediately indoors in a big hospital it had me loaded gps wise!!!

    edit: mine was already set to that default, oh well.
    10-23-2009 10:33 PM
  6. tester24's Avatar
    Well I got it working again. I got fed up with it and reset the device and only installed Google Maps and it ended up working after changing the GPS settings.

    Now to figure out which program broke it.
    10-24-2009 09:29 AM
LINK TO POST COPIED TO CLIPBOARD