1. LqDFx's Avatar
    So I have noticed that my charge speeds are down to 6%/hour since the update. Before the update I was getting 15-20%/hour. I figured that it was maybe something that I could give it a couple days and it would even out. Any one else having this issue?

    Oh, I'm using the Lumia 1520 on the official charger that came with the phone. Battery+ is what is giving me my charge speed numbers. I have tried different chargers (Samsung, Apple, PC) with different cables. All give the same effect.

    Russell
    08-22-2014 05:18 PM
  2. SeattleSeahawks's Avatar
    I've been experiencing the same exact thing on my 1520 since the update. I thought the update was supposed to open up the quick charge on our phones.
    08-22-2014 05:29 PM
  3. Blacklac's Avatar
    Same here. I can barely charge my phone while I'm using it.

    1520.
    08-22-2014 05:34 PM
  4. tire_007's Avatar
    I have the same problem with my 820
    08-22-2014 06:13 PM
  5. Geddeeee's Avatar
    No problems with my 1520. Getting 30% per hour on wireless charging....
    08-22-2014 06:29 PM
  6. Geddeeee's Avatar
    So I have noticed that my charge speeds are down to 6%/hour since the update. Before the update I was getting 15-20%/hour. I figured that it was maybe something that I could give it a couple days and it would even out. Any one else having this issue?

    Oh, I'm using the Lumia 1520 on the official charger that came with the phone. Battery+ is what is giving me my charge speed numbers. I have tried different chargers (Samsung, Apple, PC) with different cables. All give the same effect.

    Russell
    Try using Insider. this will give the true charging speed. Battery + is old now.....
    08-22-2014 06:30 PM
  7. Geddeeee's Avatar
    I've been experiencing the same exact thing on my 1520 since the update. I thought the update was supposed to open up the quick charge on our phones.
    You also need a quick charging cable and mains charger for that to happen....
    08-22-2014 06:31 PM
  8. Blacklac's Avatar
    Weird a reboot seemed to fix mine. It was noticeably slower than normal, so it must have been a freak thing on my end.
    08-22-2014 09:52 PM
  9. LqDFx's Avatar
    Mine seems to be really weird. It starts out low now, but then ends up at about 15% within an hour. What really gets me is the slow charge notification. I hate that toasts and finally disabled it.
    08-22-2014 09:54 PM
  10. Blacklac's Avatar
    You also need a quick charging cable and mains charger for that to happen....
    Do you know any cables that work?
    08-22-2014 10:53 PM

Similar Threads

  1. Slow Motion Video?
    By buggyglint in forum HTC One (M8) for Windows
    Replies: 7
    Last Post: 11-30-2014, 07:16 PM
  2. Wireless bundle Dc 50 battery bank only charges to 50%
    By Stephen Lynam in forum Nokia Lumia 930
    Replies: 4
    Last Post: 09-08-2014, 04:28 PM
  3. Lumia 620 charging and connectivity problem..
    By hss0899 in forum Nokia Lumia 620
    Replies: 1
    Last Post: 08-22-2014, 08:46 AM
  4. "Plugged in not charging"
    By Tsang Fai in forum Microsoft Surface Pro 3
    Replies: 1
    Last Post: 08-22-2014, 06:31 AM
  5. QBracelet wrist battery is stylish, gives you half a charge for $100
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-21-2014, 09:11 AM
LINK TO POST COPIED TO CLIPBOARD