1. A54D's Avatar
    I know Windows 10 isn't supposed to be used as a primary PC, which is why I didn't. I dual booted it alongside Windows 7. Everything was working fine. I managed to sort all the niggles I had with it at the start and just used it occasionally as a testing platform.

    Today however I received an update which looked as though it all worked well but having been away from my PC for a while the computer went to sleep. I woke it up eager to restart and go back to Windows 7 to do work, but the blue screen of death showed and restarted the PC. I wasn't really bothered until it just stopped booting. I keep getting a (p)ci Port0 Device Error. (the "p" is in brackets because I'm not sure it's a "p". It's cut off the screen but I'm assuming it is actually a "p").

    Usually I wouldn't mind but I don't even get the option to start Windows 7. So I can't access my documents.

    I've changed the boot order to CD first and then HDD and inserted an Ubuntu CD with hope that the live CD would run and I could retrieve my documents like that but to no avail.

    Please somebody help. I don't care about the computer but need my documents urgently.
    11-13-2014 04:58 PM
  2. someone2639's Avatar
    Open boot menu.
    11-13-2014 05:09 PM
  3. A54D's Avatar
    I managed to access my documents. Just in case anyone else runs into a similar problem, here's what I did:

    I managed to run the Linux Ubuntu Live CD, This was done via the boot menu. I simply placed the CD drive before HDD. I still received the error when booting but pressed 'F1' in order to continue.

    Waited a while and the Ubuntu screen started loading. Waited a further 5 minutes (approximately) and the Live CD fully loaded.

    I chose to NOT install Ubuntu and ran off the DVD.

    Now that I was in Linux I had to open terminal, you can just search for it.

    (This first command may be irrelevant but seen as it worked for me I might as well include it).

    sudo /bin/bash This allowed me to become the root user.

    I then typed in mkdir /media/disk

    Followed by, Sudo mount -o ro -t auto /dev/sda5 /media/disk This allowed me to access my Windows drive ("sda5") in a read only way. I could view and copy my documents to an external hard drive but I couldn't modify them from Ubuntu.

    MAKE SURE TO CHANGE "SDA5" TO YOUR DRIVE!!

    Unfortunately I couldn't enable read and write privileges but I could still back up all important files so it's all good. Hope that helps anyone who runs into a similar problem.
    11-13-2014 06:31 PM
  4. someone2639's Avatar
    I managed to access my documents. Just in case anyone else runs into a similar problem, here's what I did:

    I managed to run the Linux Ubuntu Live CD, This was done via the boot menu. I simply placed the CD drive before HDD. I still received the error when booting but pressed 'F1' in order to continue.

    Waited a while and the Ubuntu screen started loading. Waited a further 5 minutes (approximately) and the Live CD fully loaded.

    I chose to NOT install Ubuntu and ran off the DVD.

    Now that I was in Linux I had to open terminal, you can just search for it.

    (This first command may be irrelevant but seen as it worked for me I might as well include it).

    sudo /bin/bash This allowed me to become the root user.

    I then typed in mkdir /media/disk

    Followed by, Sudo mount -o ro -t auto /dev/sda5 /media/disk This allowed me to access my Windows drive ("sda5") in a read only way. I could view and copy my documents to an external hard drive but I couldn't modify them from Ubuntu.

    MAKE SURE TO CHANGE "SDA5" TO YOUR DRIVE!!

    Unfortunately I couldn't enable read and write privileges but I could still back up all important files so it's all good. Hope that helps anyone who runs into a similar problem.
    Works great with my Ubuntu cd. If I HAD one! ๐Ÿ˜ƒ๐Ÿ˜ƒ๐Ÿ˜ƒ๐Ÿ˜ƒ
    11-14-2014 03:02 PM

Similar Threads

  1. New Update downloading now!
    By Loco5150 in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 8
    Last Post: 11-16-2014, 12:59 AM
  2. Replies: 2
    Last Post: 11-13-2014, 08:11 PM
  3. New Windows Phone 8.1.1 build 14203 available to download
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 2
    Last Post: 11-13-2014, 05:29 PM
  4. Windows 10 on ALL Lumia's?!
    By Gfrsh325 in forum Nokia Lumia Icon
    Replies: 2
    Last Post: 11-13-2014, 04:11 PM
  5. Replies: 0
    Last Post: 11-13-2014, 04:00 PM
LINK TO POST COPIED TO CLIPBOARD