The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Bkr11's Avatar
    To be fair this computer has had issues recently, which is why I'm trying the Win 10 preview on it, but it always worked w/ the Band in the past. Any ideas on a manual driver install re: the band or something else? Thx.
    01-13-2015 11:17 PM
  2. Giffdev's Avatar
    Thanks for bringing this to our attention. I don't have a quick solution for you, but this is being tracked internally now and we'll take a look. One potential workaround may be to clean your band contacts as we've seen this issue on Windows 8 as well.

    edit: here are more details

    Can you please try the following:
    1. Clean the band connector with a swab and alcohol. Pencil eraser will also work. Concentrate the cleaning on 2nd from the outside gold connectors from both sides.
    2. Quit the app, then reconnect the band to a known working USB 2.0 port directly(if using a hub earlier)
    3. Does the band enumerate in the device manager?

    devicemanager.png
    Last edited by Giffdev; 01-16-2015 at 03:17 PM.
    01-16-2015 02:58 PM
  3. flash1967's Avatar
    Hi, I'm having the same problem. Cable charges the Band when connected to the electrical plug.
    Get the USB device not recognized, uninstalled the app, reinstalled it, rebooted but no success.
    02-07-2015 09:08 PM
  4. Bkr11's Avatar
    So my Dell had a bum mobo...fixing it now. I'll see whether the problem persists after getting it fixed.
    02-09-2015 09:48 AM
  5. lrn2board's Avatar
    I am having the same issue as well! Will charge the band but that's it :/
    02-10-2015 01:19 AM

Similar Threads

  1. Windows My Family app not installing on Nokia Lumia 635
    By WPCentral Question in forum Ask a Question
    Replies: 4
    Last Post: 07-16-2017, 05:00 AM
  2. Windows 10 not updating!
    By someone2639 in forum Windows 10 Insider Preview
    Replies: 5
    Last Post: 01-15-2015, 11:42 AM
  3. FitnessSyncer to link Band to HealthVault
    By willgill in forum Microsoft Band & Band 2
    Replies: 7
    Last Post: 01-14-2015, 08:42 PM
  4. My outlook is not synching with the Mail application
    By Yazan Mowed in forum Ask a Question
    Replies: 5
    Last Post: 01-14-2015, 10:26 AM
  5. No Sound on Win HD BLU
    By mrmjorizing in forum Windows Phone 8.1
    Replies: 0
    Last Post: 01-13-2015, 09:41 PM
LINK TO POST COPIED TO CLIPBOARD