1. garak0410's Avatar
    Has anyone been brave enough to install today's new preview build on their Surface Pro 3? If so, how is it? My only real concern is OneDrive...I need my placeholders. Is the Modern OneDrive available for Windows 10 TP yet?
    01-23-2015 02:07 PM
  2. leo74's Avatar
    Did not dare to yet, but I sure would like to. OneDrive is a major concern for me too. Beside that, I would need to know if I should expect any issues running Visual Studio Community with Win 10 TP to code.
    Everything in me REALLY wants to give it a shot. I don't have a problem with glitches, but the SP3 is my daily driver and while I can deal with some bugs, I can't afford it to not work for some things at all.
    01-23-2015 02:43 PM
  3. garak0410's Avatar
    Did not dare to yet, but I sure would like to. OneDrive is a major concern for me too. Beside that, I would need to know if I should expect any issues running Visual Studio Community with Win 10 TP to code.
    Everything in me REALLY wants to give it a shot. I don't have a problem with glitches, but the SP3 is my daily driver and while I can deal with some bugs, I can't afford it to not work for some things at all.
    Agreed...very tempted and feeling that I may be able to trust the TP from here on out...waiting for more reports on how it is...
    01-23-2015 02:45 PM
  4. leo74's Avatar
    Agreed, I will give it a few days. OneDrive seems to be working OK btw. I connect to OneDrive and OneDrive for Business and I haven't seen any issues with the new build yet, but I only played around with it for about half an hour.
    01-23-2015 03:03 PM
  5. prosimian's Avatar
    I installed on my SP3. Graphics performance is a bit bad, but otherwise it seems solid. I don't have VS installed, though. My SP3 is more of an entertainment / Office / Presentation machine, and all of that looks good.

    Need a better graphics driver, may go to the Intel website and see what I can do.
    01-23-2015 04:28 PM
  6. daniel329's Avatar
    I would hold off. I ran the upgrade - took about 30 minutes. Now my SP3 is unusuable. When it booted into Win10 the screen sat and constantly flashed. Touch didn't work. Pen worked for a few seconds then quit. Then the whole system froze and it shut down. Now it is stuck at the "Choose an Operating System" screen with two options - Windows Technical Preview and Windows Rollback. Tried doing the volume up power restart. Didn't work. Still stuck. Beware.
    01-23-2015 04:50 PM
  7. BaritoneGuy's Avatar
    The choice option is a known bug. For your other issues install the newest graphics driver from the Intel website. Also a known issue. The version is .4080. I posted I instructions in the SP3 forum.

    I too am going to wait for a couple days to see how it goes with the other more adventurous folks.
    01-23-2015 04:59 PM
  8. prosimian's Avatar
    My only big issue was fixed with another system update this evening - finally got the Intel HD Graphics driver from windows update. Other than the occasional little oddities that are to be expected of a TP like this, so far so good.
    01-23-2015 06:36 PM
  9. mylumia928's Avatar
    I would hold off. I ran the upgrade - took about 30 minutes. Now my SP3 is unusuable. When it booted into Win10 the screen sat and constantly flashed. Touch didn't work. Pen worked for a few seconds then quit. Then the whole system froze and it shut down. Now it is stuck at the "Choose an Operating System" screen with two options - Windows Technical Preview and Windows Rollback. Tried doing the volume up power restart. Didn't work. Still stuck. Beware.
    I have the same flashing issue 😞
    01-23-2015 10:43 PM
  10. garak0410's Avatar
    I have the same flashing issue
    My flashing issue went away after a reboot...I am making a new post abut issues with W10 TP on the SP3
    01-24-2015 10:04 AM
  11. Chuck Foltz's Avatar
    If you have an external monitor connect it and the flashing stops. Than run all updates. It should update the driver to 10.18.15.4079 and that will stop the flashing of the screen.
    01-24-2015 10:52 AM
  12. garak0410's Avatar
    I decided to do it...I've got three possible big issues (big enough to go back to 8.1)

    Runs Hot - My SP3 seems to run hot. I check task manager and often times there will be WSPACKAGEMANGER running high CPU or Windows Explorer doing the same...but usually hovering around 14% CPU and fan runs a lot.

    Start Screen - If I pin anything besides an app (say a OneNote Note, a Kindle Book) and try to move that tile around, the start screen will crash and remove what I had pinned.

    IE - Despite actually missing the touch IE, YouTube crashes upon video playback. Guessing it is a Flash Issue...anyone else have this?
    01-24-2015 02:24 PM
  13. tdb1's Avatar
    garak0410 - check here for a solution to the IE / YouTube issue: http://forums.windowscentral.com/win...y-youtube.html

    I installed on SP3. Other than the video issues, it has been tolerably stable. Not very touch friendly still, and I'm still trying to figure my way around.
    01-24-2015 09:28 PM
  14. mylumia928's Avatar
    Is anyone else experiencing audio and video slowly desynchronizing?
    01-24-2015 11:03 PM
  15. uzeroni's Avatar
    I'm using it on my SP1, and so far, everything works! I highly suggest a fresh install with this. Problem is, I don't know how to adjust the screen brightness manually now, where can I do that? Drivers via Windows Update were installed already, so no more driver issues.
    01-24-2015 11:28 PM
  16. jordanzhninja's Avatar
    I'm using it on my SP1, and so far, everything works! I highly suggest a fresh install with this. Problem is, I don't know how to adjust the screen brightness manually now, where can I do that? Drivers via Windows Update were installed already, so no more driver issues.
    Power options - Screen brightness

    Also, I installed this on my SP3 and its way more glitchy than 9879 was. It's not as unstable as 9901, but it randomly crashes now and again, meaning you have to hard boot because the OS won't respond to anything, but the keyboard lights still work. It's odd.
    01-25-2015 06:46 AM
  17. mylumia928's Avatar
    Does anyone else's surface run really hot on 9926?
    01-25-2015 01:40 PM
  18. Jorge Holguin's Avatar
    I have SP1 and I haven't install it there yet I am going to way little bit more for the OS to get more polish. Although, I installed on my Acer laptop.
    01-25-2015 01:41 PM
  19. PepperdotNet's Avatar
    It has bugs but that's what I expected, no big deal.

    I went to display resolution and made everything the largest size. That made it a lot easier to use.
    01-25-2015 03:31 PM
  20. Benjec83's Avatar
    I have the Start screen problem on my laptop too
    01-26-2015 01:10 AM
  21. Roland Stoll's Avatar
    I would hold off. I ran the upgrade - took about 30 minutes. Now my SP3 is unusuable. When it booted into Win10 the screen sat and constantly flashed. Touch didn't work. Pen worked for a few seconds then quit. Then the whole system froze and it shut down. Now it is stuck at the "Choose an Operating System" screen with two options - Windows Technical Preview and Windows Rollback. Tried doing the volume up power restart. Didn't work. Still stuck. Beware.
    same here... rollback to 8.1 was quite complicated - took me the whole weekend... :(
    01-26-2015 04:50 AM
  22. Alex Rodriguez Jr.'s Avatar
    Those of you having performance issues (running hot, bad graphics, glitch screens) please manually updated your graphics driver. I was having terrible issues. Then, I uninstalled the driver, and tried running the Intel installation as I did on 8.1. It wouldn't stick. So, I pointed Windows Device Manager to the driver folder, and it forced the install. Ever since, this thing has been giving me tremendous battery life, graphics are buttery smooth, and my screen adjusts auto - not to mention the Surface stopped running at 1000 degrees.
    01-26-2015 07:41 AM
  23. daniel329's Avatar
    Those of you having performance issues (running hot, bad graphics, glitch screens) please manually updated your graphics driver. I was having terrible issues. Then, I uninstalled the driver, and tried running the Intel installation as I did on 8.1. It wouldn't stick. So, I pointed Windows Device Manager to the driver folder, and it forced the install. Ever since, this thing has been giving me tremendous battery life, graphics are buttery smooth, and my screen adjusts auto - not to mention the Surface stopped running at 1000 degrees.
    Yeah there just seems to be a lot of confusion about which driver to install....
    01-27-2015 08:56 AM
  24. cgavula's Avatar
    I installed the Intel .4080 driver and video stabilized a lot but I still have a lot of video related issues. Video de-synchronizing over time, graphic anomalies in games like Magic Puzzle, a lot of IE video crashes and stuttering on YouTube in Firefox. The start menu sometimes "sticks", Kindle doesn't rotate correctly (video tearing occurs), and numerous other issues - mostly video driver related.

    ​I'd be curious to know what you meant by "pointed WDM at the driver folder". Exactly what process did you follow? I had to kind of force the install but I might try your uninstall/install process to see if its any cleaner. If you can detail that a little better and indicate what driver version you used it would give all of us something else to try.
    01-27-2015 05:59 PM

Similar Threads

  1. Install Jan TP on SP3? Read this first
    By BaritoneGuy in forum Microsoft Surface Pro 3
    Replies: 13
    Last Post: 01-29-2015, 03:24 AM
  2. Is it possible too upgrade ram on a surface pro 3
    By mtb1 in forum Microsoft Surface Pro 3
    Replies: 5
    Last Post: 01-25-2015, 06:27 PM
  3. Build 9841 to very latest?
    By jm4cc in forum Windows 10 Insider Preview
    Replies: 1
    Last Post: 01-23-2015, 01:39 PM
  4. What are the advantages of updating to Windows 10 preview ?
    By MAHER_Central in forum Windows 10 Insider Preview
    Replies: 1
    Last Post: 01-23-2015, 01:08 PM
  5. Major Nelson takes us on a tour of the Xbox app for Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-23-2015, 01:00 PM
LINK TO POST COPIED TO CLIPBOARD