1. RodimusMajor's Avatar
    So I've managed to reinstall the new build after my troubles yesterday, but my AMD graphics drivers are completely borked. Every time I boot up, I get a warning saying that I have the wrong drivers for the device/OS or something, and not only has it rendered me unable to play games, but it seems to have killed Netflix and other video playing stuff too. Anyone else have this problem? I'm using an Acer Aspire V5-552P-X617; A10-5757M CPU; Radeon HD 8650G.
    01-24-2015 01:52 PM
  2. JamesDax's Avatar
    When I installed the TP it installed the proper graphic drivers by default. I have a HD 5750. The only problem I had was the black borders around my 1080p monitor. I was able to install the latest AMD Catalyst Control Center to fix that. All has been well since. So, go grab the latest 8.1 drivers for your chipset and gpu from AMD and you should be good to go.
    01-24-2015 08:49 PM
  3. Soypan's Avatar
    A fix is going into your BIOS and disabling secure mode, or setting boot mode to UEFI+CSM (legacy) or just setting Legacy Mode to "ON" (depends on your manufacturer). This was found by a user in the Windows Insider Forums, it's worked for a bunch of people.
    01-25-2015 10:36 AM
  4. Ed Boland's Avatar
    I'm also having trouble with my video card drivers, though mine is a GeForce GTX 295. Tried a couple different versions, tried forcing them in device manager, and also tried installing them in "Windows 8 compatibility mode" so far, no luck.. Still looking for a solution.
    01-25-2015 11:12 AM
  5. kg4icg's Avatar
    Have no problems with my GTX770. Might be some of the older cards having problems.
    01-26-2015 10:12 AM
  6. JamesDax's Avatar
    Have no problems with my GTX770. Might be some of the older cards having problems.
    My HD5570 is pretty old. No problems at all here.
    01-26-2015 01:51 PM
  7. ttsoldier's Avatar
    Mine is pretty broken as well. Got a laptop with amd 7670hd.. broken. Drivers just will not install.
    01-26-2015 02:13 PM
  8. dawindbag's Avatar
    Having all kinds of issues with my display drivers. I have an older desktop I'm using as the guinea pig and it's ATI Radeon HD 6450 card works, but I have the black border issue on my HD display.

    ​Originally I upgraded 8.1 to 10 and it was a bad experience, none of my store apps were updating and wouldn't open. I uninstalled the AMD Catalyst Control Center and performance improved, but the black borders remained. I then did a clean install of Windows 10 and the performance is much better and the store apps are downloading and working, but I'm running only on the stock graphics drivers. Still have a black border.

    ​I may try and install the Catalyst Control Center again and see if I have the 1080p option this time, but I'm skeptical. We'll see.
    01-27-2015 09:09 PM

Similar Threads

  1. Why does my settings app crash when I try to open it (Windows 10)?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2015, 12:33 AM
  2. How do I do these things in Windows 10 build 9926?
    By Deepak in forum Windows 10 Insider Preview
    Replies: 18
    Last Post: 01-26-2015, 05:11 PM
  3. Windows 10 Build 9926
    By jordanzhninja in forum Windows 10 Insider Preview
    Replies: 2
    Last Post: 01-24-2015, 04:35 PM
  4. Windows 10 phone question?
    By arbyjr in forum Nokia Lumia Icon
    Replies: 8
    Last Post: 01-24-2015, 03:28 PM
  5. Cortana on Windows 10 TP
    By saras112 in forum Windows 10 Insider Preview
    Replies: 0
    Last Post: 01-24-2015, 01:07 PM
LINK TO POST COPIED TO CLIPBOARD