1. 123gettothechopper's Avatar
    Hey guys, after a lot of hardship, I was able to install Windows 10 on my Mac. I waited a few days after the Windows 10 event to install the new build. Now, I face yet another conundrum. The PC Settings show that it is downloading the build but I'm unsure if progress is being made. I'll edit the post later, with a screenshot
    Help will be appreciated

    EDIT: SCRREENSHOT ATTACHED

    preview-build.png

    EDIT 2: My Internet connection is moderately fast at 15 Mb/s, I've left the laptop like this for a while but no cigar.
    Last edited by 123gettothechopper; 02-01-2015 at 12:36 AM.
    02-01-2015 12:11 AM
  2. 123gettothechopper's Avatar
    UPDATE: It seems, the build has been downloaded but can't be installed. Attaching a screenshot
    preview-build-2.png
    02-01-2015 01:55 AM
  3. 123gettothechopper's Avatar
    UPDATE: The laptop attempted to install the build, but to no avail. It restarted (s), but no changes were/are to be found. I have updated it to the latest update available for my current build.
    Regards,
    02-03-2015 11:50 AM

Similar Threads

  1. Are we getting WP10 tomorrow?
    By AVerifiedDeath in forum Ask a Question
    Replies: 52
    Last Post: 02-02-2015, 07:14 PM
  2. How do I get Cortana working on my Build 9926?
    By Malay Agarwal in forum Windows 10 Insider Preview
    Replies: 8
    Last Post: 02-02-2015, 04:15 AM
  3. Replies: 7
    Last Post: 02-01-2015, 06:30 PM
  4. Issues with Lumia denim on L1520
    By Qais Abu-Hasan in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 02-01-2015, 01:11 PM
  5. "Resuming...." WTH is going on?
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 02-01-2015, 09:50 AM
LINK TO POST COPIED TO CLIPBOARD