The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
03-21-2015 10:07 PM
31 12
tools
  1. Ambious's Avatar
    I upgraded through Windows Update, and so far:
    • "Exporer.exe" crashed, then crashed when I hit CTRL+ALT+DEL and I had to powercycle
    • Some store apps became unavailable, and when I try to install from store they error out
    • Beta store suddenly "Not available in your region"
    • The whole Settings app is Right-To-Left despite my language being English! (it goes back when I change my regional time settings, but why are those even related to language?!)
    • Right click with pen is dodgy at best
    • Wifi module crashed when I tried connecting to my Uni. network, twice.
    • Open programs crash. A lot.
    • Opening any setting window not from the main screen (like "Wifi" etc.) opens smack in the middle instead of at the top

    And that's all just the NEW bugs.
    TechFreak1 likes this.
    03-19-2015 09:47 AM
  2. Jas00555's Avatar
    Why on earth did you opt into the fast ring if you didn't want as many problems?

    Sorry, but this is your own fault lol

    Edit: Ok, you changed the title now. All if forgiven :p
    Last edited by Jas00555; 03-20-2015 at 04:53 PM.
    Likwidz, xandros9, a5cent and 2 others like this.
    03-19-2015 09:50 AM
  3. drjekel_mrhyde's Avatar
    Yeap. I'm having sound card driver issues. How do we roll back to 9xxx
    03-19-2015 09:51 AM
  4. DavidinCT's Avatar
    Hmmmm besides it taking almost an hour to install, I have had none of the issues above in my trial last night for about 2 hours while doing stuff.

    In fact it seems faster and more stable than the last build. Also Windows programs run on this one that the last build would not even open.
    03-19-2015 09:53 AM
  5. Ambious's Avatar
    I'm not COMPLAINING, I'm sharing and observing.
    Also, the point wasn't that I didn't expect problems, but that I didn't expect regression in things that were working fine before.
    Yes, I know that's how things work - again, I'm just making an observation.
    The stuff that DOES work DOES indeed seem faster and more responsive, and yes the Windows programs seem to load much faster.
    TechFreak1 likes this.
    03-19-2015 09:55 AM
  6. Adretheon's Avatar
    Yeap. I'm having sound card driver issues. How do we roll back to 9xxx
    ​Go to the setting and to restore to a previous version. That'll take you back to 9xxx. However you'll lose your start menu I assume like many others.
    03-19-2015 09:58 AM
  7. xandros9's Avatar
    Why on earth did you opt into the fast ring if you didn't want as many problems?

    Sorry, but this is your own fault lol
    To his credit though, that's not normal operation, even for the Preview.

    Yes, you signed up for early builds in exchange for stability, some privacy, etc. But something is wrong with his install.
    If it were me I'd try the sfc /scannow command to see if there's corruption.
    Perhaps simplest, a clean install could help.

    No those are not bugs that reflect this build as a whole, my computer has its quirks while another computer with the same OS doesn't. It doesn't "suck," its the reality of unfinished, nowhere-near-imperfect code that simply resulted in you getting the short end of the stick.
    03-19-2015 10:00 AM
  8. Ambious's Avatar
    I'll try that, thanks for the tip.
    Does anyone know how the whole "Refresh your PC" thing work after you upgrade the build? Will it just reinstall the old build and 'upgrade', or is it a way to get a clean install of the new build?
    03-19-2015 10:04 AM
  9. Jas00555's Avatar
    To his credit though, that's not normal operation, even for the Preview.

    .
    Oh, I get that. I was referring to his title "So, Build 10041 sucks".
    03-19-2015 11:13 AM
  10. PepperdotNet's Avatar
    ​Go to the setting and to restore to a previous version. That'll take you back to 9xxx. However you'll lose your start menu I assume like many others.
    Indeed. So how do I get the start menu working again, now that I'm back at 9926? Typing out the name of everything I want to launch in the Cortana box is gonna get old real quick.

    It forgot a lot of other stuff too like my user profile picture and wireless passwords.

    Edit: found a fix, launch PowerShell in admin mode, paste this there and push enter:
    Code:
    Get-appxpackage -all *shellexperience* -packagetype bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + “\appxmetadata\appxbundlemanifest.xml”)}
    wait a minute then it should be working again. (credit to http://www.rbrussell.com/2015/01/30/...pps-wont-work/)
    Last edited by PepperdotNet; 03-19-2015 at 11:55 AM.
    TechFreak1 likes this.
    03-19-2015 11:37 AM
  11. jhoff80's Avatar
    Honestly, more than the bugs, what sucks is the direction they're taking this (on tablets). The new start screen? Terrible (and that's not including the bug where it crashes if I try to scroll past F in 'all apps'. The tablet input panel (for handwriting recognition)? New in this build, it's completely downgraded from what already was a huge downgrade in Windows 8. Snapping? Completely downgraded. If you switch between apps, then you lose your snapped window. The always visible taskbar on tablets? Just poor design, akin to the days of Windows XP Tablet Edition, Windows Vista, and Windows 7 tablets.

    And if they're launching this summer, they're running out of time. It's been nearly two months since the last preview and the only tablet mode improvement is that we can turn off the notifications for it.

    I get that they needed to improve the experience for desktop users, but the pendulum is swinging way too far in that direction even on tablets.
    920Walker and Joe920 like this.
    03-19-2015 11:38 AM
  12. markyjns's Avatar
    Agree completely, for desktop it's great but on an SP3 the Start Screen is terrible, I know its a preview but the direction of travel is wrong in tablets.

    The taskbar should not be present on the Start Screen, way to look stupid and clumsy!
    But my biggest gripe is the jump list on the left hand side of the Start Screen, talk about design awkwardness, its in the way, takes up vital screen real estate and is completely illegible as the background is transparent. Please remove the list or better still make its presence optional.
    jhoff80 likes this.
    03-19-2015 11:49 AM
  13. anon(5445874)'s Avatar
    cabugequkaaeh89.jpg

    This is just simply the worst thing anyone has released into the public. It's so ugly & nasty. Just going to the start menu makes me want to vomit.
    920Walker likes this.
    03-19-2015 12:22 PM
  14. jhoff80's Avatar
    Click image for larger version. 

Name:	CAbUGeQUkAAeh89.jpg 
Views:	166 
Size:	28.3 KB 
ID:	100049

    This is just simply the worst thing anyone has released into the public. It's so ugly & nasty. Just going to the start menu makes me want to vomit.
    The transparency thing is at least a known issue. But I think the whole left bar is terrible design for tablets, and the tiles feel cluttered and unorganized as they're on slightly less of a grid than they used to be. I've got many other complaints, but yeah, it feels like instead of things improving for tablets with every build that each one instead just frustrates me more and more.
    03-19-2015 01:38 PM
  15. nmercy's Avatar
    I hope everyone who is complaining in here is also doing so in the Windows Feedback app as they all sound like they would be improvements if implemented.

    I'm finding this build to be much more stable than the last one and feels like it's working much more as intended.
    03-19-2015 01:51 PM
  16. Ambious's Avatar
    Oh, I get that. I was referring to his title "So, Build 10041 sucks".
    Would you have been bothered less by "Build 10041 sucks compared to 9926"?


    I hope everyone who is complaining in here is also doing so in the Windows Feedback app as they all sound like they would be improvements if implemented.
    Definitely, I'm not in this just to get early software, I'm doing my part to improve it as much as possible.

    I'm finding this build to be much more stable than the last one and feels like it's working much more as intended.
    I'm guessing it has a lot to do with specific setups. There are so many variables, you'd never know what causes one system to misbehave and the other not to.
    The consensus seems to be that it is indeed more stable and robust, albeit being ugly.
    Since it keeps crashing and misbehaving for me, I have to assume the problem is local to me.
    03-19-2015 02:41 PM
  17. markyjns's Avatar
    Already provided feedback and will continue to do so, I really like a lot of W10, its just the bloody Start Screen is a joke compared to the beauty and elegance of 8.1
    920Walker likes this.
    03-19-2015 02:41 PM
  18. a5cent's Avatar
    I'm not COMPLAINING, I'm sharing and observing.
    In that case you won't mind that I took the liberty to change your thread title from "So, 10041 sucks" to something more in line with "sharing and observing"
    03-19-2015 02:47 PM
  19. PepperdotNet's Avatar
    OK, I just upgraded a virtual machine from 9926 to 10041, and am seeing none of the aforementioned issues from my SP3, except for the mail/people/calendar thing and weird Windows Update behavior because my network is on WSUS. I'll use that one to generate feedback since it was useless trying to do anything on the SP3.
    03-19-2015 04:01 PM
  20. Conan143's Avatar
    Why on earth did you opt into the fast ring if you didn't want as many problems?

    Sorry, but this is your own fault lol
    Well to me he isn't bragging about bugs but he seems to enlighten the insiders that they are new bugs :)
    03-20-2015 12:37 AM
  21. iyae's Avatar
    Click image for larger version. 

Name:	CAbUGeQUkAAeh89.jpg 
Views:	166 
Size:	28.3 KB 
ID:	100049

    This is just simply the worst thing anyone has released into the public. It's so ugly & nasty. Just going to the start menu makes me want to vomit.
    I submitted this in the feedback, but it would be worth voting on; all they really need to do is (in tablet mode) make the desktop and taskbar hide (so just show the wallpaper as it looked in 8.1) when you open the start menu. That would make the start menu in tablet mode MUCH better
    anon(5445874) likes this.
    03-20-2015 02:20 AM
  22. iyae's Avatar
    Anyone else having issues with modern apps? (i.e. they aren't useable unless you are in tablet mode. parts of the app are off screen, the appbar doesn't show up etc..)
    03-20-2015 02:20 AM
  23. mhc48's Avatar
    I'm finding it far more flaky than past builds.
    03-20-2015 09:25 AM
  24. Zulfigar's Avatar
    I'm having an issue with the "Show More Icons" button on the bottom right. It shows to be there, but I can't click it (when I left or right click, it's like it isn't there).

    Anyone got this issue?
    03-20-2015 09:35 AM
  25. Jazmac's Avatar
    I'm not having trouble with much of anything significant with 10041 myself. The only thing that I'm having trouble with is I usually use a 4 digit code to unlock my PC. I have the code set, it says its set, but in order to unlock my PC is to use my Live password. Beyond that, everything seems to work for me. I installed a game on this build called Cities Skylines yesterday to see how it functions with a larger, memory/video intensive app and it played just fine.
    IE struggles from time to time but I don't use it for very long beyond downloading Firefox. I keep it as my default browser just the same though. To be clear, I'm running this on my desktop, where this OS should be run. So its expected that it would have more stability than on a tablet. Corel Draw X7 runs beautifully as well. Plex runs well too. Speaking to Cortana doesn't work at all but typing in the Cortana window does work. I can't tell if it has trouble with my bluetooth head phones or not but no joy there.
    03-20-2015 11:58 PM
31 12

Similar Threads

  1. Pictures / Video Taken With Your Lumia 430
    By RumoredNow in forum Microsoft Lumia 430
    Replies: 8
    Last Post: 11-30-2015, 05:20 AM
  2. IE Crashing on build 10041
    By kendric84 in forum Windows 10
    Replies: 1
    Last Post: 03-20-2015, 02:24 AM
  3. How to access your music collection from OneDrive with Xbox Music
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-19-2015, 02:30 PM
  4. Band work well with 1020?
    By clemgrad85 in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 03-19-2015, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD