1. kwill's Avatar
    Has anyone had issues with the System Hardware Update from 5/14/2015 installing fine and then later on it will say that it needs to install? It keeps happening and I can't figure it out.
    05-27-2015 09:49 AM
  2. Pete's Avatar
    I have the same. Firmware updates never seem to fully install in Windows 10 for me on my Surface Pro 3 (I assume you're talking about the same device). I always either get an error to say it didn't install, or it thinks it's installed and prompts a reboot. The next day, the same update appears again.
    05-27-2015 09:53 AM
  3. kwill's Avatar
    Yes, sorry about that. I'm using a SP3. But, yep, it happens the same with me for this system update. All others have actually installed fine for me...just the problem with this particular one.
    05-27-2015 10:10 AM
  4. hnic29's Avatar
    I'm having the same issue. What is this update about anyways?
    05-29-2015 10:33 AM
  5. kwill's Avatar
    Not sure now. I finally just went back to 8.1. The bug with the lockscreen blanking if I was using a picture password and the crashes in general just made me move on.
    05-30-2015 01:13 AM
  6. hotphil's Avatar
    It's been an issue with all Surface Pros for quite a while. There was something I read about it being related to if the user has ever done a system restore/installed another OS through the BIOS. But that seemed to be not fully correct. Even more annoying is that (from what I can see) in 10, you can't hide/dismiss/decline the update. It just keeps on wanting to reinstall.
    05-30-2015 01:37 AM
  7. lcpljones's Avatar
    Count me in as well. Is it strange to be glad I am not alone? I have submitted this to the feedback app...hopefully we can get a fix at some point.
    06-09-2015 05:48 PM
  8. hotphil's Avatar
    I wouldn't hold your breath - it's been an issue since the first update for the first Surface Pro. And still no fix.
    06-09-2015 06:32 PM
  9. rmac1813's Avatar
    I'm glad I'm not the only surface pro 3 user with this problem with Windows 10 (build 10130).
    I did try downloading the update manually, but cannot find a firmware pack with the 5/14 date.
    06-15-2015 05:09 PM
  10. jdowsett's Avatar
    Same issue here. Reply back if anyone finds something. I did do an OS re-install via BIOS also if anyone is counting.
    06-24-2015 05:49 PM
  11. Mark Kaplan's Avatar
    Same here. Get prompted to install it every day or so and it seems to complete but still getting prompted.
    06-27-2015 02:07 PM
  12. bldg7's Avatar
    I also have this issue on my Surface Pro 3. Is there a way to check and see if it is installed?

    Posted via the Windows Central App for Android
    loofmodnar likes this.
    06-27-2015 10:34 PM
  13. jtzako's Avatar
    Mine finally installed tonight after the 10159 build finished installing.
    07-01-2015 01:19 AM
  14. Mark Kaplan's Avatar
    Mine too. At least I think it did....
    07-01-2015 02:09 PM
  15. Mark Kaplan's Avatar
    Scratch that. Was just prompted to install it again.
    07-01-2015 05:24 PM
  16. Mark Kaplan's Avatar
    Ok, after installing 10162 I was prompted to again install the 5/14 hardware update. This time it is listed in my history as successful.
    07-02-2015 08:39 PM
  17. slickxsparkie's Avatar
    Oh there's finally a fix? I had this forever! On SP1
    07-02-2015 08:51 PM
  18. hotphil's Avatar
    Not necessarily - after a "successful" installation it will often try another installation and fail. And fail. And fail....
    07-02-2015 08:53 PM
  19. PepperdotNet's Avatar
    07-02-2015 10:31 PM
  20. Mark Kaplan's Avatar
    Well, its back after installing the final build on my SP3. I've tried all posted fixes.
    • System Firmware Update - ‎5/‎14/‎2015 - Error 0x8024004c
    07-15-2015 10:24 PM
  21. ConradM's Avatar
    After running disk clean up to remove the Windows.old folder on C:\ drive, do some folders remain behind which contain some Surface-specific .sys driver files?

    I had the same problem after deleting these files, but they have since reappeared and I'm not having problems any more (not sure if it's a coincidence)
    07-16-2015 08:17 AM
  22. Pete's Avatar
    This appears to have been installed for me after moving up to the latest Windows 10 build (it appears in the list of installed updates now).

    Remains to be seen whether it returns in the next couple of days.
    07-16-2015 08:21 AM
  23. jlangner's Avatar
    I have had to install after every build (yesterday included) but only one time per build.
    07-16-2015 02:22 PM

Similar Threads

  1. AT&T One (M8) GDR2 Update?
    By GReeN SCoRPioN 8K in forum HTC One (M8) for Windows
    Replies: 12
    Last Post: 06-12-2015, 09:30 AM
  2. Why aren't my Photos and Music updating?
    By vipulgog in forum Windows Phone 8.1
    Replies: 1
    Last Post: 05-27-2015, 12:43 PM
  3. Why system uses ~9.11 gb of phone memory on my lumia 1520?
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 05-27-2015, 11:00 AM
  4. Overkill 3 for Windows Phone adds leaderboards in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-27-2015, 09:11 AM
  5. Xbox Music picks up bug fixes and minor improvements in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-27-2015, 12:30 AM
LINK TO POST COPIED TO CLIPBOARD