1. KarateDad's Avatar
    I have a surface 3 (NOT PRO) running windows 10. Windows tried to automatically install build 10130, but it fails every time. It goes through windows update, and reboots, then it is at the BIOS screen that just says "Surface" and sticks there for hours. Hold down the power button for 10 seconds to force a reboot, and it goes back to build 10122. I've tried it 4 or 5 times.

    I had to go back to the slow ring to stop it from continually retrying the upgrade.

    Am I the only person crazy enough to run Win10 on their shiny new Surface 3 ?
    06-01-2015 10:18 AM
  2. Benjaminiun Harpit's Avatar
    +1

    exactly as above.
    KarateDad likes this.
    06-01-2015 11:31 AM
  3. H Seldon's Avatar
    I'm having the same issue. And I have the iso for 10130 as well and tried doing a clean install. Same issue, stuck at the Surface logo.
    06-02-2015 12:41 PM
  4. Scott Lambert1's Avatar
    Same for me. I don't have a problem with it, but I wish they would make a note of this. So I don't bust my nose on it. When the surface 3 was released it apparently took Microsoft by surprise, that someone might try to install it on a 3. Now the same thing has happened again. Perhaps no one at Microsoft owns a surface 3.

    Ah, well thanks to us now they know. Does anyone think that they will test a surface 3 on the RTM?

    Scott
    06-02-2015 02:46 PM
  5. d0m1's Avatar
    06-02-2015 04:36 PM
  6. makeshiftballer's Avatar
    Same. Seems to be a surface 3 issue. Bummer. Hopefully they push out a fix soon!
    06-02-2015 10:05 PM
  7. H Seldon's Avatar
    10125 installs fine (I have access to a lot of different builds). I'm running that right now until a new build comes out.
    06-02-2015 10:58 PM
  8. Mr. Brown's Avatar
    I'm having the same issue. And I have the iso for 10130 as well and tried doing a clean install. Same issue, stuck at the Surface logo.
    I'm glad I saw your post that you tried with the 10130 iso and that it still doesn't work. I don't want to waste time on trying it now.
    06-03-2015 02:34 PM
  9. H Seldon's Avatar
    I'm waiting for a new build to drop internally. So far nothing new.
    06-03-2015 03:39 PM
  10. H Seldon's Avatar
    So the 10135 iso dropped internally finally. Doesn't work, same issue. I did see the latest MS dashboard, so maybe we'll get lucky with 10146.
    06-17-2015 08:04 AM
  11. H Seldon's Avatar
    Just waiting for the legit copy of 10147 to download (mine comes from MS). I should know this weekend if it works with the Surface 3.
    angelblast1997 likes this.
    06-19-2015 05:09 PM
  12. H Seldon's Avatar
    I have 10147 installing right now. 16% done. Looks like they fixed the issue.
    06-20-2015 09:06 PM
  13. chasvs's Avatar
    Where did you get 10147????
    06-24-2015 08:56 AM
  14. H Seldon's Avatar
    Where did you get 10147????
    I work for a large company that gets weekly builds from MS. But MS is also a customer of mine and I work out of a MS office, that also brings some benefits.
    seanpr likes this.
    06-25-2015 10:36 AM
  15. H Seldon's Avatar
    10154 is now installed. The Surface 3 feels very quick, though I'm frequently having Intel graphics driver crashes. Hopefully when MS releases an updated TP, the driver situation will be better.
    06-29-2015 03:39 PM

Similar Threads

  1. Build 10130: VPN unusable. What should I do?
    By KarateDad in forum Windows 10
    Replies: 2
    Last Post: 06-02-2015, 08:05 PM
  2. How can I get my Windows 10 reserve working?
    By reuven Hershkovitz in forum Windows 10
    Replies: 2
    Last Post: 06-02-2015, 08:54 AM
  3. Will insider get a fresh FREE copy of RTM Windows 10?
    By Nishad Thakur in forum Windows 10
    Replies: 2
    Last Post: 06-01-2015, 01:17 PM
  4. Windows 10 build 10134 may be next for Fast ring users, 10130 could go to Slow ring
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-01-2015, 09:50 AM
  5. Windows 10 will be pre-loaded on your PC ahead of its July 29 launch if you upgrade
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-01-2015, 09:30 AM
LINK TO POST COPIED TO CLIPBOARD