1. vincentw56's Avatar
    Title says most of it. I can't uninstall to try to reinstall it. Funny thing is it still runs in the background because I get notices about new email and events pop up. It is just that when I try opening the apps they crash. I know there are others having the issue so I thought I would make a thread about it in case someone finds a fix.
    Sur Komm likes this.
    07-01-2015 01:03 PM
  2. Kyle Stilkey's Avatar
    Title says most of it. I can't uninstall to try to reinstall it. Funny thing is it still runs in the background because I get notices about new email and events pop up. It is just that when I try opening the apps they crash. I know there are others having the issue so I thought I would make a thread about it in case someone finds a fix.
    Try the Powershell command that will refresh your installed app list and see if that can fix it and get it out of its funk.

    Run Powershell as an Administrator and paste this line into it.

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    See if that solves it. If not, there is a PowerShell command to manually remove apps and is a little bit more involved. If that simple method didn't work let me know and I'll place the steps.
    rdubmu likes this.
    07-01-2015 01:10 PM
  3. Medioholik's Avatar
    I have similar problem with People and Phone Companion apps. They just start to splash screen and then crash. Unfortunately PowerShell command that You posted doesn't work. I could reinstall phone companion app and install via store but it doesn't help.
    07-01-2015 01:43 PM
  4. vincentw56's Avatar
    Try the Powershell command that will refresh your installed app list and see if that can fix it and get it out of its funk.

    Run Powershell as an Administrator and paste this line into it.

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    See if that solves it. If not, there is a PowerShell command to manually remove apps and is a little bit more involved. If that simple method didn't work let me know and I'll place the steps.
    I tried that from another post I read. It didn't work.
    07-01-2015 01:45 PM
  5. Kyle Stilkey's Avatar
    OK to manually remove Window Apps from your computer here is the steps to follow. Before proceeding remember, anything you modify with your system is all done by you and I take no responsibility if things break or get worse. Only proceed if you know how to repair systems if something is to go wrong.

    I highly recommend making a system backup before you begin incase anything goes wrong. If you understand this then follow the steps.




    1. Run PowerShell as Administrator.
    2. Type in Get-AppxPackage *officehub*
    3. That should bring up a program that says Microsoft.MicrosoftOfficeHub
    4. Copy the PackageFullName down exactly as it's shown.
    5. Type in remove-appxpackage (Then your FullPackageName here) Example: remove-appxpackage Microsoft.MicrosoftOfficeHub_17.4218.23751.0_x64__8wekyb3d8bbwe
    6. Type in Get-AppxPackage *communications*
    7. That should bring up the program that says Windows.Live.Communications
    8. Copy the PackageFullName down exactly as it's shown.
    9. Type in remove-appxpackage (Then your FullPackageName here)
    10. Your Mail and Calendar apps should now be removed, just go to the store and re-download them.

    NOTE: YOU MAY NEED TO RESTART YOUR PC TO TAKE AFFECT.
    Last edited by Kyle Stilkey; 07-01-2015 at 05:16 PM.
    vincentw56 likes this.
    07-01-2015 03:15 PM
  6. Kyle Stilkey's Avatar
    I have similar problem with People and Phone Companion apps. They just start to splash screen and then crash. Unfortunately PowerShell command that You posted doesn't work. I could reinstall phone companion app and install via store but it doesn't help.
    Companion app doesn't work at all, but People Hub is a hit or miss it seems. I use to have major issues but now it works. Follow the steps I had above but instead search for Get-AppxPackage *People* to get just that app and not every WIndows App installed. Remember the same warning I posted applies so if you don't think it's safe then I would hold off and wait for a new build.
    07-01-2015 03:20 PM
  7. vincentw56's Avatar
    That did it. The only thing I had to do was remove the "windows.live.communications" using the command. The other one didn't remove the mail app. I then rebooted and installed it. Worked! Thanks so much.
    07-01-2015 04:08 PM
  8. Kyle Stilkey's Avatar
    That did it. The only thing I had to do was remove the "windows.live.communications" using the command. The other one didn't remove the mail app. I then rebooted and installed it. Worked! Thanks so much.
    Glad to know man, I'll update my post reflecting that so others that have this issue will know how to fix it.
    07-01-2015 05:13 PM
  9. MBY's Avatar
    I'm also having problems with these apps in 10159. 10158 took a big step forward with Mail finally syncing sent mail. But now the apps lost their icons on the taskbar. Reinstalling from the store just crashes it. The worst part is that I can't even tell Microsoft because the feedback app won't load in this build either.
    07-01-2015 09:44 PM
  10. Hestev's Avatar
    Hi,

    I uninstalled Mail and Calendar but unable to download them again from the Store.
    07-02-2015 01:00 PM
  11. vincentw56's Avatar
    Hi,

    I uninstalled Mail and Calendar but unable to download them again from the Store.
    I had the same issue until I rebooted. Once I rebooted, I was able to reinstall it.
    07-02-2015 01:03 PM
  12. RicoFrost's Avatar
    On the wifes PC mail is crashing a bit with the 10162 build
    07-03-2015 02:47 AM
  13. FLJeepGuy's Avatar
    10162 killed my Mail, Calendar, and Music apps. All of them open and immediately close. I've tried the PowerShell commands to re-register all the apps, plus the PowerShell commands to manually uninstall them and then download again from the store. Even the store app bombs out occasionally. They really fubar'ed something in this build.
    07-03-2015 07:54 PM
  14. pbike908's Avatar
    I had this problem when I initially installed 10162. A couple of restarts later and then downloading updated apps from the store fixed everything. I have seen similar posts in other forums that sometimes it takes a couple of restarts to get all the apps working correctly -- especially the store. also try running wsreset from an elevated command prompt and then restart your computer.
    07-03-2015 09:06 PM
  15. Norman Acunis's Avatar
    Thank you. So many have posted stuff on this that didn't work. I used the commands with the results from communications which covers mail and calendaring and for the first time, it worked perfectly! Nice job on the documentation.
    07-04-2015 07:33 PM
  16. Kyle Stilkey's Avatar
    Thank you. So many have posted stuff on this that didn't work. I used the commands with the results from communications which covers mail and calendaring and for the first time, it worked perfectly! Nice job on the documentation.
    No problem, glad this fixed your issue. I wish we could figure out why this is happening. I've had no issues on my wife's PC till this build yet I've had app issues every build till this one. I'm just bot sure why they are failing to install correctly. I think it's with the new store as its failing to register them correctly.
    07-06-2015 11:00 PM
  17. vodda's Avatar
    Guys, a little bit of help please.

    I had similar problems with Store, it did not want to start and just shuts down. So I thought I can do the same as described in this thread, remove it, download new and install again, via PS.

    I am stuck now as I cant download the proper package, the command Get-AppxPackage *store* does not work. I still have the old package name as I've used it to remove-appxpackage it, but using the Get-AppxPackage "real package name, the one I removed a few minutes ago" does not work aswel.

    Any ideas where to get the WindowsStore package?
    07-11-2015 01:47 AM
  18. vodda's Avatar
    I get it, the get-appxpackage shows only installed apps, as I've removed store, its no longer on that list.

    The question now is, how to get the Store app package from online source so I can install it again?
    07-11-2015 02:12 AM
  19. Kyle Stilkey's Avatar
    I get it, the get-appxpackage shows only installed apps, as I've removed store, its no longer on that list.

    The question now is, how to get the Store app package from online source so I can install it again?
    You can't, the thing you can do is run the command I listed i believe in the second post and this will reinstall all apps including the store. If it doesn't you'll have to either wait for a new build or reinstall.
    07-12-2015 04:09 PM
  20. vodda's Avatar
    It doesnt :/

    Hope new build is just around the corner :)
    07-13-2015 10:52 AM
  21. Kyle Stilkey's Avatar
    That's too bad, I'm sure there is as Microsoft is nearing release. The worse is you'll have to wait till the 29th which is not that far away.
    vodda likes this.
    07-13-2015 11:58 AM
  22. Sur Komm's Avatar
    I have the same thing, even after I updated my PC today 8/12/2015, mail/calendar/onenote/app store are still not working!
    08-12-2015 11:05 AM
  23. vincentw56's Avatar
    I have the same thing, even after I updated my PC today 8/12/2015, mail/calendar/onenote/app store are still not working!
    Your issue is probably different since this thread refers to an old insider build. There is an issue right now with the released version of Windows 10. Microsoft has said they are working on a patch that should be out soon.
    08-12-2015 11:18 AM

Similar Threads

  1. Office 2016 preview rolls out real-time collaborative typing for Word and more new features
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 07-17-2015, 11:46 AM
  2. Replies: 4
    Last Post: 07-03-2015, 02:43 AM
  3. Surprise! Here's what's new in Windows 10 build 10159
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 07-01-2015, 11:40 PM
  4. The latest CustomPFD is not working
    By Mark863 in forum Update 2 for Windows Phone 8.1 (GDR2)
    Replies: 0
    Last Post: 07-01-2015, 12:16 PM
  5. Why does the lightning tab keep coming up and does not work?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-01-2015, 11:30 AM
LINK TO POST COPIED TO CLIPBOARD