1. I3unny's Avatar
    I am in the process of downloading the update.. But I would like to know what you guys feel about win10 on 520.
    04-10-2015 09:53 PM
  2. Just Blank's Avatar
    just installed it, and have been messing around with it for about an hour, and performance is really sluggish. some issues i have found on the 520, at least for me,

    • no Project Spartan. it wasn't installed for me.
    • the Start button is not responsive most of the time. you have to press the back button a lot to get back to start.
    • can't enable/ disable Airplane Mode. the settings page is there, but there is no slider.


    still playing around with. please feel free to add on with issues you may have.
    I3unny likes this.
    04-10-2015 10:54 PM
  3. PepperdotNet's Avatar
    Home and back buttons both MIA. All I can do is launch Cortana or reboot.

    Wiping it back to 8.1 and will try again.
    04-10-2015 10:58 PM
  4. I3unny's Avatar
    just installed it, and have been messing around with it for about an hour, and performance is really sluggish. some issues i have found on the 520, at least for me,

    • no Project Spartan. it wasn't installed for me.
    • the Start button is not responsive most of the time. you have to press the back button a lot to get back to start.
    • can't enable/ disable Airplane Mode. the settings page is there, but there is no slider.


    still playing around with. please feel free to add on with issues you may have.
    I got project Spartan installed on my 520, start button is working but a bit laggy and yea I cant enable airplane mode has well.
    04-11-2015 12:11 AM
  5. Akash Patel's Avatar
    Are you guys able to install apps from store i always get error code 87af000b

    p.s : i did a hard reset after installing W10
    04-11-2015 12:14 AM
  6. akshay surya's Avatar
    I don't find option to change image of start screen (background image)
    04-11-2015 12:16 AM
  7. I3unny's Avatar
    Are you guys able to install apps from store i always get error code 87af000b

    p.s : i did a hard reset after installing W10
    Yes I am able to install apps from store. No such error for me.
    04-11-2015 12:31 AM
  8. I3unny's Avatar
    I don't find option to change image of start screen (background image)
    Go to settings->personalisation-> background
    04-11-2015 12:32 AM
  9. Akash Patel's Avatar
    Yes I am able to install apps from store. No such error for me.
    Okay trying hard reset once again to see if it is solved
    04-11-2015 12:39 AM
  10. Max Monteiro's Avatar
    Yes, I'm using it right now. It's working better than I expected, but i can't use the controller on the normal keyboard since it doesn't appear. I can't use the insider hub app to make reports too, I'm trying to figure out some way of using it, if anyone can help me, I'd be grateful
    04-11-2015 12:41 AM
  11. akshay surya's Avatar
    I haven't noticed any change in start screen and settings .... New outlook and calendar app aren't working/opening ... How about you guys
    04-11-2015 02:36 AM
  12. idoloo's Avatar
    doesnt works start button and data, a little bit laggy
    04-11-2015 06:05 AM
  13. uSlackr's Avatar
    my 520 is
    - slow (expected)
    - missing the Settings app (not expected)
    - Insider app won't open
    - not recognized by my laptop (not expected)

    I would like to reset the device but have no apparent option to do so.
    Last edited by uSlackr; 04-11-2015 at 12:56 PM.
    04-11-2015 11:26 AM
  14. kurotsuki's Avatar
    just installed it, and have been messing around with it for about an hour, and performance is really sluggish. some issues i have found on the 520, at least for me,

    • no Project Spartan. it wasn't installed for me.
    • the Start button is not responsive most of the time. you have to press the back button a lot to get back to start.
    • can't enable/ disable Airplane Mode. the settings page is there, but there is no slider.


    still playing around with. please feel free to add on with issues you may have.
    Same as this ... with additional issue. Same like Project Spartan, the new Settings app does not exist.

    @l3unny: How do you have your Project Spartan? Is it installed by default? I was subscribed to the fast ring one. Does this differ with the slow ring one?
    04-11-2015 12:26 PM
  15. WPmaniac4 25's Avatar
    Settings nor insider hub will open, project Spartan is nowhere to be seen and really laggy
    04-11-2015 12:55 PM
  16. I3unny's Avatar
    Same as this ... with additional issue. Same like Project Spartan, the new Settings app does not exist.

    @l3unny: How do you have your Project Spartan? Is it installed by default? I was subscribed to the fast ring one. Does this differ with the slow ring one?
    Hi, ya when I installed win10 it came by default. Each and every feature they said came to my phone by default. I was on fast ring.. No you wont get anything with slow ring. Btw I simply tried a hard reset(Not recommended at all after installing win10) to see what happens to my phone and after I did that, I got issues which many people have like settings not opening, no Spartan etc.. So I have revert back to 8.1 now. Win10 is way too laggy in 520 to be used tbh so I have decided to stay on 8.1 until a stable build comes.
    Last edited by I3unny; 04-12-2015 at 12:36 PM.
    04-12-2015 11:12 AM
  17. kurotsuki's Avatar
    I see. It also hampering my application which currently under heavy development because I need to update it as fast as I could. I guess I'll revert back to 8.1 too.
    04-13-2015 12:55 PM
  18. Sean LeJumpman Ngobeni's Avatar
    Is there any other way to roll back to 8.1 without a pc. Cause o don't have access to It... At the moment
    04-13-2015 01:01 PM
  19. Krystianpants's Avatar
    Mine is working fine. It was very barebones when I installed it. I had no apps installed outside of the ones it came with. I was just waiting to have windows 10 come out to install on it for playing around. I don't have a sim card though so only have wifi functionality. Spartan does work if I go directly to links but if I search it goes to bing search where results take me to internet explorer 11. The only time my start button fails to work is if I use a pinned setting that goes directly to the setting I want. Otherwise it works fine. But it is super slow. To me that's not a big problem since I can't expect to run the latest software on such an old phone. I hope that they disable certain features for 520 to keep it running smooth. We live in a fast paced technologically changing world and the fact that Windows 10 even runs on these puppies is crazy enough. Even iOS has dumped new version support for older models. I hope Microsoft doesn't sacrifice anything in order to support these phones.
    04-13-2015 01:08 PM
  20. kipet999's Avatar
    Installed it today, did a hard reset right after the installation. After all the apps reinstalled, I have played around with it for an hour, and it just looks weird. UI is a mix of android and windows, it lags, the home button is not working most of the time, or working, but not vibrating. Insider app is not working, Spartan is there, but it just redirects to an ugly and glitchy new cortana, that redirects to IE. People hub looks and acts like a prepre-alpha app. Dialer is terrible, calculator follows it's (lack of) design. Store is working just fine, just like the 3rd party apps. W10 is clearly in a really early stage, and as such, it's not optimized to run on 520's hardware.

    I'll keep it for a few days, but i'll revert to 8.1 100%.
    04-13-2015 01:35 PM
  21. I3unny's Avatar
    Lets wait for a build which would come for slow ring. I m pretty sure that one would work way better than this :)
    04-17-2015 08:39 AM

Similar Threads

  1. Anyone else getting this Error updating Windows 10 on 520?
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 04-12-2015, 03:57 AM
  2. My Nokia Lumia 925 won't turn on or charge?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-10-2015, 11:42 PM
  3. Big screen phone 📱 like lumia 1320 all icon ,setting,etc. Appears too small
    By Patel Guarav in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 04-10-2015, 11:16 PM
  4. 3 across on the front screen of my 630??
    By AaLF in forum Nokia Lumia 630
    Replies: 1
    Last Post: 04-10-2015, 10:23 PM
LINK TO POST COPIED TO CLIPBOARD