The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. stmav's Avatar
    Anyone?
    04-10-2015 10:27 PM
  2. t.mehoves's Avatar
    AT&T 1020 now on cricket working here (minus a few bugs here and there).
    stmav likes this.
    04-10-2015 10:29 PM
  3. btgusto's Avatar
    yes I have a 920 and it works
    04-10-2015 10:41 PM
  4. Kyle Stilkey's Avatar
    Both yes.
    04-10-2015 10:54 PM
  5. Guzzy's Avatar
    What did you guys do? My 920 isn't detecting my SIM card :/
    04-10-2015 10:55 PM
  6. Dusteater's Avatar
    Have an 1520 that works, 1020 does not, no SIM detected, cannot access phone apps or settings.
    04-10-2015 10:58 PM
  7. Lotema's Avatar
    My 1020 was working but it crashed when trying to download a PDF file and when it restarted, it has since been unable to detect the SIM.
    04-10-2015 11:14 PM
  8. tgp's Avatar
    My AT&T 920 updated to W10 just fine. It's not active though, so I cannot report anything about recognizing the SIM card. Otherwise it seems to be working as it's supposed to be.
    04-10-2015 11:18 PM
  9. tosvus's Avatar
    1020 ATT: No Sim Detected. On the first soft reset (since it locks up when lockscreen goes on), it did show cell with 0 reception, since then, No Sim.
    04-11-2015 01:23 AM
  10. trixsta587's Avatar
    My 920 on att took the update fairly well. Mms just doesn't work as of now.
    04-11-2015 01:30 AM
  11. Laura Knotek's Avatar
    Are you using slow or fast Insider?
    04-11-2015 01:39 AM
  12. WsqH's Avatar
    I updated my ATT 920 but I can't find Spartan and Outlook. Can't even find the old mail app. Whats wrong. Everything is slow and very buggy.
    04-11-2015 02:42 AM
  13. Laura Knotek's Avatar
    My AT&T 920 updated to W10 just fine. It's not active though, so I cannot report anything about recognizing the SIM card. Otherwise it seems to be working as it's supposed to be.
    Same here.

    Sent from my Nexus 7 using Tapatalk
    04-11-2015 03:46 AM
  14. kareem09's Avatar
    on ATT 920 (unlocked) in fast ring. I have the same problem with no cellular service. phone app also crashes. phone doesn't resume when I turn off the lockscreen either.
    The old mail clients aren't there. They are all in outlook mail and outlook calendar so jump to 'O' in the app list and have to pin them to start.

    phone is largely unusable with black screens and no cellular service though. I'll keep an eye on this thread for sure before I recover to win8.1
    04-11-2015 04:24 AM
  15. WsqH's Avatar
    I don't see Outlook in 'O', no old mail app either.
    04-11-2015 04:40 AM
  16. kareem09's Avatar
    did a hard reset and the phone is very usable now compared to how it was.
    before the phone was NOT* (edit) waking up. sim and cellular were off. all kinds of crashes and glitches. it was unusable basically: mainly cuz had to soft reset everytime the screen times out.

    after hard reset I can now send and receive calls no problem (att L920phone but not att network). thanks for all the help.

    Now I just have to wait a while since all my apps are now reinstalling. will report any further problems with sim/att/phone app
    Last edited by kareem09; 04-11-2015 at 11:11 AM.
    04-11-2015 06:32 AM

Similar Threads

  1. Lumia 1020 w/ Default Camera App Issue
    By t.mehoves in forum Windows 10 Insider Preview
    Replies: 5
    Last Post: 04-19-2015, 12:11 PM
  2. Did you try win10 Build on Lumia 520?
    By I3unny in forum Windows 10 Mobile Insider Preview
    Replies: 20
    Last Post: 04-17-2015, 08:39 AM
  3. Anyone else getting this Error updating Windows 10 on 520?
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 04-12-2015, 03:57 AM
  4. 3 across on the front screen of my 630??
    By AaLF in forum Nokia Lumia 630
    Replies: 1
    Last Post: 04-10-2015, 10:23 PM
  5. Replies: 3
    Last Post: 04-10-2015, 09:57 PM
LINK TO POST COPIED TO CLIPBOARD