The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. cfscorpio's Avatar
    I have no data access and can't send MMS. I updated to Windows Phone 10 TP on my Lumia 920. I initially had the no SIM issue but did a Hard Reset to fix that. Now my SMS, WiFi and calling works fine. I read something about APN settings and tried a few configurations for T-Mobile but got nowhere.

    Anyone else having this problem or have an answer?
    04-12-2015 12:33 PM
  2. Harrie-S's Avatar
    For people upgrading their phone from Build 9941, there is a bug in which your phone's MMS settings will be lost after upgrade. The new Messaging app doesn't yet have the ability to re-enter these settings. You will need to use the Windows Phone Recovery Tool to go back to Windows Phone 8.1 and then upgrade to this build to get MMS working again.

    Here are the known issues in the new Windows 10 for phones 10051 build | Windows Central
    xandros9 likes this.
    04-12-2015 03:26 PM
  3. drtek's Avatar
    Thanks.
    Harrie-S likes this.
    04-12-2015 03:28 PM
  4. Wyn6's Avatar
    Well, I didn't upgrade from a previous build and had the No SIM/NO Data issue. After several hard resets, the SIM was detected, but I still had not data connection, although my phone showed an LTE signal.

    I tried to roll back to 8.1 which was borked for some odd reason. I then hard reset again, and 8.1 was back. I upgraded to 10 from that point, and chose to do a fresh install as opposed to restoring a backup. Then I went into the Settings and Extras and selected Access Point. I put the APN info in, which I had tried several times before, and I was then able to get a data connection.

    So, I hard reset again to restore my most recent backup, but it had been overwritten. I chose the one that was there and the no data connection issue returned. I hard reset AGAIN and chose my backup from December and all was well, minus 3 months of text messages.

    So, if you have this issue, do a hard reset, a fresh install, a hard reset and restore from a backup. Oh! And, do not select Backup the first time around or your most recent backup will be overwritten. Hope this helps someone.

    Lumia 925 also on T-Mobile.
    04-12-2015 06:51 PM
  5. cfscorpio's Avatar
    I didn't upgrade from Build 9941. I have a Lumia 920, that build wasn't even available for it. Will this idea help me at all? I already did a hard reset with a fresh install of TP10 build 10051.
    04-14-2015 08:20 AM
  6. WiseManWhite's Avatar
    I'm on T-mobile as will with a Lumia 925 and am having the same issues. I can make calls, but I can't send or receive SMS. I'll try your solution and will report back.
    08-04-2015 10:53 AM
  7. worldspy99's Avatar
    You need to input the APN settings for MMS and Internet manually.
    Please input the settings shown on T-Mobile website.
    Go to
    Settings > Network & Wireless > Cellular&SIM
    Slide data connection to On
    Tap on Cellular, then tap on Properties
    Scroll down on the screen and manually input Internet APN and MMS APN settings.
    I use fast.t-mobile.com on my Lumia 830 and works fine without any issues.
    Good luck.
    Last edited by worldspy99; 08-04-2015 at 11:11 AM.
    08-04-2015 10:58 AM

Similar Threads

  1. Downloading problem in speech and keyboard
    By anupkd13 in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 06-26-2015, 09:50 AM
  2. Why aren't my contacts showing in the People app in WP 10?
    By dharma teja1 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 04-16-2015, 05:45 AM
  3. New to forum and windows lumia 930
    By ap0calypto in forum Nokia Lumia 930
    Replies: 4
    Last Post: 04-12-2015, 08:18 PM
  4. Win 10 tp Lumia 830
    By Hasan Moursi in forum Ask a Question
    Replies: 2
    Last Post: 04-12-2015, 01:20 PM
  5. Microsoft Lumia 640 XL camera sample gallery
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-12-2015, 11:11 AM
LINK TO POST COPIED TO CLIPBOARD