08-05-2015 07:43 PM
74 123
tools
  1. nasellok's Avatar
    Hi all - really wanting to try out W10 preview - my Icon is my daily driver - please let us all know about your experience if you install - is it stabile, how's your battery life, is anything not working?

    Thanks!
    05-14-2015 12:29 PM
  2. Marko Marjanovic's Avatar
    Hey there friend, heres the tip: Never install preview on daily driver.
    msirapian likes this.
    05-14-2015 12:31 PM
  3. PRG270's Avatar
    I'll do it tonight. Wish me luck.
    05-14-2015 12:51 PM
  4. Blacklac's Avatar
    Hey there friend, heres the tip: Never install preview on daily driver.
    Truth. I loaded up on my 1020, which is just a gym music player, now. After limited use of a week or so, I had to revert back. Couldn't even use it reliably as a music device. I even freshly installed 8.1 prior. But I reverted, might try this new build out... :p
    05-14-2015 12:58 PM
  5. Matthias Verboven's Avatar
    Now prepairing to install on my 930, daily driver. I like to live dangerous and will let you know my experiences.
    Tafsern likes this.
    05-14-2015 01:10 PM
  6. JohnGalt1717's Avatar
    My Icon is stuck on "loading" after swiping to unlock....
    05-14-2015 01:27 PM
  7. Matthias Verboven's Avatar
    Welp, hope that doesn't happen to mine, still installing..
    05-14-2015 01:29 PM
  8. Martinspire's Avatar
    Also stuck on loading here. But i can hold back button but taskmanager is not really showing anything. I can get into notifications and via that into settings, but other then that i can't do anything. Not sure if hard-reset will fix
    05-14-2015 01:32 PM
  9. RSailer's Avatar
    Same problem here. No home screen, just: "Loading..."
    05-14-2015 01:36 PM
  10. Tepid's Avatar
    Installing now. Waiting at the gears screen.
    05-14-2015 01:42 PM
  11. maxpower818's Avatar
    Same here
    05-14-2015 01:42 PM
  12. Matthias Verboven's Avatar
    It's these moments I like about being a beta tester :) Will it work or not? It's like a gambling game haha. Mine's migrating now.
    05-14-2015 01:44 PM
  13. Kieta's Avatar
    I took the plunge too, migrating data right now
    05-14-2015 01:45 PM
  14. Jeffrey Davidson's Avatar
    I gave it a shot, and got stuck in a reboot loop. Doing a hard reset now.
    05-14-2015 01:47 PM
  15. fx45guy's Avatar
    Mine got stuck in an endless reboot too, after finishing up. Trying hard reset now.
    Me thinks this didn't get tested too well!
    05-14-2015 01:51 PM
  16. RSailer's Avatar
    Fingers crossed on the hard reset. Otherwise its back to 8.1 we go.
    05-14-2015 01:53 PM
  17. Matthias Verboven's Avatar
    From other thread:

    Mine works! :) After migrating I unlocked the phone and got the loading screen like three times, now on homescreen.

    I hope to all whos phone doesn't work you'll find a way to fix it.
    05-14-2015 01:55 PM
  18. donkiluminate's Avatar
    Installed and have been playing with it over lunch. Once my lunch break is over I'll be going back to my desk and reverting back to 8.1
    05-14-2015 02:15 PM
  19. Martinspire's Avatar
    Just let it go for quite some time and my startscreen is back. No hard reset required! Just let it load for many minutes and your golden
    05-14-2015 02:19 PM
  20. hossam hammouri's Avatar
    Can't find build 10080 (LUMIA 640XL)
    05-14-2015 02:22 PM
  21. Bashar Awwad's Avatar
    I advise you not to install it..I did on mine and now its stuck in a reboot loop. Should never have installed it..
    05-14-2015 02:30 PM
  22. maxpower818's Avatar
    How you liking it?
    05-14-2015 02:40 PM
  23. donkiluminate's Avatar
    HA! Hows this for a bug/user error? So I was reading that doing a hard reset would help with some issues with the phone so I did a hard reset. What happened is hilarious. I cant help but laugh. So my 930 is from Thailand(?) and after the hard reset was done I was asked to set my language and region. Well, I would hit the little box to bring up the list of possible languages and every single time I tried to scroll to English the list of languages disappeared. After doing this five times I somehow set the language in Thai(or probably Chinese) and now my phone is in a language I cant read. Hopefully I can fumble my way through the settings to change the language
    05-14-2015 02:49 PM
  24. Alexandre Sebrao's Avatar
    I advise you not to install it..I did on mine and now its stuck in a reboot loop. Should never have installed it..


    Same problem here, how u did a hard reset?
    05-14-2015 02:49 PM
  25. Matthias Verboven's Avatar
    How you liking it?
    For me it's quite stable. One major bug that is annoying me: when setting a background picture behind the tiles, and when I make the tiles transparent, half of my picture is black, the other half displays a cropped picture.

    Funfact: 'old' WP8.1 apps launch faster than before, no resuming.

    Other little bug: the tiles of official apps by MS, and some other from the store, have a fussy logo on it.
    05-14-2015 02:50 PM
74 123

Similar Threads

  1. Win 10 Tech Preview Notification!!
    By jasqid in forum Windows 10 Mobile Insider Preview
    Replies: 15
    Last Post: 06-15-2015, 04:02 AM
  2. Digicel ROM for a Lumia 625?
    By anguilla1980 in forum Nokia Lumia 625
    Replies: 2
    Last Post: 05-14-2015, 02:57 PM
  3. Windows 10 Insider Preview 10080 build for phone is now available!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-14-2015, 12:11 PM
  4. Digicel ROM for a Lumia 625?
    By 92GTA in forum Windows Phone 8.1
    Replies: 0
    Last Post: 05-14-2015, 11:55 AM
LINK TO POST COPIED TO CLIPBOARD