The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
06-25-2015 06:47 PM
84 1234
tools
  1. xrs22's Avatar
    I got this action...well it'd be nice if I can get to my albums to show my half *** start screen.
    Lord Icon
    05-14-2015 07:20 PM
  2. mikeofthegarden's Avatar
    I'm getting the constant "Loading" screen as well. I wish I could go to Settings and do a hard reset, but when I hit Settings in the Action Center, it just goes back to Loading...
    05-14-2015 07:29 PM
  3. DavidinCT's Avatar
    Hmmm....Although I want to play, I NEED my phone to be available 24 hours a day. Crap, seems too buggy for me to try...When about 90% of the posts here are in a reboot loop or the tiles just don't work right and removing exchange data ? DAM ! Not even close to prime time yet, huh ?

    I guess I cant touch it right now :(

    CRAP, been waiting for this for a while too...
    aximtreo likes this.
    05-14-2015 08:05 PM
  4. Owen Dugmore's Avatar
    Definitely waiting for the final release. The Icon is my daily driver and I can't afford the risk. Keep us posted :)
    05-14-2015 08:18 PM
  5. DavidinCT's Avatar
    Definitely waiting for the final release. The Icon is my daily driver and I can't afford the risk. Keep us posted :)
    I'm not sure about the final, because that would be a Verizon thing and if getting Cyan/Denim was any clue, we'll be the last to get it.

    Maybe when it hits to be a little more bug free, I might. I just need my phone to work and I don't want to hard reset it now.
    05-14-2015 08:21 PM
  6. bulls96's Avatar
    Definitely waiting for the final release. The Icon is my daily driver and I can't afford the risk. Keep us posted :)

    Same boat as you.
    05-14-2015 08:22 PM
  7. mhc48's Avatar
    I've got the sister 930 and the download and installation seemingly went fine. Except that I have everything except the two things I most use: Outlook Calendar and Outlook Mail. I've got Contacts, and appointments show up on the screen, but the tile doesn't open either program. Calendar looks like it's opening, says loading and then returns to the tile screen. Also I've got a OneNote Tile (with gibberish as a title) but it doesn't open.
    aximtreo likes this.
    05-14-2015 08:46 PM
  8. sweatshopking's Avatar
    Can not get any lte data on my icon NO MATTER WHAT. claims LTE in the top, it's turned on in the sim menu, but doesn't work. I'm on Bell in Canada with it, and never had any issues with 8.1. doesn't work at all, and 2 hard resets later, completely clean starts with no backups and still no luck. manually entered my apn, tried using automatic settings, still no data. No idea why. Turned it off and on, still no luck.
    05-14-2015 09:17 PM
  9. psiu_glen's Avatar
    Did this cycle through 8.1 Update 2 on the way to 10? And has anyone tried it out, any problems? I would actually prefer that version I think.
    05-14-2015 09:17 PM
  10. cory1717's Avatar
    I'm on Verizon how do I get the preview. I have the insider on the fast ring . Don't see where I can download it
    05-14-2015 11:02 PM
  11. AskaLangly's Avatar
    I'm on Verizon how do I get the preview. I have the insider on the fast ring . Don't see where I can download it
    After choosing the method, check for updates like normal. Beware, though...
    05-15-2015 12:34 AM
  12. Ankit Gupta2's Avatar
    Installed on my L930. it first updated to 8.1 update 2 which went fine. But then W10 started and now I am getting a blank start screen, no Loading message, no action center. Can receive calls, and volume rocker pop down comes up. but that's it am leaving it for an hour, will update if anything come up.
    05-15-2015 02:15 AM
  13. juan6996's Avatar
    Hey guys. I wrote about my experiences updating my Icon, and some problem-solving including how to prevent the boot loop and how to get your tiles back: HiImJayC comments on Windows 10 Insider Preview Build 10080 for phone now available
    05-15-2015 06:01 AM
  14. GreenScrew's Avatar
    I can report that I didn't have any problems installing. Do far, issues are:
    1. Getting to stay screen is slow, sits at "loading..." For a few seconds.
    2. I had 3 start screen folders; one works fine but was mislabeled with the name of another, the other two have disappeared and the apps contained in them can't be pinned to start (as if they already are pinned but they can't be found).
    3. It's a bit slow/laggy/not smooth
    There are other sniggles but so far these are the most significant

    On the plus side:
    LOVE the new OneNote app
    Like Xbox music beta
    Like the start screen background/transparency look
    Like the dark theme
    Like the settings and notifications
    All settings seem more intuitive
    05-15-2015 06:14 AM
  15. Julien Friede's Avatar
    Hey,
    anybody tried to reset the Lumia Icon/930 to factory Defaults after installing Windows 10 ( want a clean install of Windows 10) ?
    05-15-2015 06:23 AM
  16. GreenScrew's Avatar
    I can report that I didn't have any problems installing. Do far, issues are:
    1. Getting to stay screen is slow, sits at "loading..." For a few seconds.
    2. I had 3 start screen folders; one works fine but was mislabeled with the name of another, the other two have disappeared and the apps contained in them can't be pinned to start (as if they already are pinned but they can't be found).
    3. It's a bit slow/laggy/not smooth
    There are other sniggles but so far these are the most significant

    On the plus side:
    LOVE the new OneNote app
    Like Xbox music beta
    Like the start screen background/transparency look
    Like the dark theme
    Like the settings and notifications
    All settings seem more intuitive
    Also:
    Some tiles on start screen are blurry (crystal clear on lower rest 830)
    Start screen background is compressed leaving right 3rd black (only an issue in full setting, change background to tiled is OK).
    Unable to hit the ellipse in Internet Explorer (Spartan to the rescue?) seems due to scaling

    I'll keep adding as I find. I think I'm going to do a hard reset after work today and see if that changes any experiences. At this point, its bearable for me on my daily driver but its a bit early in the assessment phase.
    Last edited by GreenScrew; 05-15-2015 at 07:00 AM.
    05-15-2015 06:47 AM
  17. GreenScrew's Avatar
    Changing Start background to tiled has also resolved the performance issue when loading/returning to Start. So highly recommend changing this setting to tiled for a much better and more smooth/responsive experience!!
    05-15-2015 07:05 AM
  18. Ben Fulks's Avatar
    I was having issues with Start screen folders. once i got rid of mine (annoyed by that) the loading of the start screen MOSTLY stopped. there are still some hang ups, but its not terribly often. I also can't create new folders...idk what that's about.


    P.S. on full background, I like the transparent look.
    05-15-2015 09:24 AM
  19. Mark_Twain007's Avatar
    When I first installed I got the endless loading loop. It also destroyed my battery. I went from 50% to dead in 2ish hours. Eventually, I got the pull down notification area to work, and used that to get to a hard reset, which went better. As standard, the icons are huge, if I use the setting to make them smaller they are really small. Email seemed to work, but now won't download any new emails. Apps crash sometimes. I'm liking the new look and setup of everything, but if you need to keep using your phone I would not recommend the upgrade. Does anyone know a way to get your phone back to 8.1?
    05-15-2015 10:49 AM
  20. jrdatrackstar1223's Avatar
    I tried going back to 8.1 Denim with Windows Recovery Tool on my Icon and now internet radio is bricked. Have no clue how to fix it. It sucks because I was trying to avoid installing 10 on my Icon but it pulled down the update automatically because I forgot to disable Windows Insider....
    05-15-2015 11:05 AM
  21. antonius138's Avatar
    Anyone have any luck syncing a second account to the new Outlook mail app? I have a second outlook.com account that I can add but it never sync's and this secondary account I use more often and it has all of my contacts.

    UPDATE: Fixed. For anyone who might have had this issue, the fix is to install any other outlook.com account as an "Exchange" account and it will finally sync.
    Last edited by antonius138; 05-15-2015 at 02:42 PM. Reason: Updated
    05-15-2015 11:16 AM
  22. Grim Santo's Avatar
    Is anybody ICON running hot since installing beta?
    05-15-2015 11:23 AM
  23. TrueMetalGeek's Avatar
    Well mine took the update last night.
    It took a LONG time and I thought it was stuck in a loop. But eventually it did finish.
    The start screen was buggy and didn't see it until I slid down the screen to get to settings and went back to home.

    The first thing I noticed bad is that my contacts seem to be gone and I can not figure out how to import from a past save.
    I clicked SYNC contacts and that seemed to sync what I had now in the phone.
    Looks like it isn't downloading from Verizon's backup assistant properly.

    Now that I played with the "Show more tiles" option in the start menu settings I am not getting the start menu to come back. I just get a LOADING screen. :-/

    Maybe I will do a hard reset which I have not done yet.

    Some things look pretty cool but some things are buggy.
    05-15-2015 11:26 AM
  24. PANTHERGM's Avatar
    I got the notice about 11:30 AM (MST) fr the new 10 update. I said okay. I had issues with the upgrade and eventually it finished. I couldn't get my start menu (Live tiles) but could get into settings. that is about as far as I got. I finally had to do a Hard Reset in order to get the phone working again. Thank Goodness I had backed it all up before. When I finally got it up working the batter was low (Below 30%) and the phone was SUPER SLOW to respond to what I wanted it to do. Finally, I tried restoring all my apps via the windows store, but it said my phone couldn't be reached. I was able manually reinstall a download the apps. (Just a Few) The Verizon backup did not w to work. Email accounts, are all grouped into one tile. I looked to see if I could set Specific tiles for specific accounts. I had no luck with this. I also have had to do several soft resets of the phone. My advice is if this your primary means of communication. wait for a more stable version to come out.
    05-15-2015 12:03 PM
  25. jrdatrackstar1223's Avatar
    Can not get any lte data on my icon NO MATTER WHAT. claims LTE in the top, it's turned on in the sim menu, but doesn't work. I'm on Bell in Canada with it, and never had any issues with 8.1. doesn't work at all, and 2 hard resets later, completely clean starts with no backups and still no luck. manually entered my apn, tried using automatic settings, still no data. No idea why. Turned it off and on, still no luck.
    Had the same exact same issue as yours to the 'T'. It sucks, but the only way I got it to work was to switch my Straight Talk profile to spare SIM I had. I then put that SIM into my phone, the Icon ran the Windows Phone 8.1 LTE SIM registration, and my internet worked again.
    05-15-2015 12:25 PM
84 1234

Similar Threads

  1. hi my lumia 1320 is acting crazy,
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 05-14-2015, 07:50 PM
  2. Have Installed Windows 10 but Reverts to Version 8.1
    By tallarob in forum Windows 10 Insider Preview
    Replies: 2
    Last Post: 05-14-2015, 03:13 PM
  3. Lumia 530 Sad Face on Windows 10 Update
    By tohoshinki in forum Microsoft Lumia 530
    Replies: 1
    Last Post: 05-14-2015, 02:31 PM
  4. Telltale won't release Walking Dead Season 3 in 2015, but 'something major' is coming soon
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-14-2015, 02:11 PM
  5. Exclusive: More updates and Xbox upgrades coming to Windows Phone titles from Gameloft
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-14-2015, 02:00 PM
LINK TO POST COPIED TO CLIPBOARD