05-16-2015 07:29 AM
31 12
tools
  1. Krystianpants's Avatar
    region has to match language.

    I had the same problem had canada as language united states as region. Changed language to united states and fixed problem.
    05-15-2015 02:24 PM
  2. Wurstsalat's Avatar
    Same Problem here
    Region Germany
    language german (Germany)

    So this cant be the issue for me

    Hard reset changed nothing, skype was downloading a bit but didnt finished....nothing seems to help for me at the Moment.


    Lumia 920
    05-15-2015 04:34 PM
  3. Gravity oXo's Avatar
    Not sure if this is the cause, but I had the same problem and I checked the original store. Turns out I had several updates going. Once they were done, the beta store let me install apps and no longer got stuck at the "Working...". You guys may check to see if the old store is downloading or has anything pending.
    05-15-2015 11:13 PM
  4. ncbartschi's Avatar
    Honestly I think it may be more of a connection issue. I've installed several apps from the store with no problem. I occasionally get the "working" status. After just leaving it alone for a few hours, it installs fine.
    hotphil likes this.
    05-16-2015 12:12 AM
  5. Vasrias's Avatar
    I was going to post "same here", and suddenly it works :O
    I let it over night "working...", but it did nothing. Then I read here, closed the Store Beta app, opened the normal Store app, checked for updates (it had nothing to install), closed Store, opened Store Beta and tried again and now it's downloading.
    The only thing that could have done the trick is opening the normal Store before trying to download on Store Beta.
    05-16-2015 04:19 AM
  6. Julien Friede's Avatar
    Same here, it works now :)
    05-16-2015 07:29 AM
31 12

Similar Threads

  1. WIndows 10 is now avaiable for the ICON, What issues do you have ?
    By DavidinCT in forum Windows 10 Mobile Insider Preview
    Replies: 83
    Last Post: 06-25-2015, 06:47 PM
  2. Phone doesn't stop to reboot Windows 10 10080 build
    By Alexandre Sebrao in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 05-16-2015, 12:05 PM
  3. [10080] Can't find build 10080 (LUMIA 640XL)
    By hossam hammouri in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 05-15-2015, 10:34 AM
  4. [10080] Can't find Store beta and new mail app (L930)
    By Dennis Bakker in forum Windows 10 Mobile Insider Preview
    Replies: 6
    Last Post: 05-15-2015, 10:21 AM
  5. Lumia 530 Sad Face on Windows 10 Update
    By tohoshinki in forum Microsoft Lumia 530
    Replies: 1
    Last Post: 05-14-2015, 02:31 PM
LINK TO POST COPIED TO CLIPBOARD