The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
05-16-2015 07:29 AM
31 12
tools
  1. janbures12's Avatar
    Does anyone else encounter this? Whenever I want to download an app in the Store beta, I actually never get to download anything, it just says "working..." for minutes for both Office and the Music Preview and Video Preview apps
    05-14-2015 02:39 PM
  2. Matthias Verboven's Avatar
    Same here, doesn't seem to install anything.
    05-14-2015 02:53 PM
  3. wpfanboy17's Avatar
    Store(Beta) always says "The server stumbled - We all have bad days" for me
    05-14-2015 03:48 PM
  4. ncbartschi's Avatar
    I've managed to install several Office preview apps, as well as Music Preview. I did a hard reset, although not because of the store issue.
    05-14-2015 03:49 PM
  5. yves707's Avatar
    i have the same problem. can't install any store beta apps
    05-14-2015 04:34 PM
  6. tk-093's Avatar
    I got all three of the office preview apps installed as well as the Music Preview.
    Verizon 928 over cellular, FWIW. Don't know why it would be a WiFi thing though....
    05-14-2015 04:40 PM
  7. brad4560's Avatar
    can't install anything, lumia 635 hard reset. just says acquiring license, office app previews and one note
    05-14-2015 05:31 PM
  8. insert92's Avatar
    i have same issue.
    05-14-2015 05:41 PM
  9. crunchtime85's Avatar
    Same issue here, could not resolve it so far...
    05-15-2015 02:09 AM
  10. Florin_Anghel's Avatar
    ALL: Set your regional format to US & location to US and store beta will install apps, it will not hang on "working"
    SLMalling likes this.
    05-15-2015 02:40 AM
  11. elrohlik's Avatar
    Same here (Lumia 1520), a was able to launch it trough search button. (i dont have cortana because i have Czech region). Just hit search button, right down store beta, then first green line should be Store (Beta) modern application. Then you cvan search for excel and other preview stuff. Hope that helps
    05-15-2015 02:49 AM
  12. Akash Patel's Avatar
    Was able to install all three of the office preview apps and xbox app without issue on my L520
    05-15-2015 03:00 AM
  13. gmocnik's Avatar
    I have change regional settings to US and now working... is gone, but now all apps are Pending.
    Haven't done hard reset yet and I have apps on SD card.
    All transfers should be seen in action center.
    05-15-2015 04:21 AM
  14. hotphil's Avatar
    Shouldn't need to change Regional settings...Worked fine on my handset. And many others. Changing Region can break other stuff too.
    05-15-2015 04:37 AM
  15. Wbutchart1's Avatar
    Mines kept saying pending for any app downloads, kept closing the app via multitasking eventually it randomly started downloading the apps, have managed to install a few but its never simple at the moment.
    05-15-2015 05:03 AM
  16. svaethier's Avatar
    Mines kept saying pending for any app downloads, kept closing the app via multitasking eventually it randomly started downloading the apps, have managed to install a few but its never simple at the moment.
    The new store did just come out yesterday,they'll fix these bugs and improve it as time goes by I'm sure of.
    05-15-2015 05:36 AM
  17. Matthias Verboven's Avatar
    It's working for me now, I kept my region settings to Belgium.
    05-15-2015 05:46 AM
  18. hotphil's Avatar
    Mines kept saying pending for any app downloads, kept closing the app via multitasking eventually it randomly started downloading the apps, have managed to install a few but its never simple at the moment.
    So, no issue then. Pending means pending. If you won't wait and choose to over-complicate by force-killing etc, then you can't really complain about simplicity.
    05-15-2015 06:06 AM
  19. gmocnik's Avatar
    Did hard reset, and have set regional to US, now it even showed some progress on donwloading, but haven't really installed an app yet :(
    05-15-2015 06:17 AM
  20. Julien Friede's Avatar
    I was able to install Apss like Shazam, Facebook and Netflix from the new Beta Store. Xbox, Word and Excel always hangs on "working..."

    I Think it is a Region Problem (I'm using an European Market)
    05-15-2015 06:27 AM
  21. yves707's Avatar
    i have exactly the same problemm. but if it was a regional problem it should work after changing the region to us. but it still doesn't...

    hard reset didn't make a difference
    Last edited by yves707; 05-15-2015 at 06:59 AM.
    05-15-2015 06:37 AM
  22. Wbutchart1's Avatar
    So, no issue then. Pending means pending. If you won't wait and choose to over-complicate by force-killing etc, then you can't really complain about simplicity.

    I think you need to re read what i wrote to try and download apps.....
    05-15-2015 06:41 AM
  23. gmocnik's Avatar
    I've installed OneNote for now, Excel is in progress ...
    05-15-2015 07:06 AM
  24. hotphil's Avatar
    I think you need to re read what i wrote to try and download apps.....
    if it doesn't read well, you could always re-phrase it.
    05-15-2015 07:32 AM
  25. Wbutchart1's Avatar
    if it doesn't read well, you could always re-phrase it.
    It reads fine, it's your interpretation of it that is suspect.
    05-15-2015 07:34 AM
31 12

Similar Threads

  1. WIndows 10 is now avaiable for the ICON, What issues do you have ?
    By DavidinCT in forum Windows 10 Mobile Insider Preview
    Replies: 83
    Last Post: 06-25-2015, 06:47 PM
  2. Phone doesn't stop to reboot Windows 10 10080 build
    By Alexandre Sebrao in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 05-16-2015, 12:05 PM
  3. [10080] Can't find build 10080 (LUMIA 640XL)
    By hossam hammouri in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 05-15-2015, 10:34 AM
  4. [10080] Can't find Store beta and new mail app (L930)
    By Dennis Bakker in forum Windows 10 Mobile Insider Preview
    Replies: 6
    Last Post: 05-15-2015, 10:21 AM
  5. Lumia 530 Sad Face on Windows 10 Update
    By tohoshinki in forum Microsoft Lumia 530
    Replies: 1
    Last Post: 05-14-2015, 02:31 PM
LINK TO POST COPIED TO CLIPBOARD