1. Coan's Avatar
    Loaded the update yesterday from 8.1, using a rogers 920 (as a canadian). When I had the loading...issue before my hard reset, it still functioned. Today I've tried changing between cn/uk/us and done the restart and soft resets and updated my country/region in account.live.com

    I do notice the icon difference between UK and US regions.

    Anyone else got any workarounds or am I stuck until they extend support to the "alpha" regions in new builds?
    05-15-2015 02:31 PM
  2. BaritoneGuy's Avatar
    I haven't done the W10 thing yet but Cortana in Canada sucks. I switched my phone to US and Cortana is much, much better. Even for Canadian things.
    05-15-2015 04:30 PM

Similar Threads

  1. [L1520] Update error 0x80244015?
    By Byu1 in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 05-15-2015, 03:59 PM
  2. Build 10080 on my lumia 1520 does not have Spartan, has anyone been able to fix this?
    By theolympusguy in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 05-15-2015, 02:57 PM
  3. How can I hard reset my phone?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-15-2015, 02:03 PM
  4. Bing Images in Windows Phone
    By Qaddafi in forum Windows Phone 8.1
    Replies: 1
    Last Post: 05-15-2015, 01:54 PM
  5. The latest Cortana server-side updates offer fun with riddles and trivia
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-15-2015, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD