1. Gregory Whatley's Avatar
    I've been trying all week to update my Lumia Icon (running build 10080) to the newest build (10149), but Phone Update keeps reporting that my device is up-to-date (obviously, it is not). I skipped build 10136 because I didn't want to revert back to Windows Phone 8.1, hoping to update directly when the next build is released, but again, Phone Update says the device is up-to-date. Has anyone else seen this? Is there a workaround? I want to avoid reverting back to 8.1 if at all possible (I will do that if it is the only choice I have).

    Thanks
    06-30-2015 06:57 PM
  2. mijacs's Avatar
    Go into the windows insider app and make certain that you are setup for the fast ring.
    06-30-2015 07:10 PM
  3. Gregory Whatley's Avatar
    Go into the windows insider app and make certain that you are setup for the fast ring.
    I've done that several times. This is strange because my Lumia 1520 is downloading the update now, and my Lumia 635 is already running it. Each phone is connected to the same network.
    06-30-2015 10:08 PM
  4. TerjeForsund's Avatar
    Hi, did you get a solutions to this? I have 10080 on my 1520, not beiing able to Upgrade it......
    07-01-2015 12:32 PM
  5. Lost_Cosmonaut's Avatar
    I was having the same problem, I believe I was on 10136, but every time I went to Update, it said I had the latest version. Played with the Insider app, made sure everything was signed in, soft reset and hard reset several times, no go. Finally plugged it in to my computer and rolled back to 8.1 and tried again and it worked, now I'm on 10149 and it's way way way better.

    I know it's not the easiest solution, but it seems like rolling back to 8.1 and trying again kickstarts it and makes it work.
    07-02-2015 01:02 PM
  6. Charles Brown8's Avatar
    I was having the same problem, I believe I was on 10136, but every time I went to Update, it said I had the latest version. Played with the Insider app, made sure everything was signed in, soft reset and hard reset several times, no go. Finally plugged it in to my computer and rolled back to 8.1 and tried again and it worked, now I'm on 10149 and it's way way way better.

    I know it's not the easiest solution, but it seems like rolling back to 8.1 and trying again kickstarts it and makes it work.
    Same here I was stuck with 080 qued for download and had to roll back to 8.1 then re-enroll in fast ring to get 149. No problems just time consuming. Luck with it hehe.
    07-02-2015 01:24 PM

Similar Threads

  1. How to update windows 10 builds?
    By sunno111 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 07-01-2015, 01:26 AM
  2. Windows Phone App stuck on pending
    By zunaer in forum Ask a Question
    Replies: 2
    Last Post: 07-01-2015, 01:23 AM
  3. Build 10149: where does archived email go?
    By E D B in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 06-30-2015, 06:42 PM
  4. In Windows 10 preview, is there a way to reset all settings to default?
    By Windows Central Question in forum Windows 10 Insider Preview
    Replies: 1
    Last Post: 06-30-2015, 05:53 PM
  5. Can't change desktop background pic on 10158
    By buffalosolja in forum Windows 10
    Replies: 0
    Last Post: 06-30-2015, 05:51 PM
LINK TO POST COPIED TO CLIPBOARD