1. onysi's Avatar
    It updated earlier with the latest and since I have dev preview, I literally get the latest.

    So the phone updated, restarted, and now its stuck on a loop. "NOkia", then "Tmobile".. and it keeps repeating.

    I tried the phone reset: power and up volume, or was it camera shutter? I need to reset this phone if I can.

    Any help will do thank you.
    07-03-2015 05:15 PM
  2. Zulfigar's Avatar
    Hard reset (erases all data on the phone) : Do a soft reset, but don't release the Volume Down button (you should see a large exclamation point) press (in order) Volume Up, Volume Down, Power, Volume Down and that will do a hard reset.

    Good luck!
    Mogamy Cool and onysi like this.
    07-03-2015 05:19 PM
  3. onysi's Avatar
    I think the problem was it didn't have enough charge. I plugged it in just now and its back on installing.
    07-03-2015 06:04 PM
  4. Zulfigar's Avatar
    That's even better then! :D
    onysi likes this.
    07-03-2015 07:36 PM
  5. onysi's Avatar
    it also did a reset, but its okay. this 512mb phone is really laggy with w10. its just a dummy phone to test out w10. thanks for the help
    07-03-2015 08:12 PM
  6. ajaya p's Avatar
    it also did a reset, but its okay. this 512mb phone is really laggy with w10. its just a dummy phone to test out w10. thanks for the help
    same problem with me. Please help me. How to solve it?
    07-03-2015 08:48 PM

Similar Threads

  1. Where can I buy a Lumia 640 LTE XL dual sim?
    By Windows Central Question in forum Microsoft Lumia 640 XL
    Replies: 6
    Last Post: 07-10-2015, 07:13 AM
  2. Lumia Icon & the "coming soon" Lumia 940
    By Tullphan in forum Nokia Lumia Icon
    Replies: 5
    Last Post: 07-09-2015, 05:11 PM
  3. Replies: 7
    Last Post: 07-04-2015, 10:39 AM
  4. Replies: 3
    Last Post: 07-04-2015, 04:20 AM
  5. Why does my Samsung S3 screen go blank?
    By Windows Central Question in forum Android Phones
    Replies: 2
    Last Post: 07-03-2015, 04:10 PM
LINK TO POST COPIED TO CLIPBOARD