1. Addison's Avatar
    Anyone know how to get bluetooth to work on the latest build? I'm trying to sync data from my band... I open the MS Health app and it just crashes; if I try to connect the band via bluetooth it will automatically disconnect it as well. Dealbreaker as I need to sync my fitness data up every day... hope someone knows a workaround!
    07-12-2015 08:07 AM
  2. TiLoBrown's Avatar
    This literally just helped me 5 minutes ago (mostly) http://forums.windowscentral.com/mic...-band-yet.html

    Only problem is that it still wont display my band's name
    Addison likes this.
    07-12-2015 08:15 AM
  3. joao91's Avatar
    For me, Bluetooth is still not working, both with my wireless charging plate and my car. The connection only holds for 5 seconds and then drops
    07-12-2015 08:20 AM
  4. eds817's Avatar
    I installed 10166 on top of Win8.1, no hard reset. Bluetooth is working fine with my car and my Surface Pro3.
    07-12-2015 10:20 AM
  5. Teo Bartulovic's Avatar
    Just briefly tested it in my car, no problems at all...
    07-12-2015 10:23 AM
  6. horseybob's Avatar
    Merrily listening to Pandora on my Bluetooth headset. Installed from 8.1, hard reset. Better range than in 8.1 even.
    07-12-2015 03:05 PM
  7. Addison's Avatar
    Me personally, I just had to reinstall ms health app. Working fine now!
    07-12-2015 10:09 PM
  8. michail71's Avatar
    Just briefly tested it in my car, no problems at all...
    ??

    Are you getting track info, pause, previous and skip? From what I can tell Bluetooth hasn't been touched since the initial Win 10 release. Cortana sometimes goes a bit insane on the text messages, much like when she lost in in Halo.
    07-12-2015 10:50 PM
  9. Teo Bartulovic's Avatar
    Not getting track info anyway because of the car interface but skipping tracks forward works fine while situation with going backward isn't that brilliant...but works :)
    07-12-2015 11:09 PM
  10. Sedp23's Avatar
    Working fine for me using my headset right now
    07-12-2015 11:38 PM
  11. michail71's Avatar
    Not getting track info anyway because of the car interface but skipping tracks forward works fine while situation with going backward isn't that brilliant...but works :)
    I get full functionality on my head unit with 8.1 but on 10 it's just simple audio pass-through. Looking at feedback it seems to be VW, BMW, Audi and Ford users complaining.
    07-13-2015 01:05 PM
  12. anon(9422676)'s Avatar
    Do a factory reset and it will solve the problem
    07-13-2015 02:19 PM
  13. Ozone06's Avatar
    Blue tooth is fine for my headphone and my car but when I try to connect my band it connects for 3-5 seconds then dropps. MS health also dies right away.

    I found a workaround by installing the MS band sync app on my PC. Found here: Download Microsoft Band Sync app for Windows from Official Microsoft Download Center

    You just attach the charge cable and it syncs. I'm going to be rolling back my 920 to 8.1 I miss my notifications and being able to reply from my wrist too much.
    07-29-2015 03:05 PM
  14. Rohit Janga's Avatar
    I'm also experiencing the same problem, Bluetooth connects only for 5 seconds then disconnects..
    08-09-2015 01:44 AM

Similar Threads

  1. Replies: 12
    Last Post: 08-10-2015, 12:49 AM
  2. Why isn't my Lumia 520 not downloading the 10166 build update?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 5
    Last Post: 07-23-2015, 09:42 AM
  3. Black Screen Of Death After Hard Reset on Build 10166
    By Mark863 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 07-13-2015, 09:31 AM
  4. What is the best benchmarking app on WP and Android?
    By Darius_520 in forum General Phone Discussion
    Replies: 3
    Last Post: 07-13-2015, 04:16 AM
  5. Replies: 0
    Last Post: 07-12-2015, 05:28 AM
LINK TO POST COPIED TO CLIPBOARD